Results 1 to 4 of 4

Thread: Driver AFD.SYS in not loading properly and getting booting error

  1. #1
    Join Date
    Dec 2011
    Posts
    27

    Driver AFD.SYS in not loading properly and getting booting error

    If I start my computer then it will simply hang at the microsoft loading screen. So, I have to boot up in safe mode and then restart my pc to get Windows desktop. I have already reinstalled all the drivers in my pc for lan and graphics card but still the problem persist. When I checked a boot log then I saw the main problem that is listed there states that "Did not load driver AFD.SYS". Can anyone tell me how do I solve this issue? Thanks

  2. #2
    Join Date
    Aug 2011
    Posts
    2,186

    Re: Driver AFD.SYS in not loading properly and getting booting error

    The AFD.SYS error that you are getting is a part of Winsock. It is used to provide access to the rest of the network stack for apps and different components of the operating system. If it is not there then mail clients and web browsers will not work. When you boot in safe mode then does the computer boot without any errors? Have you got the Vista DVD or is it an OEM OS that came preinstalled?

  3. #3
    Join Date
    Aug 2011
    Posts
    1,855
    Try to perform a clean startup and see if that works. Follow the below steps and see if that works:

    1. In the System Configuration Utility dialog box, click Selective Startup on the General tab.
    2. Click to clear the Load Startup Items check box.
      Note The Use Original Boot.ini check box is unavailable.
    3. Click the Services tab.
    4. Click to select the Hide All Microsoft Services check box.
    5. Click Disable All, and then click OK.
    6. When you are prompted, click Restart.

  4. #4
    Join Date
    Aug 2011
    Posts
    1,948
    Will you be able to post some information about the boot log here? I am not quite sure that the failure to initialise afd.sys is by itself causing your boot problems. It seems to be more side effect than the real problem. Do you get any warnings as well or any errors in the system event log when you are getting one of these booting problem.

Similar Threads

  1. Replies: 8
    Last Post: 31-12-2011, 01:27 PM
  2. Fedora 8 not booting properly
    By Sirens in forum Operating Systems
    Replies: 3
    Last Post: 16-11-2010, 10:04 AM
  3. Motorola phone is not booting up properly.
    By Arumugan in forum Portable Devices
    Replies: 5
    Last Post: 22-04-2010, 02:51 AM
  4. Vista not booting properly Compbatt.sys error
    By priya22 in forum Operating Systems
    Replies: 1
    Last Post: 15-04-2010, 04:45 PM
  5. Error loading cmicnfg.cpi sound driver
    By Charlie R in forum Windows XP Support
    Replies: 2
    Last Post: 16-08-2008, 03:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •