Go Back   TechArena Community > Software > Operating Systems
Become a Member!
Forgot your username/password?
Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



Ubuntu Unity panel sitting behind top Gnome shell panel

Operating Systems


Reply
 
Thread Tools Search this Thread
  #1  
Old 06-02-2012
#4 #4 is offline
Member
 
Join Date: Jan 2012
Posts: 84
Ubuntu Unity panel sitting behind top Gnome shell panel
  

First I have installed the Unity panel and updated it. After that I have installed the Gnome Shell. If I am going to change the theme and make it as transparent one, I can see that Unity panel sitting behind the top gnome panel. Does anyone know what that is? Is there any kind of setup to change it?

Reply With Quote
  #2  
Old 06-02-2012
Member
 
Join Date: Feb 2010
Posts: 701
Re: Ubuntu Unity panel sitting behind top Gnome shell panel

I was also seeing the same thing when I have installed both in my computer. It mostly appears when I was using the "compiz" as window manager chosen from "compiz fusion". I don?t know what is causing this in your computer but in my case, it was only showing unity panels. I was not getting gnome panel's even I was in gnome desktop. It looks like a known issue.
Reply With Quote
  #3  
Old 06-02-2012
Member
 
Join Date: Feb 2010
Posts: 796
Re: Ubuntu Unity panel sitting behind top Gnome shell panel

It seems to me that in your case the Unity global menu stuff might have been affecting gnome-shell panel. To resolve this, just run the following command in the terminal Window:
Code:
echo '[ "$DESKTOP_SESSION" != "ubuntu" ] && unset UBUNTU_MENUPROXY' | sudo tee /etc/X11/Xsession.d/81ubuntu-menu-proxy
The system will log out and log in back automatically. Don?t worry this will not change Ubuntu (Unity) session stuff.
Reply With Quote
  #4  
Old 06-02-2012
Member
 
Join Date: Feb 2010
Posts: 658
Re: Ubuntu Unity panel sitting behind top Gnome shell panel

I hope that you are using the Ubuntu 11.10. I have heard that this version brings a lot of changes regarding the Unity features and some of them are chameleon theme, active blur, launcher opacity, relocation of the Ubuntu button. You can from move the buttons from the panel to the launcher. Due to these new features, now you can do lots of customization in Unity as you like.
Reply With Quote
  #5  
Old 06-02-2012
Member
 
Join Date: Feb 2010
Posts: 669
Re: Ubuntu Unity panel sitting behind top Gnome shell panel

Recently Ubuntu users told that Ubuntu's Unity desktop environment has made them controversy and put the users into a loop. Due to its ability of customization you can do lot of thing in it. For you that you need to play around different settings. If you want to make the transparent Unity panel, then push the Windows button from keyboard and search for "compiz." Now click settings manager and locate "ubuntu unity plugin.". Choose the experimental tab and move the slider named?panel opacity? as you need.
Reply With Quote
  #6  
Old 06-02-2012
Member
 
Join Date: Feb 2010
Posts: 546
Re: Ubuntu Unity panel sitting behind top Gnome shell panel

There is a good but little trick which you can sue to get the classic Gnome2 panel with Ubuntu Unity interface. For that you need to open the terminal Windows by pressing the Press Alt + F2 and run:
Code:
gnome-panel
If you want the Gnome 2 panel to load at startup, in that case you must add it as startup applications. For this again type following command in terminal Window.
Code:
gnome-session-properties
Otherwise you can directly go to System > Preferences > Startup Applications and Click add.
Reply With Quote
  #7  
Old 06-02-2012
Member
 
Join Date: Feb 2010
Posts: 537
Re: Ubuntu Unity panel sitting behind top Gnome shell panel

If you are using the Ubuntu 11.10, you will get only Unity and Unity 2D. The 2D Unity isn't classic. If you use sudo method, you can get Gnome 3 and Gnome classic. At this time you will get choice to select durtin the login screen. I really don?t like the Gnome 3 and I am still using classic.
Reply With Quote
  #8  
Old 06-02-2012
Member
 
Join Date: Feb 2010
Posts: 428
Re: Ubuntu Unity panel sitting behind top Gnome shell panel

I think that it is the problem with the opacity settings. You must have to change the opacity of the Panel. For this you have to install CompizConfig Settings Manager. You can get this from the Ubuntu Software Center. After installing launch it and go to Ubuntu Unity Plug-in/Experimental/Panel Opacity. Adjust the slider.
Reply With Quote
  #9  
Old 06-02-2012
Member
 
Join Date: Feb 2010
Posts: 641
Re: Ubuntu Unity panel sitting behind top Gnome shell panel

This issue can be experienced in Ubuntu 11.10. To solve the issue, I have a best solution. Open the Terminal Windows and type, 'nautilus -q'. This command will kill and reload Nautilus. Then you will get a proper theme. If you are using the 12.04, You won't be seeing this issue anymore.
Reply With Quote
Reply

  TechArena Community > Software > Operating Systems
Tags: , , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Ubuntu Unity panel sitting behind top Gnome shell panel"
Thread Thread Starter Forum Replies Last Post
Comparison between unity and GNOME for ubuntu 11.04? Cauvery Operating Systems 7 25-07-2011 11:36 PM
Can I have Gnome Panel in place of LXDE Panel Irshaad Operating Systems 5 16-01-2011 08:06 AM
Gnome panel does not load at startup in Ubuntu Zipp Operating Systems 3 08-04-2009 11:45 PM


All times are GMT +5.5. The time now is 01:50 AM.