Results 1 to 8 of 8

Thread: Windows xp SP2 is not detecting installed Windows xp SP1

  1. #1
    Join Date
    Dec 2011
    Posts
    94

    Windows xp SP2 is not detecting installed Windows xp SP1

    I am currently having Windows xp SP1 on my system and I am willing to install Windows xp SP2 now but then the problem that I am facing here is that when I am trying to install sp2 then it says that I will have to install SP1, I donít know why is it not recognizing Windows xp SP1, is there anyone who has faced the same and has an idea about it??

  2. #2
    Join Date
    Jan 2012
    Posts
    120

    Re: Windows xp SP2 is not detecting installed Windows xp SP1

    I am currently having Windows xp SP1 on my system and I am willing to install Windows xp SP2 now but then the problem that I am facing here is that when I am trying to install sp2 then it says that I will have to install SP1, I donít know why is it not recognizing Windows xp SP1, is there anyone who has faced the same and has an idea about it??
    Even I am having the same issue going on in my system with the Vista Business x64, someone suggested me to try out KB947821l and I did the same and I was not having any problem in installing the same as well but then I am still getting the same message, I mean it says me to have the Vista Business x64 first, I have been trying to find out the possible cause of the same and I have tried out a no of solution as well but then they did not helped, is there anyone who has found a solution to get rid of this issue??

  3. #3
    Join Date
    May 2008
    Posts
    254

    Re: Windows xp SP2 is not detecting installed Windows xp SP1

    I will suggest you to get the System Update readiness tool and see if it is helping you out or not, you can get it from the below link:

  4. #4
    Join Date
    Dec 2011
    Posts
    94

    Re: Windows xp SP2 is not detecting installed Windows xp SP1

    After your suggestion I have checked out the Update readiness tool and it was not able to detect any error and I am still getting the same message saying that I will have to install sp1, if you want then you can just check the log file that I has been generated in the %SYSTEMROOT%\Logs\CBS\CheckSUR.log :
    Checking System Update Readiness.
    Version 6.0.6001.22275
    2009-05-28 23:11
    Checking Deployment Packages
    Checking Package Manifests and catalogs.
    Checking package watchlist.
    Checking component watchlist.
    Checking packages.
    Checking component store
    Checking SMI Store
    Summary:
    Milliseconds: 1532180
    No errors detected

  5. #5
    Join Date
    Jan 2012
    Posts
    120

    Re: Windows xp SP2 is not detecting installed Windows xp SP1

    I donít know whatís the other issue in my case is, I mean that I have tried to download the System Update readiness tool from the link that you have posted above but then it is giving me the following error:
    "Installer encountered an error 0x80070424 - the specified service does not exist as an installed service"
    Is there any other method that I can try out??

  6. #6
    Join Date
    May 2008
    Posts
    254

    Re: Windows xp SP2 is not detecting installed Windows xp SP1

    I will suggest you to better check out the value for the below by going in to the registry:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Component Based Servicing\Packages\KB936330~31bf3856ad364e35~x86~~6.0.1.18000\CurrentState registry key
    When you get it then just change the value to 7 and after that try out the installation process again and see if it is allowing you to do so or not.

  7. #7
    Join Date
    Dec 2011
    Posts
    94

    Re: Windows xp SP2 is not detecting installed Windows xp SP1

    I have checked out the same and the value is 7 already in the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Component Based Servicing\Packages\KB936330~31bf3856ad364e35~amd64~~6.0.1.18000. but then I have found that there are two more registry keys and they are as followed:
    • LastError
    • LastProgressState

    What should I do know?? Any further help for the same will be appreciated.

  8. #8
    Join Date
    Aug 2011
    Posts
    542

    Re: Windows xp SP2 is not detecting installed Windows xp SP1

    I have checked out for the same and I have found one having the exact issue and he had deleted the other two registry and then the issue was solved, so if you want then you can try out the same and see what you get, I also wanted to share that you will have to login with the admin account in order to delete those protected packages, so you should get the permission to the admin and make sure that you also have marked full control and read checked in the ďpermission for administratorĒ. Just check it out and then let me know if it is helping.

Similar Threads

  1. Replies: 6
    Last Post: 03-02-2012, 07:12 AM
  2. Replies: 8
    Last Post: 20-11-2011, 10:48 PM
  3. Replies: 4
    Last Post: 23-04-2011, 05:11 AM
  4. Windows 7 not detecting my external TV
    By Baby bon bon in forum Operating Systems
    Replies: 6
    Last Post: 07-03-2011, 09:17 AM
  5. Replies: 1
    Last Post: 25-11-2008, 06:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •