Go Back   TechArena Community > Software > Operating Systems
Become a Member!
Forgot your username/password?
Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



Unable to turn on websharing in Mac OS X Lion

Operating Systems


Reply
 
Thread Tools Search this Thread
  #1  
Old 17-10-2011
Member
 
Join Date: Oct 2011
Posts: 67
Unable to turn on websharing in Mac OS X Lion
  

When I click the check box to activate the script displays a check box, changes to 'Off' to'', of departure and the gray color indicator turns orange. This lasts for about a second off again. Any thoughts? I require my local host back

Reply With Quote
  #2  
Old 17-10-2011
Member
 
Join Date: Nov 2010
Posts: 363
re: Unable to turn on websharing in Mac OS X Lion

I'm having the identical trouble. I tried replacing the file / opt/local/apache2/conf/httpd.conf with / opt/local/apache2/conf/original/httpd.conf. On the other hand the web server is not functioning. Also confirm the permissions of httpd.conf and set the property in the system.
Reply With Quote
  #3  
Old 17-10-2011
Member
 
Join Date: Nov 2010
Posts: 442
re: Unable to turn on websharing in Mac OS X Lion

The location of my httpd.conf files were:

Code:
/etc/apache2/httpd.conf
 /etc/apache2/original/httpd.conf
Reply With Quote
  #4  
Old 17-10-2011
Member
 
Join Date: Jul 2011
Posts: 84
re: Unable to turn on websharing in Mac OS X Lion

I found the old file. Now what I have to move directory old httpd.conf? Let me know how to do it.
Reply With Quote
  #5  
Old 17-10-2011
Member
 
Join Date: Mar 2011
Posts: 489
re: Unable to turn on websharing in Mac OS X Lion

Quote:
Originally Posted by Emiliana View Post
I found the old file. Now what I have to move directory old httpd.conf? Let me know how to do it.
Code:
Replace /etc/apache2/httpd.conf 
With /etc/apache2/original/httpd.conf
You almost certainly want to generate a copy of /etc/apache2/httpd.conf wherever else in case you require it later. Make certain that you are in actuality moving files rather than creating an alias.
Reply With Quote
  #6  
Old 17-10-2011
Member
 
Join Date: May 2011
Posts: 397
re: Unable to turn on websharing in Mac OS X Lion

I have the same trouble, except when I click start; it says it?s not running nevertheless the web service is working for the reason that I can access the site via http://localhost

I tried replacing the httpd.conf with that of / original, and I've tried to modify the name of httpd.conf. Default, none of these things worked (together did the checkbox vigorous nevertheless when you turn it off you be capable to turn it back on)
Reply With Quote
  #7  
Old 17-10-2011
Member
 
Join Date: May 2011
Posts: 392
re: Unable to turn on websharing in Mac OS X Lion

All I did was modify the "Computer Name" field at the top of the window to share! Hope this solves your troubles too!
Reply With Quote
  #8  
Old 17-10-2011
Member
 
Join Date: May 2011
Posts: 433
re: Unable to turn on websharing in Mac OS X Lion

In my case a module reference was made that no longer exists in Lion. Try to comment out the line in httpd.conf that says: Fastcgi_module LoadModule libexec/apache2/mod_fastcgi.so

Commenting on this line requires# at the start of the line. The file editing can be done with tools such as TextWrangler or Text Mate.
Reply With Quote
  #9  
Old 17-10-2011
Member
 
Join Date: Jun 2011
Posts: 380
re: Unable to turn on websharing in Mac OS X Lion

Since I did the sudo the trick that has been functioning for me, I make use of the httpd.conf installed in / private/etc/apache2, and have even turn out to be php5 and the debugger.

For the record, changing my httpd.conf file do the trick for me, but changing my computer name actually starts Apache, although not shown in the user interface.
Reply With Quote
  #10  
Old 17-10-2011
Member
 
Join Date: Jul 2011
Posts: 348
re: Unable to turn on websharing in Mac OS X Lion

When I challenge to do this in the terminal tell me that Apache is by now loaded and will not establish. Therefore, I killed and restarted the service in the terminal.

If you endeavor to make the state sudo / release / apachectl which will provide you a URL that you be able to paste into Safari to establish it - mine cannot locate the page. I?m critically bearing in mind leaving to go away with Lighttpd and Apache. Well done Apple!
Reply With Quote
  #11  
Old 17-10-2011
Member
 
Join Date: Aug 2011
Posts: 375
Re: Unable to turn on websharing in Mac OS X Lion

I imagine the root cause of the trouble is that the settings for the daemon launch off of the box.

Code:
Edit /System/Library/LaunchDaemons/org.apache.httpd.plist and remove the lines:
   <Key>Disabled</key>
  <true/>
It is not enough to just change it to "false", apparently. I struggled with this for a while before I realized that it is necessary to completely eliminate this key to activate the devil.
Reply With Quote
Reply

  TechArena Community > Software > Operating Systems
Tags: , , , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Unable to turn on websharing in Mac OS X Lion"
Thread Thread Starter Forum Replies Last Post
Unable to use camera with Mac OS x lion pasture Operating Systems 6 04-11-2011 10:33 PM
Unable to Turn on FileVault on Mac OS X Lion Gopooo Operating Systems 7 15-10-2011 10:23 AM
Is there any Method turn off the leather look in iCal and Address Book in Mac OS X Lion v10.7 Gajagamini Operating Systems 6 14-10-2011 11:16 PM
How to turn off "Reopen windows when logging back in" in Mac OS X v10.7 Lion? Rowanee Operating Systems 11 30-09-2011 11:04 PM
How to Turn off Google Chrome 2-finger swipe gesture in OS X Lion DakshaMira Technology & Internet 4 27-08-2011 10:37 PM


All times are GMT +5.5. The time now is 02:12 AM.