Results 1 to 7 of 7

Thread: How to install VMware tools in Backtrack 5?

  1. #1
    Join Date
    May 2011

    How to install VMware tools in Backtrack 5?

    If you are using VMware Workstation you want to install VMware Tools.
    Choose VM> Install VMware Tools in the VMware Workstation menu to connect an ISO image file containing the VMware Tools Installer
    apt-get install linux-headers-`uname -r`
    mount /dev/sr0 /media/cdrom
    cd /tmp
    tar zxpf /media/cdrom/VMwareTools-*.tar.gz
    cd vmware-tools-distrib
    Enter default routes by the installer.

  2. #2
    Join Date
    Nov 2009

    Re: How to install VMware tools in Backtrack 5?

    Im also facing exactly same unable to install VMware tools in backtrack 5. When I run script in backtrack 5 its gets failed .Im getting this error message.
    Search / Line 6: unexpected EOF in finding matching '"'
    . / line 16: syntax error: unexpected end of file

  3. #3
    Join Date
    Nov 2009

    Re: How to install VMware tools in Backtrack 5?

    Not sure if anyone else is experiencing the same problem, but I found the same thing twice in two different systems. This does not work form e.
    When I put following commands in console.
    apt-get install linux-headers- 'uname -r'
    Im getting Following outputs
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Package linux-headers is not installed, so not removed
    E: Couldn't find package uname r
    Then when you get to the point where the process of configuring VMware Tools seeking the path to kernel headers, the route
    I think is not getting Recognized.

  4. #4
    Join Date
    Nov 2009

    Re: How to install VMware tools in Backtrack 5?

    Hey I followed all above steps and I managed to avoid this by introducing "no" when asked if I would change the path to the kernel headers. He gave me a warning, but simply ignored him and continued to press ENTER until it got through all the questions and end of the setup process. VMware Tools is acting a little strange, but I am clever to use the graphical user interface Backtrack filled screen style nows just wanted to install it in first place.

  5. #5
    Join Date
    Nov 2008

    Re: How to install VMware tools in Backtrack 5?

    If you are errors, either with mismatched versions of kernel header (i.e., version @ VMWARE @ UTS_RELEASE not match the version 6.2.38) or complain about a lack autoconf.h, you do not are two files in a directory that the installer expects them to be.
    /usr/src/linux-headers-2.6.38/include/linux/utsrelease.h &
    are both in /usr/src/linux-headers-2.6.38/include/generated/
    Issuing these commands from the /usr/src/linux-headers-2.6.38/include/linux/ directory will fix this:
    ln -sf ../generated/autoconf.h.
    ln -sf ../generated/utsrelease.h

  6. #6
    Join Date
    Nov 2009

    Re: How to install VMware tools in Backtrack 5?

    Installing VMware manually in backtrack 5
    root@bt:~# prepare-kernel-sources
    root@bt:~# cd /usr/src/linux
    root@bt:~# cp -rf include/generated/* include/linux/
    Next in the VMware Player, click on the VM -> Install VMware Tools; this will mount a CD containing.Type following commands to setup VMware tools.
    root@bt:~# cp -f /media/VMware\ Tools/VMwareTools-8.4.6-385536.tar.gz /root/
    root@bt:~# tar xvfz VMwareTools-8.4.6-385536.tar.gz
    root@bt:~# cd vmware-tools-distrib/
    root@bt:~/vmware-tools-distrib# ./
    After this series of questions to come, if you are unsure about them let them default.
    In which directory do you want to install the binary files?
    [/usr/bin] [RETURN]
    The configuration of VMware Tools 8.4.6 build-385536 for Linux for this running
    Kernel completed successfully.
    You must restart your X session before any mouse or graphics changes take
    You can now run VMware Tools by invoking "/usr/bin/vmware-toolbox-cmd" from the
    Command line or by invoking "/usr/bin/vmware-toolbox" from the command line
    During an X server session.
    To enable advanced X features (e.g., guest resolution fit, drag and drop, and
    File and text copy/paste), you will need to do one (or more) of the following:
    1. Manually start /usr/bin/vmware-user
    2. Log out and log back into your desktop session; and,
    3. Restart your X session.
    To use the vmxnet driver, restart networking using the following commands:
    /etc/init.d/networking stop
    rmmod pcnet32
    rmmod vmxnet
    modprobe vmxnet
    /etc/init.d/networking start
    Found VMware Tools CDROM mounted at /media/VMware Tools. Ejecting device
    If you see the preceding communication in the terminal means that the installation was winning, now, after a quick restart of the VMware tools be supposed to be operational, as well do not forget to arrange the home screen.
    root@bt:~# fix-splash
    root@bt:~# shutdown -r 0

  7. #7
    Join Date
    Apr 2010

    Re: How to install VMware tools in Backtrack 5?

    I was also facing similar difficulty while installing VMware tools in backtrack .somehow I managed to find the way to install it manually. Following are steps to install VMware tools in backtrack 5 or any other Linux.Installing VMware Workstation package worked fine, but will not run because the VMware modules do not compile. Running VMware-console-modconfig-install-all gives the cryptic message: “Gcc and kernel headers should be installed”. The files have gone from utsrelease.hy autoconf.h include / Linux to include / generated. As much as I like to hack my kernel source code, I chose to link these files in include / Linux.
    cd /usr/src/linux/include/linux/
    ln -sf ../generated/autoconf.h .
    ln -sf ../generated/utsrelease.h 
    To fix this error-/tmp/vmware-root/modules/vmnet-only/vnetUserListener.c:240: You need to type following commands.
    cd /usr/lib/vmware/modules/source/
    cp vmnet.tar was_vmnet.tar
    cd ~/tmp
    tar xf /usr/lib/vmware/modules/source/vmnet.tar
    cd vmnet-only
    In vnetUserListener,c, add the line:
    #include <linux/sched.h>
    #include "vnetInt.h"
    cd ..
    tar cf vmnet.tar vmnet-only
    mv vmnet.tar /usr/lib/vmware/modules/source/
    cd /usr/lib/vmware/modules/source/
    cp vmci.tar was_vmci.tar
    cd ~/tmp
    tar xf /usr/lib/vmware/modules/source/vmci.tar
    cd vmci-only/include
    In pgtbl.h, add the line:
    #include <linux/sched.h>
    #include "compat_page.
    cd ../..
    tar cf vmci.tar vmci-only
    mv vmci.tar /usr/lib/vmware/modules/source/
    lastly, it all compiles and we have a working VMware Workstation install!

Similar Threads

  1. BackTrack - Installing vmware-tools in vmware-fusion
    By SoftWore in forum Tips & Tweaks
    Replies: 1
    Last Post: 12-05-2010, 03:25 PM
  2. Can't reinstall VMware tools in BackTrack 4 final
    By visioneye in forum Operating Systems
    Replies: 6
    Last Post: 10-05-2010, 11:58 PM
  3. How do I install VMWare Tools in BackTrack 4?
    By Layton in forum Operating Systems
    Replies: 6
    Last Post: 10-05-2010, 10:31 PM
  4. Installation of vmware tools in backtrack 3
    By KDE_RuLeZ in forum Operating Systems
    Replies: 3
    Last Post: 20-08-2009, 11:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts