Go Back   TechArena Community > Software > Operating Systems
Become a Member!
Forgot your username/password?
Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



Help me with Armitage Setup in Linux operating system

Operating Systems


Reply
 
Thread Tools Search this Thread
  #1  
Old 06-07-2011
Member
 
Join Date: Jun 2011
Posts: 72
Help me with Armitage Setup in Linux operating system
  

Please help me with installing the Armitage in my Linux operating system. I have setup of Armitage but having problem in installing it. I want to set in my system. I just started PostgreSql and Mysql, and both of them won?t work. All your help will be appreciated.

Reply With Quote
  #2  
Old 06-07-2011
Member
 
Join Date: Nov 2009
Posts: 754
Re: Help me with Armitage Setup in Linux operating system

I would like to inform you that Armitage on both mysql and postgre. Since you have not given info related to your error message so it would be little problem for me to be appropriate. Armitage is just a GUI version of metasploit. So see more information about error message by visiting the official website of metasploit. Hope you get what you require.
Reply With Quote
  #3  
Old 06-07-2011
Member
 
Join Date: Apr 2009
Posts: 967
Re: Help me with Armitage Setup in Linux operating system

As you must be aware that Armitage is just a GUI version. You have to connect Armitage to database. To connect it you have to make use of commands. Also you have to update metasploit from the one that comes on the bt5 cd.

Code:
cd /pentest/exploits/framework3
./msfconsole
db_driver postgresql 
db_driver mysql
The above command will both return something about driver . If there is any problem then, it will complain with an error message.
Reply With Quote
  #4  
Old 06-07-2011
mv mv is offline
Member
 
Join Date: May 2008
Posts: 681
Re: Help me with Armitage Setup in Linux operating system

Perform the below script command to connect:
Code:
shell : /etc/init.d/mysql start (optional in BT5)
msfrpcd -f -U msf -P test -t Basic
2 shell : cd /opt/framework3/msf3/
ls
./armitage
use SSL 
driver MYSQL
then click CONNECT
Reply With Quote
  #5  
Old 06-07-2011
Member
 
Join Date: Apr 2009
Posts: 990
Re: Help me with Armitage Setup in Linux operating system

I had the same problem as you. To get rid of these I recommend you to use PostgreSQL instead of MySQL. Actually I am recommending you to use PostgreSQL because there have been technical issues with Metasploit causing MySQL databases to break. This issue is unsolved and it chooses to change a database schema. Also Metasploit team test with Postgres. The Linux set up Postgres for you.
Reply With Quote
  #6  
Old 09-07-2011
Member
 
Join Date: Apr 2009
Posts: 1,106
Re: Help me with Armitage Setup in Linux operating system

To install Armitage on your Linux operating system follow the below steps:
First make sure that you are the root user.
Download and Install the Metasploit Framework from official website and keep in mind that you get the full package with all of the Linux dependencies.
After installation type: /opt/framework/app/msfupdate to update Metasploit.
At last install a VNC viewer for example apt-get install vncviewer on Ubuntu.
Reply With Quote
Reply

  TechArena Community > Software > Operating Systems
Tags: , , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Help me with Armitage Setup in Linux operating system"
Thread Thread Starter Forum Replies Last Post
How can I setup mac operating system in my computer? smithson654 Operating Systems 1 01-11-2012 11:41 AM
How to get armitage in backtrack5 Linux ADELYN Windows Software 6 07-07-2011 08:11 PM
Error: This setup is not made for this operating system Felisha Operating Systems 6 30-01-2010 04:16 PM
linux operating system skpanda Operating Systems 2 10-08-2009 01:00 PM
gOS - Linux Operating System jesse Operating Systems 3 08-04-2009 02:48 PM


All times are GMT +5.5. The time now is 07:10 PM.