Results 1 to 7 of 7

Thread: Backtrack 5-Get VLC to work under root without compiling

  1. #1
    Join Date
    May 2011
    Posts
    299

    Backtrack 5-Get VLC to work under root without compiling

    When you download VLC media player in Backtrack 5 will not start. This is because they cannot run in the root. This is annoying as it is the standard Backtrack 5 root. Anyway, I found a way to implement it without installing from source with the qualification as root suffix.
    First install from vlc from the repo’s
    Use a hex editor to edit /usr/bin/vlc

    Code:
    geteuid._libc_start_man
    and change it into

    Code:
    getppid._libc_start_man

  2. #2
    Join Date
    Apr 2009
    Posts
    996

    Re: Backtrack 5-Get VLC to work under root without compiling

    Everything worked fine for Gnome BT5 32-bit version however, the search string to modify / usr / bin / vlc was "geteuid._libc_start_main" no "geteuid._libc_start_man" as indicated in the instructions cgelici. Just do a search for "geteuid" (without the quotes) as the only case and follow the Ministry of Defense. This may help some people who have problems. Thanks again for the help that I was starting to pull hairs and really cannot afford that. They have an outstanding day!

  3. #3
    Join Date
    Nov 2009
    Posts
    794

    Re: Backtrack 5-Get VLC to work under root without compiling

    Hey guys sorry total noob here I’ve recently installed my HD BT5 and use "sudo apt-get install vlc vlc-plugin-pulse vlc-plug-in-Mozilla" to download and install vlc but when I have tried to open running habit. I’m using 32-bit Backtrack 5 gnome. It is not completely sure where to start tweaking the code I’m probably more I've looked and I'm a total newbie at this so any pointers in the right direction would be sweet people, Cheers.I am a dumb as well. I’m using the version of KDE and vlc still Backtrack 5 would not work so I have been reading some posts by others on the network with the same problems all suggesting the same condition.My only question is why people are saying it’s not safe to run vlc as root.My apologies for hijacking your thread so just are good to know. I’m satisfied with above answer and it really helped me lot to make my vlc running under root.

  4. #4
    Join Date
    May 2008
    Posts
    2,684

    Re: Backtrack 5-Get VLC to work under root without compiling

    I have the same opinion with you. I know that comes with Backtrack as root by default, but I do not be familiar with why everybody insists on maintenance it that way. Particularly when people are clearly trying to use it as your daily driver OS (VLC, Open Office, wine, etc.) I mean the default password is toor, unless you have a specific technical reason not to (break bulk, etc) why not do the following.
    Code:
    useradd -m username
    passwd username
    visudo
    Add your username below the line that reads
    root    ALL=(ALL) ALL
    so that it looks like this
    root    ALL=(ALL) ALL
    username ALL=(ALL) ALL

  5. #5
    Join Date
    Apr 2010
    Posts
    234

    Re: Backtrack 5-Get VLC to work under root without compiling

    Strongly agree when it comes to applications using Open Office / LibreOffice and routine, but VLC comes in handy when doing forensic analysis of the files. VLC media player is very nice to reconstruct video sequences (explain products, Wireshark, tcpdump, etc.). Are there other applications to do this with Backtrack 5? Probably, but VLC get it done right. Just my two cents.
    They have an outstanding day!

  6. #6
    Join Date
    Apr 2010
    Posts
    62

    Re: Backtrack 5-Get VLC to work under root without compiling

    Wow so great a thread for something so simple my mind is filled. I posted something similar in the other drawing had only two seats but I just saw this and since it is a problem. For most people thought Identification ID to republish in the thread that most of the guaranteed. For applications running on the ubuntu root recompiling only post i see some people there is a way to do it any other way without having to recompile.
    Code:
    wget -c http://download.videolan.org/pub/vid...0.9.9a.tar.bz2
    tar -xvf vlc-0.9.9a.tar.bz2
    cd vlc-0.9.9a
    apt-get build-dep vlc
    ./configure --enable-run-as-root
    make
    make install
    apt-get install libvlc-dev libvlc2

  7. #7
    Join Date
    Nov 2008
    Posts
    1,185

    Re: Backtrack 5-Get VLC to work under root without compiling

    This working two ways of responsibility things the correct way Linux and way. Messing wrong with the program values to hexadecimal is WRONGWAY.recompiling suitable flags and commands are the Right way. Did you do apt-get remove - purge vlc .It must take away and recompile and take away any marks that there is no trace of folders or files vlc satisfy me the result is that after creation of errors or make install .This is after, although it is not something I thought someone was trying to do and said he worked for them .This is so important to say "this does not work or does not work for me it makes sense that they are both using the same distro"

Similar Threads

  1. Can't get my wifi to work in backtrack 5?
    By Dakshayani in forum Operating Systems
    Replies: 10
    Last Post: 07-05-2012, 10:33 PM
  2. Run Google Chrome as Root on BackTrack 5
    By Izna in forum Technology & Internet
    Replies: 5
    Last Post: 09-07-2011, 09:00 PM
  3. Backtrack, 800x600 work fine from USB?
    By Haleema in forum Operating Systems
    Replies: 4
    Last Post: 20-06-2011, 02:52 AM
  4. Backtrack 4 password "toor" doesn't work
    By Measurer in forum Operating Systems
    Replies: 6
    Last Post: 09-05-2010, 06:47 AM
  5. Replies: 3
    Last Post: 02-02-2007, 06:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •