Go Back   TechArena Community > Software > Operating Systems
Become a Member!
Forgot your username/password?
Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



SW on OVH fails to reboot after upgrading to baselayout-2

Operating Systems


Reply
 
Thread Tools Search this Thread
  #1  
Old 01-06-2011
Member
 
Join Date: Mar 2011
Posts: 165
SW on OVH fails to reboot after upgrading to baselayout-2
  

i have unexpectedly updated toward baselayout 2 on top of a OVH dedicated server (SuperPlan BestOF Reloaded through upgraded Gentoo and newest netboot kernel) . It turns into a primary outage in a long history. After some time I managed to steady it by the help of the upgrade manual. However, it fails to carry out SW reboot thus i must execute HW reboot exactly following the SW one. Then it works, except simply thanks to monitor beginning all the half deceased services ex-post. So is there any reverting back option for baselayout-1. The server doesn?t have any backup system.

Reply With Quote
  #2  
Old 01-06-2011
Member
 
Join Date: Feb 2010
Posts: 546
Re: SW on OVH fails to reboot after upgrading to baselayout-2

I believe the trouble will be moreover through ETH1 (i'm not conscious of its reason) otherwise somewhat inside the init phase which is not logged. Whilst it is a construction server i am being previously condemned plenty and i can't give fresh outages caused via noticing boot series in KVM. However i actually dread that in case of electricity outage the server will be through the OVH workforce rebooted simply into preservation mode and my scoffs will dig up mad.
Reply With Quote
  #3  
Old 01-06-2011
Member
 
Join Date: Feb 2010
Posts: 524
Re: SW on OVH fails to reboot after upgrading to baselayout-2

Ok, I assume I may get it. net.eth0 as well as net.eth1 both offer net, therefore additional services won't launch for the reason that net.eth1 won't begin. I don?t consider you still have an net.eth1 interface! Automatic install from OVH include several glitches and this might be one of them, you must get rid of from you default runlevel net.eth1, net.eth2, net.eth3 along with most likely net.eth[0123]. You can discover your real net interfaces effortlessly through: cat/etc/udev/rules.d/70-persistent-net.rules
Reply With Quote
  #4  
Old 01-06-2011
Member
 
Join Date: Feb 2010
Posts: 537
Re: SW on OVH fails to reboot after upgrading to baselayout-2

If you get rid of net.eth1 from the defaulting runlevel, you can almost certainly not require changing rc.conf. Through rc_depend_strict set toward yes, it needs all interfaces to begin prior to the dependencies can, at this moment; you have a runlevel access by a valid init.d script intended for together eth0 as well as eth1. It looks like you almost certainly simply make use of eth0 (because of config plus routes lost for eth1 inside /etc/conf.d/net) and therefore eth1 tries to utilize dhcp to dig up assigned an address, it doesn't function.
Reply With Quote
  #5  
Old 02-06-2011
Member
 
Join Date: Feb 2010
Posts: 763
Re: SW on OVH fails to reboot after upgrading to baselayout-2

Altering rc_depend_strict to no will assist by the services fault, and yes, I believe it's a excellent thought to fresh your defaulting runlevel of the busted scripts if simply for housekeeping. Snce for the soft rebooting..I have no problem by means of that myself up to now, therefore I cannot assist you much I believe. shutdown rc carry out fine. And it appears to attain its end. Thus I'd speak the problem is among the end of the shutdown runlevel in addition to the establishment of boot runlevel. At that point, I'd go in vKVM to fnid out what's happening between these moment.
Reply With Quote
Reply

  TechArena Community > Software > Operating Systems
Tags: , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "SW on OVH fails to reboot after upgrading to baselayout-2"
Thread Thread Starter Forum Replies Last Post
While upgrading Windows 7 encountered a reboot loop Mustaffa Operating Systems 5 19-04-2011 05:32 AM
Windows 7 - KB2454826 fails to recover after reboot Dechen Operating Systems 5 27-02-2011 08:10 PM
Cluster Service fails to start 1st time following reboot. Chalkie Windows Server Help 9 27-05-2008 10:39 PM


All times are GMT +5.5. The time now is 07:36 PM.