Go Back   TechArena Community > Software > Operating Systems
Become a Member!
Forgot your username/password?
Register Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



Gentoo booting stops at init-early.sh

Operating Systems


Reply
 
Thread Tools Search this Thread
  #1  
Old 29-05-2011
Member
 
Join Date: Mar 2011
Posts: 88
Gentoo booting stops at init-early.sh
  

Hello Friend, I am faced serious trouble in the Gentoo Linux operating system. I had installed it in the last week and there is some problem present in this OS. Whenever I starts the booting process the initially it works fine. Then after sometime it stops and the system hangs. The last line of the booting process is to be [ 1.448408] init-early.sh used greatest stack depth: 3640 bytes left . I need to solve the trouble. Any help would be appreciates.

Reply With Quote
  #2  
Old 29-05-2011
Member
 
Join Date: May 2008
Posts: 859
Re: Gentoo booting stops at init-early.sh

Hey dude, I suggest you to just use the initial actions to solve this trouble. I suggest you to mount the root directory of the system in the rw mode. After mounting this directory in the read-write mode, the system works correctly and the booting is to be done successfully in the system. Initially we use the ro mode that is read only mode to boot the system. Just try this solutions and it works to solve the trouble. You definitely got the different result.
Reply With Quote
  #3  
Old 29-05-2011
Member
 
Join Date: May 2008
Posts: 991
Re: Gentoo booting stops at init-early.sh

Hey dude, this rw mode works sometime and the booting error is to be removed temporary from the system. I think you need some extra effort for solving the trouble completely on the system. Then enabled devtmpfs in your kernel file system. This helps to remove this booting error completely form the system. You can use the manual for do this task. Then use these different solutions and then solve the trouble.
Reply With Quote
  #4  
Old 29-05-2011
Member
 
Join Date: Nov 2009
Posts: 1,292
Re: Gentoo booting stops at init-early.sh

Thanks for your reply. I also faced the same trouble and I used this enabled devtmpfs in my kernel solutions. This works really well and my Gentoo Linux system boots with no troubles. Then I understand now is there is necessary to enabled this option in the system. This helps the booting process of the system. This enabled devtmpfs helps to initialization of kernel, before any driver core device is registered. Then use this solutions and it really works very well.
Reply With Quote
  #5  
Old 29-05-2011
Member
 
Join Date: Apr 2009
Posts: 963
Re: Gentoo booting stops at init-early.sh

Probably, there is possibility that your system is used an older versions of the kernel. Then you need to update this version. You can be doing this easily in the system. The latest version of the Linux kernel is to be 2.6.39. With new kernel-2.6.39, you need to just enable the devtmpfs options. This will helps to solve the booting trouble form the system. This will helps to speed up the boot process and then the booting has to be done fast in the system. Actually the disabled devtmpfs options create this trouble.
Reply With Quote
  #6  
Old 29-05-2011
Member
 
Join Date: Nov 2009
Posts: 823
Re: Gentoo booting stops at init-early.sh

Hi, I'm the experiencing user of this OS and I also faced the same problem. Then I use this enabled devtmpfs solutions to solve the trouble. But this will not work properly and the trouble is still present in the system. Then I mount the root file system that is xfs as rw mode. Then everything goes fine in this booting process. I wonder this thing. I read these solutions in somewhere and it works correctly. I suggest you to use these solutions.
Reply With Quote
  #7  
Old 30-05-2011
Member
 
Join Date: May 2008
Posts: 2,676
Re: Gentoo booting stops at init-early.sh

It is necessary to enable both options in this gentoo OS. The updated kernel and the enabled devtmpfs help to solve this trouble. I had experienced about it. I faced this trouble in the last week. Initially, I enabled only devtmpfs and it didn't work. Then I also done set the automatically mount devtmpfs option in the Gentoo. This will helps to solve the trouble from the system. This is the best way to solve the booting problem in the system.
Reply With Quote
Reply

  TechArena Community > Software > Operating Systems
Tags: , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Gentoo booting stops at init-early.sh"
Thread Thread Starter Forum Replies Last Post
Lenovo ThinkPad T60 not booting and stops at crcdisk.sys Uganda Portable Devices 6 13-03-2012 08:08 AM
Problem with init cpu Asus Crosshair IV Sindu Motherboard Processor & RAM 7 04-07-2010 06:26 AM
Bad Company 2 - PB Init Failure Am_Wamika Video Games 4 17-05-2010 01:34 PM
PB Init failure KAILEY Video Games 4 29-03-2010 10:05 PM


All times are GMT +5.5. The time now is 01:38 AM.