Results 1 to 6 of 6

Thread: Getting Error message ‘Northbridge Error, node 2<0>K8 ECC error.’ in CentOS 5.5

  1. #1
    Join Date
    Jan 2011
    Posts
    54

    Getting Error message ‘Northbridge Error, node 2<0>K8 ECC error.’ in CentOS 5.5

    I am running CentOS 5.5 on the computer of mine. I am getting an error message on the new server on the computer. The error message can be stated as ‘Northbridge Error, node 2<0>K8 ECC error’ I have tried lots of tricks and tweaks to get rid out from this particular problem. But all the efforts of mine were fruitless. Let me know if you are having any suggestion to fix the problem of mine. Thanks a lot in advance.

  2. #2
    Join Date
    Nov 2009
    Posts
    825

    Re: Getting Error message ‘Northbridge Error, node 2<0>K8 ECC error.’ in CentOS 5.5

    Looking at the problem which you have provided over I think there could be different reason which could be the root cause of the problem. So first of all tell me about the entire hardware configuration of the computer. Do you have done any recent changes? Have you ever get the above mentioned error message on the system of yours. So answer the above mentioned thing as early as possible so that I can let you know about the further steps for troubleshooting.

  3. #3
    Join Date
    Apr 2009
    Posts
    972

    Re: Getting Error message ‘Northbridge Error, node 2<0>K8 ECC error.’ in CentOS 5.5

    I think that you are aware of the thing which is being running of the NUMA system and all the memory controllers are located into the CPU. You should simply swap the RAM module and see whether you are getting the error message or not. Another thing which could be the root cause of the problem that is bad heat sink or due to marginal power supply voltage or bad fan. It is purely happening due to hardware issue not the kernel issue.

  4. #4
    Join Date
    Nov 2009
    Posts
    688

    Re: Getting Error message ‘Northbridge Error, node 2<0>K8 ECC error.’ in CentOS 5.5

    This particular error is associated with md64_edac module. In order to fix the problem let me know whether you are getting BIOS option which can be stated into below mentioned wordings.’ Gart Table Walk Error MC reporting: Disabled/Enabled.’ Well you should use the disable option and see whether it is working or not. So try the above mentioned thing and see whether it is working or not.

  5. #5
    Join Date
    Nov 2009
    Posts
    1,035

    Re: Getting Error message ‘Northbridge Error, node 2<0>K8 ECC error.’ in CentOS 5.5

    If you are unable to get the BIOS option on the computer then you need to use the following patch.
    Code:
    --git a/drivers/edac/edac_mce_amd.c b/drivers/edac/edac_mce_amd.c
    index 713ed7d..026f0cb 100644
    --- a/drivers/edac/edac_mce_amd.c
    +++ b/drivers/edac/edac_mce_amd.c
    @@ -300,6 +300,12 @@ void amd_decode_nb_mce(int node_id, struct err_regs *regs, int handle_errors)
     	if (!handle_errors)
     		return;
     
    +	/*
    +	 * GART TLB error reporting is disabled by default. Bail out early.
    +	 */
    +	if (TLB_ERROR(ec) && !report_gart_errors)
    +		return;
    +
     	pr_emerg(" Northbridge Error, node %d", node_id);
     
     	/*
    @@ -311,10 +317,9 @@ void amd_decode_nb_mce(int node_id, struct err_regs *regs, int handle_errors)
     		if (regs->nbsh & K8_NBSH_ERR_CPU_VAL)
     			pr_cont(", core: %u\n", (u8)(regs->nbsh & 0xf));
     	} else {
    -		pr_cont(", core: %d\n", ilog2((regs->nbsh & 0xf)));
    +		pr_cont(", core: %d\n", fls((regs->nbsh & 0xf) - 1));
     	}
     
    -
     	pr_emerg("%s.\n", EXT_ERR_MSG(xec));
     
     	if (BUS_ERROR(ec) && nb_bus_decoder)
    @@ -334,21 +339,6 @@ static void amd_decode_fr_mce(u64 mc5_status)
     static inline void amd_decode_err_code(unsigned int ec)
     {
     	if (TLB_ERROR(ec)) {
    -		/*
    -		 * GART errors are intended to help graphics driver developers
    -		 * to detect bad GART PTEs. It is recommended by AMD to disable
    -		 * GART table walk error reporting by default[1] (currently
    -		 * being disabled in mce_cpu_quirks()) and according to the
    -		 * comment in mce_cpu_quirks(), such GART errors can be
    -		 * incorrectly triggered. We may see these errors anyway and
    -		 * unless requested by the user, they won't be reported.
    -		 *
    -		 * [1] section 13.10.1 on BIOS and Kernel Developers Guide for
    -		 *     AMD NPT family 0Fh processors
    -		 */
    -		if (!report_gart_errors)
    -			return;
    -
     		pr_emerg(" Transaction: %s, Cache Level %s\n",
     			 TT_MSG(ec), LL_MSG(ec));
     	} else if (MEM_ERROR(ec)) {
    After using the above mentioned patch let me know about the results.

  6. #6
    Join Date
    Nov 2009
    Posts
    1,292

    Re: Getting Error message ‘Northbridge Error, node 2<0>K8 ECC error.’ in CentOS 5.5

    I think you need to change the sysconfig.conf. you can find that particular file on the /etc/sysconfig folder on the computer of yours. You need to execute the below mentioned command on the terminal.
    Code:
    # rpm -qf /etc/syslog.conf
    sysklogd-1.4.1-46.el5
    I am hoping that it will help you to fix the problem of yours.

Similar Threads

  1. Error message while login into VSFTPD on CentOS 5.5
    By fanish-war in forum Operating Systems
    Replies: 5
    Last Post: 07-05-2011, 12:13 PM
  2. Replies: 5
    Last Post: 06-05-2011, 10:37 AM
  3. CentOS 5.2 and Apache 2.2.3: Getting error message 403
    By Angee in forum Operating Systems
    Replies: 5
    Last Post: 05-05-2011, 10:49 AM
  4. Replies: 5
    Last Post: 04-05-2011, 10:53 AM
  5. Error message While Installing CentOS
    By Obessed in forum Operating Systems
    Replies: 5
    Last Post: 11-11-2010, 10:29 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •