Results 1 to 6 of 6

Thread: SQMAPI.dll missing while installing Windows 7 SP1

  1. #1
    Join Date
    Dec 2010
    Posts
    275

    SQMAPI.dll missing while installing Windows 7 SP1

    The SP1 is downloaded and restart the system. It continues with stage one of the two but for some reason the process of "time out" and invested. Windows 7 then start to undo all that had downloaded. I believe this is where W7 uninstalled all or part of the SQMAPI.dll or spoiled. As the only application that was uninstalled was the Service Pack 1 itself, re-install the Service Pack 1 to download the Service Pack 1 is impossible. I rebooted several times, turn off all antivirus, clean any debris as possible and continues to fail W7 SP1. Again, I think the problem is created when SP1 has timed out and uninstalled.

  2. #2
    Join Date
    May 2008
    Posts
    681

    Re: SQMAPI.dll missing while installing Windows 7 SP1

    Processes outside the system as sqmapi.dll are created from the software you have installed on your system. Like most applications store data on the registry of your system, it is possible that the latter is broken by the disintegration and the accumulation of injurious errors. I advise that you verify your registry now to recognize hidden errors .

  3. #3
    Join Date
    Dec 2010
    Posts
    275

    Re: SQMAPI.dll missing while installing Windows 7 SP1

    Yesterday I tried to upgrade this computer to Win7 SP1. When I came in this morning, I had the icons on my taskbar or the desktop. The start menu was not working well. I was able to successfully do a system restore to a date before the update. Now when I try to update through Windows Update, it freezes at 99% discharge. So I downloaded the standalone update 64-bit SP1. To install (with Run as administrator), I find an error representing that sqmapi.dll missing or damaged.

    The steps I've tried:

    • I ran sfc / scannow (as administrator) - all cleaned and repaired
    • I ran the System Update Readiness Tool (Windows6.1-KB947821-v10-x64.msu) to completion.
    • I have restarted the computer several times - no problems booting or login.


    At this point, the system is responding normally with no error message. But I'd get the SP1 installed on this computer. I have another identical system here has been updated to SP1 last night. I want to know more information. Any help is appreciated!

  4. #4
    Join Date
    Apr 2009
    Posts
    996

    Re: SQMAPI.dll missing while installing Windows 7 SP1

    If your computer is having trouble finding and installing operating system updates, theWindows update troubleshooter might be able to solve the problem. To run the Windows troubleshooter Update. Open Troubleshooter Windows Update, click the Start button and then click Control Panel. In the search box, type troubleshooter and then clickTroubleshooting. UnderSystem & Security, click Troubleshooting Windows Update. If you are provoked for an administrator password or verification, type the password or give confirmation. Run the System Update Readiness Tool : System Update Readiness tool can assist you to solve troubles that can avoid Windows updates and service packs installation.

  5. #5
    Join Date
    May 2008
    Posts
    991

    Re: SQMAPI.dll missing while installing Windows 7 SP1

    I suggest you try the steps listed below and see if it helps.

    Method 1: Disable your security software temporarily. Note: The antivirus software can facilitate to guard your computer in opposition to viruses and further security threats. In the majority cases, you must not stop the antivirus software. If you must temporarily disable the installation of other software, you must re-enable as soon as you finish. If you are linked to the Internet or a network through the time it disables antivirus software, your computer is vulnerable to attack.

    Method 2: Place the computer in clean boot earlier than going on with the installation of SP1. Note: After troubleshooting step clean boot, follow step 7 in the link provided to return your computer to normal startup mode.

    Method 3: Also, disconnect the external devices could be connected to the system. It is possible to download SP1 may be corrupt, download a copy and try again.

  6. #6
    Join Date
    Apr 2009
    Posts
    972

    Re: SQMAPI.dll missing while installing Windows 7 SP1

    Throughout installation of Service Pack 1 of Windows 7, one of the main familiar error arise when a third party application has a file open or tresses a file that the Setup Service Pack is to be used. For instance, a third-party antivirus or antispyware application can originate this trouble. If you are using third party applications like accelerators Spyblocker, Internet or web in order to increase the internet speed, security programs like McAfee, Norton, etc, I suggest disabling them for the time being throughout troubleshooting.

Similar Threads

  1. Programs missing after installing Windows 8
    By Triple H in forum Operating Systems
    Replies: 5
    Last Post: 03-12-2011, 12:10 AM
  2. Replies: 4
    Last Post: 20-04-2011, 08:28 AM
  3. Replies: 3
    Last Post: 22-03-2011, 12:35 AM
  4. Missing some icons on windows 7 after installing Nero 9
    By Tajdar7 in forum Operating Systems
    Replies: 4
    Last Post: 20-11-2010, 12:31 PM
  5. DVD RW missing after installing Windows 7
    By Santosh24 in forum Hardware Peripherals
    Replies: 4
    Last Post: 19-11-2009, 02:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •