Go Back   TechArena Community > Software > Operating Systems
Become a Member!
Forgot your username/password?
Register Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



USB device working but can't read drive in windows 7

Operating Systems


Reply
 
Thread Tools Search this Thread
  #1  
Old 08-02-2011
Member
 
Join Date: Jan 2011
Posts: 32
USB device working but can't read drive in windows 7
  

Hi all,
I am using from last one and half years a Dell inspiron one desktop computer running with windows 7 OS. The machine is specified with Intel dual core processor and NVIDIA graphical interface. Along with this also i am having a USB flash device. There is a problem i am facing whenever I tried to plug the USB device into the machine. The device is detected but windows does not allow me to access further. I tried to solve this issue, but nothing help me is there any one having any suggestion to resolve this issue?

Reply With Quote
  #2  
Old 08-02-2011
Member
 
Join Date: May 2008
Posts: 951
Re:USB device working but can't read drive in windows 7

As per my opinion I think you should go for the USB mass driver update. For that open device manager and right click on the USB mass storage device driver, and choose on line update option. It will collect the information regarding the update version of the driver and will direct you to download the driver firmware. Wait till the firmware downloads and installed into the machine. A system reboot is required after the process, go for this and reboot your machine. I hope after this the USB device will surely read by the OS.
Reply With Quote
  #3  
Old 08-02-2011
Member
 
Join Date: May 2008
Posts: 871
Re:USB device working but can't read drive in windows 7

As per my knowledge about this type of problems, this type of problems may occur for the OS windows log file, those are works with the hardware device driver. According to the problem that you mentioned, I think those windows log file will missing or corrupt in your windows installed folder. For that I recommend you to download the update version of the file of the operating system from developer web site, and install into your machine.
Reply With Quote
  #4  
Old 08-02-2011
Member
 
Join Date: May 2008
Posts: 923
Re:USB device working but can't read drive in windows 7

Did you check the USB connector or the port in your machine? Whether this one working fine or not. Some of the cases I found that it might be cause for the USB port, though the device is connected, but not read by the windows version. So if this type of problem is arrives in your machine then I recommend you to plug the device and enter into device manager from there check the status of the driver which is working for the USB driver. If this working fine then simply goes to the manufacturer service center and from ether consult with any engineer for the problem. And if still if you are facing the problem then there is a simply solution for this type of problems, format the flesh drive and then try to re-plug it.
Reply With Quote
Reply

  TechArena Community > Software > Operating Systems
Tags: , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "USB device working but can't read drive in windows 7"
Thread Thread Starter Forum Replies Last Post
I/O device is not working properly with external hard drive Raju Chacha Hardware Peripherals 4 12-01-2012 09:56 AM
dvd drive not working and will not read disc mail2jaydeep007 Hardware Peripherals 5 12-06-2011 03:29 AM
Can copy and read the new files but cannot read or delete old contents in the hard drive GOOL Hardware Peripherals 3 14-12-2010 03:10 AM
Recover Windows Server 2003 DC that won't boot but drive can be read aileen Active Directory 2 30-05-2009 08:43 PM
READ THIS IF YOU CANNOT GET DRIVE TO READ DISK TO FIX VISTA ERROR! DesTiny! Vista Hardware Devices 2 14-01-2009 01:42 PM


All times are GMT +5.5. The time now is 11:25 PM.