Go Back   TechArena Community > Software > Operating Systems
Become a Member!
Forgot your username/password?
Register Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



Install Java 6.21 Plug-in For Linux Mint 9 x64 with FF 3.6.10

Operating Systems


Reply
 
Thread Tools Search this Thread
  #1  
Old 03-01-2011
Member
 
Join Date: Nov 2010
Posts: 48
Install Java 6.21 Plug-in For Linux Mint 9 x64 with FF 3.6.10
  

I am wondering if anybody else has Java 6.21 running in Linux Mint 9 64 bit with the plug-in functioning for Firefox 3.6.10. Up to now I handled to perform the following.
  1. Uninstall the present version of Java 6.20 by means of Synaptic
  2. Install the Java version for Linux 64 bit jre-6u21-linux-x64.bin
  3. Create the file executable.
  4. Run the setup
Code:
./jre-6u21-linux-x64.bin
In the folder usrs/local/java/ that unloads the whole thing into the sub folder jre1.6.0_21. At the present the procedure completes. There is no additional information regarding how to enable the plug-in for a browser. If I interpret the instructions for the 32 bit version, there are instructions for making a symbolic link, but the references for example the file libjavaplugin_oji.so or the like, do not be. Can anybody point me in the right path? Thanks for any helpful tips.

Reply With Quote
  #2  
Old 03-01-2011
Member
 
Join Date: May 2008
Posts: 962
Re: Install Java 6.21 Plug-in For Linux Mint 9 x64 with FF 3.6.10

If I remember properly, you can set things up utilizing Galternatives which you will have to setup it. If the uninstall of the Java 6.20 package detached the substitutes entry, then consider re-installing it. You can supersede the favorites using Galternatives. You might as well be able to put the penchants in the gnome control center. There is a plug-in control panel in the other category.
Reply With Quote
  #3  
Old 03-01-2011
Member
 
Join Date: May 2008
Posts: 859
Re: Install Java 6.21 Plug-in For Linux Mint 9 x64 with FF 3.6.10

No necessitate for Galternatives; run the below command in its place:
Sudo update-alternatives --config java
You will observe something like this:
Code:
abc@abc-laptop:~$ sudo update-alternatives --config java
There are 3 options for the alternative java.
  Selection    Path                                      Priority   Status
------------------------------------------------------------
  0            /usr/lib/jvm/java-6-openjdk/jre/bin/java   1062      auto mode
  1            /usr/bin/gij-4.4                           1054      manual mode
  2            /usr/lib/jvm/java-6-openjdk/jre/bin/java   1051      manual mode
  3            /usr/lib/jvm/java-6-sun/jre/bin/java       65        manual mode

You'd wish java-6-sun in its place of the Open JDK alternative. The next step is to setup a symlinks between the accurate Sun Java plug-in, and Firefox's plug-in folder that is:
Code:
Sudo in -s /usr/local/java/jre1.6.0_21/jre/lib/amd64/libnpjp2.so /usr/lib/Mozilla/plug-in/libjavaplugin.so
If libnpjp2.so resides in a dissimilar directory in your installation, and your Firefox plug-in is in a dissimilar directory, alter the path as required. After that start again any browsers you have release. Install.jsp to observe if it is documented or type:
Code:
about: plugins
In the Firefox's URL bar to test for Sun Java.
Reply With Quote
  #4  
Old 03-01-2011
Member
 
Join Date: Oct 2010
Posts: 52
Re: Install Java 6.21 Plug-in For Linux Mint 9 x64 with FF 3.6.10

I establish your post pretty helpful later than installing the 1.6.0_22 Java update. Both Ff and command line explained me still utilizing 1.6.0_18 version, and when I memorized something regarding having to perform a config command, I not recall the procedure. I did discover though, later than executing the "sudo update-alternatives --config java" and choosing the most recent Sun Java, the Mozilla link was previously taken care of by a link to "/etc/alternatives/mozilla-javaplugin.so" that was after that linked to "/usr/lib/jvm/java-6-sun/jre/lib/amd64/libnpjp2.so". To be sure, the main page for command "update-alternatives" shapes the major purpose is to "keep symbolic links determining default commands."
Reply With Quote
Reply

  TechArena Community > Software > Operating Systems
Tags: , , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Install Java 6.21 Plug-in For Linux Mint 9 x64 with FF 3.6.10"
Thread Thread Starter Forum Replies Last Post
How to install java plug-in Google Chrome Mudam Technology & Internet 4 23-05-2011 08:51 AM
What about Permissions , NTFS and java in linux mint Kensington Operating Systems 4 13-01-2011 10:51 PM
Linux Mint 10 cannot install package Umrao J Operating Systems 5 12-01-2011 06:44 AM
Cannot install Linux Mint ThenOOPUR Operating Systems 4 08-01-2011 06:23 AM
Installing Java on Linux Mint 10 hAVELOCK Operating Systems 3 03-01-2011 10:43 PM


All times are GMT +5.5. The time now is 09:36 PM.