Go Back   TechArena Community > Software > Operating Systems
Become a Member!
Forgot your username/password?
Tags Active Topics RSS Search Mark Forums Read

Reply
 
Thread Tools Search this Thread
  #1  
Old 30-12-2010
Member
 
Join Date: Dec 2010
Posts: 2
"Access Denied", XP in home network

I have 3 pc's running Win98, XP, Vista. Networked via a BT home hub.

Only problem is, neither Win98 nor Vista can access files or printer on XP. Win98 accesses Vista and vice-versa, XP accesses them both, but produces "Access Denied" or "You may not have permissions" to all attempts to access itself.

Both XP and Vista are on auto-update. Win98 is the basic version untouched since 1998 and has never connected to the internet, but I don't need it to.

I'm logged in as administrator on both XP and Vista. Never did work out access rights on Win98. The home hub sees all three machines.

I've tried disabling all the firewalls and antivirus (after disconnecting from the telephone line) -no difference.
I've trawled through every thread I can find but they all have some significant difference from mine in the symptoms described. Nonetheless I've tried several of the "cures" without success.

The killer is that this has been a problem for some considerable time but I'm usually intent on achieving something when problems arise so I've got altogether too smart at "workarounds". But carrying a USB stick between machines doesn't seem right in 2011.

I'll be very pleased if someone can point me at a solution
Reply With Quote
  #2  
Old 06-01-2011
Member
 
Join Date: Dec 2007
Posts: 459
Re: "Access Denied", XP in home network

I think that on Win98, make sure that Client for Microsoft Networks and File and Printer Sharing are enabled. On the WinXP computers, you can also try to create local user account(s), with non-blank password(s), that have the desired access privileges to the desired shares. Log on to the other PCs using those account(s), and you will be able to access the designated shares, provided your network is configured properly. Also, if running WinXP SP1 or later, make sure that WinXP's built-in firewall is disabled on the internal LAN connection. If using WinXP SP2, make sure that you've either disabled the built-in firewall, or set the firewall to allow file and print sharing.
Reply With Quote
  #3  
Old 07-01-2011
Member
 
Join Date: Dec 2010
Posts: 2
Re: "Access Denied", XP in home network

Thank you for responding. After posting I found "How to ask questions the smart way" by ES Raymond, which was a bit of an eye-opener.
I'm not an expert, nor a newbie, and I think I've done everything that a diligent non-expert might be expected to do before troubling you. What I didn't do is to tell you the detail of what I've done, probably because I didn't think you'd want to read several pages.
In Precis: I've been through the Microsoft support forums at length. A search on "Access Denied, XP" gets over 20k hits, and I selected about ten of the reasonably recent descriptions closest to mine and explored and actioned each one in depth to the best of my ability.
Win 98 is an archive function and seldom switched on: I used it to show that it and Vista communicate, indicating that the problem is in XP. (maybe!). I'm willing to ignore it while I fix the main issue.
XP is Home SP3. I found the long way round that it doesn't have "Simple file sharing"
XP & Vista share the same workgroup name.
On both machines, everything is enabled except "password protected sharing" and "TC/IP v6". I disabled TC/IP v6 as part of a fix for something else that didn't work (a long time ago).
Windows firewalls are set to Private network. The other firewalls which were installed have been disabled
Both machines have all user accounts removed except Administrator and Guest. The user name and passwords are identical, the guest accounts are enabled.
The IRP StackSize is now set to 27 (decimal).
I've reinstalled Networking on XP times without number. I've tried to run Netsetup.exe from the XP on the Vista machine but it won't have it. ("Failed")
I haven't found any way to re-setup networking on Vista, it just doesn't seem to recognise the possibility of a simple cabled network.
Vista "sees" XP under "Network", but not under "Network and Sharing centre"
That last is true whether connected via cable or wireless.
"View Full Map" in Network and Sharing center produces an error message "..cannot connect....Responses delayed.. or there is an incompatible router. Remove the router" {That will fix it, no router= no network. It's a BT homehub2, so not probable as a culprit.}. I've done everything appearing in Help& Support arising from that.
I've tried to download LLTD Protocol to XP. (Twice) I can't tell if it's actually happened .
Until an hour ago I would have said that I could copy a file from XP to Vista. Now I discover I can't "Cannot copy... Access Denied... Make sure the disc is not full or write protected" (Both folders are Shared with "everybody" and there is loads of disc space)
I can copy from Vista to XP using the XP machine. ie XP will let stuff in but nothing out.

By now you must be finding this boring. My current fix is to do all file transfers via a USB stick, and I've installed the printer to both machines seperately so I can connect either by swapping the USB cable.
Hi-tech eh!

I really don't expect anyone to fix the problem without hands-on but I don't think this is an "ordinary" query and I would appreciate any guidance as to where I might look. Perhaps looking will make me an expert.
Reply With Quote
Reply

  TechArena Community > Software > Operating Systems
Tags: , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: ""Access Denied", XP in home network"
Thread Thread Starter Forum Replies Last Post
Windows 7 home Premium "backup" cannot access network drives TheHibiscus Networking & Security 4 16-01-2011 07:31 PM
XP Home sp3 "access is denied" Jimmy G Windows XP Support 2 28-02-2010 12:13 AM
"Access denied" error in a subfolder that the user has "full-control Justvicks Active Directory 1 19-10-2009 09:48 AM
Vista "Access Is Denied" Trying to Access Network Share akhtar Windows Vista Network 2 26-03-2007 05:48 PM
"access denied" with robocopy to a network folder Spin Windows Server Help 2 31-07-2006 01:36 AM


All times are GMT +5.5. The time now is 01:05 PM.