Go Back   TechArena Community > Software > Operating Systems
Become a Member!
Forgot your username/password?
Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



Windows 7:Microsoft Excel Application entry missing in DCOMCNFG

Operating Systems


Reply
 
Thread Tools Search this Thread
  #1  
Old 04-12-2010
Member
 
Join Date: Nov 2010
Posts: 12
Windows 7:Microsoft Excel Application entry missing in DCOMCNFG
  

Hello friends, I am the user of the Windows 7. I had loaded the application in ASP.NET which make use of the Excel application objects. it use to work on my Windows XP but in Windows 7 I get the error message that: Retrieving the COM class factory for component with CLSID {00025400-0000-0000-C000-000000000047} failed due to the following error: 80700005. I have to give the permission to the MS Excel application in to the DCOM config but I am unable to find this in the Windows 7. It was there in the older version of but now it?s not there I think. I also reinstalled the Office 2007 but I was unable to get the DCOM config. Please help what can I do now?

Reply With Quote
  #2  
Old 04-12-2010
Member
 
Join Date: Nov 2009
Posts: 681
Re: Windows 7:Microsoft Excel Application entry missing in DCOMCNFG

I had solved this problem: 1) in to the DCOMCONFIG, first right click on to the My computers on the desktop and then select the properties. 2) in that select the COM security tab. 3) now go in to the access permission click on to the Edit Defaults and add the Network Service to it and give the permission as Allow local access. Try this same for <Machine_name>\Users 4) after that go to the launch and Activation Permissions and then select Edit Defaults and add Network Service to it and give it "Local launch" and "Local Activation" permission. Also do this same for <Machine_name>\Users. Complete the process by pressing the OK button. This worked for me
Reply With Quote
  #3  
Old 04-12-2010
Member
 
Join Date: Apr 2009
Posts: 990
Re: Windows 7:Microsoft Excel Application entry missing in DCOMCNFG

In to the windows 7, try to open the DCOM config, to open it: first click on to the start button and then click on the search window, in that type DCOMCONFIG.EXE and then press enter. After that click the computers, in that DCOM config and then locate the component with the CLSID {00024500-0000-0000-C000-000000000046} and then alter or modify the given permission. If now still the error occurs then disable UAC and check if the application works.
Reply With Quote
  #4  
Old 04-12-2010
Member
 
Join Date: Nov 2009
Posts: 861
Re: Windows 7:Microsoft Excel Application entry missing in DCOMCNFG

Have you ever view the MS Excel Application in to the DCOMCNFG? If you have seen DCOMCNFG then try to modify its permission. After that change the permission for the registry key: HKEY_CLASSES_ROOT\CLSID
Open regedit and then locate [HKEY_CLASSES_ROOT\CLSID]. After it right click on to the CLSID key and select the Permissions. Select the add button and then type in everyone and then Allow Full Control.
Reply With Quote
  #5  
Old 04-12-2010
Member
 
Join Date: Nov 2009
Posts: 754
Re: Windows 7:Microsoft Excel Application entry missing in DCOMCNFG

Try to do this:
1) First click on to the Start option , in that select the control panel, in that select the Administrative Tools, from that select the component services.
2) In the Console Root select the Root, from that component services, select the computers, from computers go to the My Computers>DCOM congif
3) Now go at the MS Excel and right click on the application icon and select properties, in that select the security tab.
4) Customize the Launch and activation permission and the add the local ASP.NET user and give all the permission.
Reply With Quote
  #6  
Old 04-12-2010
mv mv is offline
Member
 
Join Date: May 2008
Posts: 681
Re: Windows 7:Microsoft Excel Application entry missing in DCOMCNFG

I had got the solution for this issue by giving the permission at the system level by following these steps: go to the DCOMCNFG, now in the left tree structure right click on to the My Computers and in that select the properties. Choose the tab of the COM security. Try to give the Permissions on to the Network Service and the Users in the "Access Permissions" and by clicking the Edit Default button "Launch and Activation Permissions".
Reply With Quote
  #7  
Old 15-09-2011
Member
 
Join Date: Sep 2011
Posts: 1
Re: Windows 7:Microsoft Excel Application entry missing in DCOMCNFG

If you are using 32 bit version of Excel on 64 bit OS then it won't appear.

You'll need to go start > mmc -32 > file > Add/Remove Snap-in > add component services...

and you should see Excel in there
Reply With Quote
Reply

  TechArena Community > Software > Operating Systems
Tags: , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Windows 7:Microsoft Excel Application entry missing in DCOMCNFG"
Thread Thread Starter Forum Replies Last Post
How to lock a cell after making entry in Microsoft Excel SirName MS Office Support 2 07-02-2012 07:46 PM
getting error:?KERNEL32.DLL ENTRY POINT MISSING? on windows XP Ebadaah28 Operating Systems 3 19-06-2011 03:36 AM
My Computer properties (Windows 7 RTM) Missing values in dcomcnfg $OLIVER$ Technology & Internet 3 19-02-2011 08:21 PM
In DCOMCnfg Run application on this computer is grayed out for my application on two Windows 7 machines Nauset Operating Systems 6 29-08-2010 06:15 AM
Issue with Microsoft Excel application in DCOMCNFG Heraclio Windows Software 4 11-08-2010 02:36 AM


All times are GMT +5.5. The time now is 07:08 PM.