Results 1 to 5 of 5

Thread: Ubuntu:WOL doesn't work

  1. #1
    Join Date
    Apr 2010
    Posts
    53

    Ubuntu:WOL doesn't work

    Hi friends, I tried to turn on my Ubuntu 8.04 workstation remotely with the help of the Ubuntuforums.org web site. I was unable to configure it. I performed the certain steps on my work station firstly enabled Wake On LAN (WOL) in the BIOS for Ethernet adapter 0. And perform many other steps to connect it. I also tried many times to turn system on from the remote laptop on to the subnet using the magic packet method. But nothing happens. It doesn’t turned ON. I then tried to turn it on from the DD-WRT on the same subnet, nothing happens. Anyone have the idea how to solve this problem. I don’t understand why it won’t work.

  2. #2
    Join Date
    Nov 2009
    Posts
    1,035

    Re: Ubuntu:WOL doesn't work

    My suggestion to you is to install the Ubuntu 10 or even Ubuntu 9. Because it has much better remote support to the remote access. Or even if you want to continue to work with Ubuntu 8.04, then first check that led on to the net card is still lightning up after you powering your computer system off. Secondly check for the status (ethtool eth0) after bringing the interface down (ifdown eth0) if it still has "wake on:g".

  3. #3
    Join Date
    May 2008
    Posts
    681

    Re: Ubuntu:WOL doesn't work

    If you are making use of the command “wakeonlan” without the –p option, then make use of your router to forward port9 UDP to the computer on to the internal network. I am not very sure that how well it work with the router when the system is turned off. It will now don’t have an IP address to forward. After this you will need a utility which sends the packet with the help of the internet to an IP. I have not done any research in to the precise aspect of the LAN network. What you want to do is when you wake from the internet, find for the system that is ON, and ssh is in, and then send packets through that path. See that whether it works for your WAN.

  4. #4
    Join Date
    Apr 2009
    Posts
    996

    Re: Ubuntu:WOL doesn't work

    As much as know about the problem of the WOL cable connector, most of the motherboard producers use to add it for the purpose of the compatibility with the old Network Interface Card most commonly known as the NIC. Even if your computer has the modern motherboard of PCI 2.1 compliant still you can find Wake On Lan cable connectors. Currently it is esdy to found out such kind of cable in a second hand shops or you can find it out on the eBay. I am not very confirm from when PCI 2.1 is a standard. Check it whether your motherboard is produced after. I think this will help you.

  5. #5
    Join Date
    Nov 2009
    Posts
    867

    Re: Ubuntu:WOL doesn't work

    This script was also not working for me but then I saw that the LED on to my router corresponding to the computer. What I tried is , I decided to remove the –i from the halt as suggested and it really worked. What I did is created the back up of the /etc/init.d/halt script, after it edited the /etc/init.d/halt script, and then I locate the line where the halt command is invoked. The code I typed is : halt –d –f –I spoweroff shddown.
    Finally removed the –i keyword from it. It worked for me.

Similar Threads

  1. Suspend doesn't work properly with ubuntu
    By leshaspar in forum Operating Systems
    Replies: 5
    Last Post: 18-11-2010, 06:31 AM
  2. Replies: 3
    Last Post: 26-06-2010, 10:56 PM
  3. Dual booting Fedora 11 with Ubuntu 9.04 doesn't work
    By Fedora Rocher in forum Operating Systems
    Replies: 3
    Last Post: 22-10-2009, 02:13 PM
  4. Wireless doesn't work on Ubuntu 9.04 for MacBook 4,1
    By MacIntel in forum Operating Systems
    Replies: 3
    Last Post: 01-09-2009, 06:30 PM
  5. Replies: 1
    Last Post: 06-01-2009, 11:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •