Results 1 to 5 of 5

Thread: Toshiba L650 11f shows error with recent kernels

  1. #1
    Join Date
    Oct 2010
    Posts
    237

    Toshiba L650 11f shows error with recent kernels

    Several month ago I father bought me a branded Toshiba L650 11f laptop. I had an ubuntu 10.04 live CD but I couldn’t make it run on my laptop. When I try to run the CD the system shows me a list error messages. Then I thought that I should install the ubuntu 9.10 first and will try to upgrade it. My idea successfully works. I managed to upgrade 10.04 easily without any problem. I noticed that the only kernel 2.6.31-22. Has anyone suffered from this kind of issue before? How can fix this headache? I tried to upgrade to newer version of ubuntu but I got the same response.

  2. #2
    Join Date
    Feb 2010
    Posts
    546

    Re: Toshiba L650 11f shows error with recent kernels

    This kind of error occurs when the ubuntu kernel doesn’t match its requirements. Some of the hardware configuration in your system doesn’t allowing the ubuntu kernel. So need to check the compatibility of your hardware first. It may include your CPU, processor, video card, output of ispci and also the PCI cards. This is not only your issue. Many of Toshiba users are suffering this. As I can it might be only the Hardware parts that are causing the problem.

  3. #3
    Join Date
    Feb 2010
    Posts
    524

    Re: Toshiba L650 11f shows error with recent kernels

    As I have gone through your problem I concluded that it is the ACPI problem in your Toshiba Satellite that is restricting the ubuntu kernel. I heard that there is a patch available for those who are suffering the ACPI problem. This patch might be included in the next kernel 2.6.36 which will be going to release soon or later. Now you are trying to install ubuntu 10.04 (kernel 2.6.35). You will notice the changes when you add adding 'acpi=copy_dsdt' to the boot parameters. You can add these parameters setting the end of the kernel line

  4. #4
    Join Date
    Feb 2010
    Posts
    537

    Re: Toshiba L650 11f shows error with recent kernels

    If your system doesn’t accept the newer version of ubuntu directly then you can use old distribution and then upgrade it to the latest version. But you have to still use the kernel from the older distribution otherwise it won’t allow you to install or upgrade. It is not the good trick but it works well. I have done the same thing in my computer. I figured it out that it will work in debian stable. I upgraded it by keeping the old kernel and it started working as I assumed.

  5. #5
    Join Date
    Feb 2010
    Posts
    766

    Re: Toshiba L650 11f shows error with recent kernels

    The problem exists due to some faulty Bios regarding poor or non existing ACPI options and some of the kernel bugs in ACPI. I solved this problem by adding a little configurations to "noapic nolapic acpi=ht" which is in lilo.conf file. This helps me to disable the ACPI. To test this open the file /etc/lilo.conf and create a first line like given below:
    append=" vt.default_utf8=0 noapic lapic acpi=ht
    then save the lilo.conf and return.

Similar Threads

  1. Modem dropping connection with Toshiba Satellite L650
    By Annamalai in forum Portable Devices
    Replies: 7
    Last Post: 19-09-2011, 07:30 AM
  2. Toshiba Satellite L650 gives error at every boot
    By Badmannah in forum Portable Devices
    Replies: 4
    Last Post: 06-04-2011, 10:48 PM
  3. Toshiba Satellite L650, black screen with windows 7
    By Lopazax98 in forum Portable Devices
    Replies: 5
    Last Post: 01-04-2011, 07:32 PM
  4. Toshiba L650/OE8 vs Dell XPS 15
    By cHYNA in forum Portable Devices
    Replies: 5
    Last Post: 30-01-2011, 06:36 AM
  5. Asus N61 vs Toshiba satellite L650
    By The EClipse in forum Portable Devices
    Replies: 5
    Last Post: 28-12-2010, 06:02 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •