Results 1 to 6 of 6

Thread: Suspend doesn't work properly with ubuntu

  1. #1
    Join Date
    Oct 2010
    Posts
    108

    Suspend doesn't work properly with ubuntu

    Hello friends, I have ubuntu 10.0 AMD 54 on my HP laptop, after I had installed the ubuntu it worked fine without any problem and I was able to use all the functionality of the linux operating system. It was just that when I was trying to turn off my laptop I found that the suspend functionality was not working properly. When i Tried to hibernate the laptop it gave some some error messages but when o tried to suspend the laptop the screen turned off and after quite some time it aging showed the login screen. The only way to turn it off is to switch of the power supply , I know this is dangerous but I dont have any option left so please can any one help me sort out this issue as quickly as possible.

  2. #2
    Join Date
    Nov 2009
    Posts
    1,416

    Re: Suspend doesn't work properly with ubuntu

    Hello dear looks like you are in a real mess, the laptop is refusing to turn off is a very awful thing and this is kind of problem usually occurs when either the suspend or something else related to shutdown options are having some defection in it. So i would like to request to use log files to locate where exactly your problem lies. I was also facing trge same problem but after using the log files I found that mu Nvidia Geforce is having the problem as it cant be suspended. So after searching the web I got to know that we have to install some drivers as this is caused due to some malfunction of the drivers in the computer system. So first make use of the log file to come to know what the problem is.

  3. #3
    Join Date
    Nov 2009
    Posts
    1,292

    Re: Suspend doesn't work properly with ubuntu

    When a computer is Hibernating, it's the same as switching off the computer system such as it does not consume any more electricity.When you hibernate your computer system the computer memory is actually released out of disk and your computer stays there until you turn the computer back on. Since all this related to your hard disk as well as your internal hardware of the laptop so I guess that there is something wrong with either your control bus or the main power of the laptop. So I guess to avoid any further damage to the laptop you should quickly consult the engineer as he will be able to sort out the issue since he knows each and every minute details of the laptop hardware.

  4. #4
    Join Date
    Oct 2010
    Posts
    108

    Re: Suspend doesn't work properly with ubuntu

    Hey I have done exactly as you said I use the log files to search out where exactly the problem lies and found out it was in my hard disk. So I installed the drivers which were required by this and after installing the drivers when I again switched of my computer I got the error again but this related to AHCI controller which is again related to internal hardware and the memory. So now how can I be able to overcome this issue, I have tried calling the hardware technician and since he is out of town for few weeks I cannot wait until so long. So can any one come up with a nice solution to overcome this problem.

  5. #5
    Join Date
    Nov 2009
    Posts
    1,269

    Re: Suspend doesn't work properly with ubuntu

    I think your kernel might have been got damaged due to some electrical stroke in the laptop. Since you have mentioned in the post that you are having 54 AMD and this is one of the cheapest available in the market so I guess that due to the lower feature model the kernel might have got damaged which is causing this problem. Also you are at the same time using ubuntu so I would reckon you to use Debian and Fedora since they have the best collection of scripts for the suspend/hibernate stuff. This is all because they have added power manager which helps them to make the task more simpler without causing any problem.

  6. #6
    Join Date
    Apr 2009
    Posts
    1,108

    Re: Suspend doesn't work properly with ubuntu

    Hey since after using the log files you found out there is something wrong with the AHCI controllers them I would suggest you to use modprobe ahci and see if solves your error. The Advanced Host Controller Interface (AHCI) is a host controller interface which defines the operation of SATA host bus adapters. This is used to exchange data between host system memory and attached storage device. If this is defected then its obvious that there would be a problem of transferring the data. So I guess if you use modprobe then you might be able to overcome the problem.

Similar Threads

  1. Suspend, Hibernate unable to work in ubuntu 10.04
    By Bellare in forum Operating Systems
    Replies: 9
    Last Post: 31-03-2012, 01:10 AM
  2. The application DES 2.0 doesn't work properly
    By Rainbow in forum Windows Software
    Replies: 3
    Last Post: 25-05-2011, 07:19 PM
  3. In xbox 360 ventilation doesn't work properly.
    By Ikrama in forum Portable Devices
    Replies: 5
    Last Post: 19-05-2011, 07:41 PM
  4. Ubuntu:WOL doesn't work
    By Strangers in forum Operating Systems
    Replies: 4
    Last Post: 18-11-2010, 05:16 AM
  5. Wireless doesn't work on Ubuntu 9.04 for MacBook 4,1
    By MacIntel in forum Operating Systems
    Replies: 3
    Last Post: 01-09-2009, 06:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •