Go Back   TechArena Community > Software > Operating Systems
Become a Member!
Forgot your username/password?
Register Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



HP Mini 110 with Ubuntu 10.04 but no sound

Operating Systems


Reply
 
Thread Tools Search this Thread
  #1  
Old 15-11-2010
Member
 
Join Date: Nov 2010
Posts: 78
HP Mini 110 with Ubuntu 10.04 but no sound
  

I have the HP Mac Mini with me and there was no issue with the same as long as I was running the Windows Vista on it. After that I tried to have the Windows 7 on the same laptop and that too was serving me pretty nicely but the issue started when I switched to the Ubuntu. Well I thought that it will be nice if I can have some non Windows system with me and hence I thought of having the Ubuntu. Well the installation of the OS went pretty nice and I think that ended well too. Now the thing is that I cannot hear the sound from the laptop when it is in the Ubuntu mode. Please help me in this situation as I am new to the environment of Ubuntu and it will be nice if I can have some easy steps to get back the sound on this laptop.

Reply With Quote
  #2  
Old 15-11-2010
Member
 
Join Date: Nov 2009
Posts: 1,416
Re: HP Mini 110 with Ubuntu 10.04 but no sound

Well I think that you are not aware of the fact that though you have both the Ubuntu and the Windows 7 on the same system but then too you are required to have the drivers for both the Operating System. I will suggest you to have the drivers for the same so that you can have the sound back on track. Just pay a visit to the official site and I am sure that you will have the right drivers for you. Well in addition to that I would suggest you to see for the CD that came along with the Hardware, I am sure that you will be having the drivers for the same on that particular CD. Please have a look at this and I am sure that you will be out of the trouble in no time. Please let me know about the same in your next post.
Reply With Quote
  #3  
Old 15-11-2010
Member
 
Join Date: Nov 2009
Posts: 1,292
Re: HP Mini 110 with Ubuntu 10.04 but no sound

Looking at the scenario of yours I think that there is some issue with the Pulse Audio. Well that is I think in the UserSpace. From your description I think that the card is recognized but is not being used. The problem is definitely in the userspace and precisely in the Pulse Audio volume control. I would suggest you to have the reinstallation of the Pulse and see if the reinstallation does the trick here. For doing that here is the code that can assist you a bit:
Code:
$ sudo apt-get purge pulseaudio && sudo apt-get install pulseaudio
Reply With Quote
  #4  
Old 15-11-2010
Member
 
Join Date: Nov 2009
Posts: 1,269
Re: HP Mini 110 with Ubuntu 10.04 but no sound

Whatever may be the case here but I am of the opinion that what I think that what Zhankana_n said is true. Well the issue of the Pulse Audio comes later but if there is no driver then I do not think that there is anything called Pulse Audio that can pop up here. Well I think you will have to have the right drivers and you will be able to get the same from the official site of the Motherboard. In addition to that I think that the drivers that you have is not going to help you, as the version for the Ubuntu is 10.04. It will be nice if you can have the latest one from there itself. Once you get the drivers let me know about it and I will help you with the configurations.
Reply With Quote
  #5  
Old 15-11-2010
Member
 
Join Date: Nov 2008
Posts: 1,185
Re: HP Mini 110 with Ubuntu 10.04 but no sound

Well I think that I can do a little help here. I have also come across the same situation. Well I was caught with this issue when I had changed the Connector option in the Output Tab. I had changed the option to the Analog Headphones. Well I think that you must have done that by mistake or that must have been the option there. I just changed the Connector option back to the Analog Output and after that every single issue is solved. Please check this and let me know if at all that was the reason behind this. Happy to contribute here.
Reply With Quote
  #6  
Old 16-11-2010
Member
 
Join Date: Nov 2009
Posts: 1,035
Re: HP Mini 110 with Ubuntu 10.04 but no sound

I have the perfect thing for this scenario. Here is the thing that I did and I am sure that this can help you in this matter. I am saying this as I was also struck with the similar situation and one of my friend whom we call Linux Expert helped me in getting the sound on the right track. Hope that this will also help you here. He also did a bit of googling and then after multiple attempts he was able to get the sound. He simply added the following option options snd-hda-intel model=ref to the /etc/modprobe.d/alsa-base.conf and the sound came flying after the restart. Well in my case I was having only Ubuntu on the HP but I am sure that you will have the same in your case too. Please let me know about the same.
Reply With Quote
  #7  
Old 18-11-2010
Member
 
Join Date: Nov 2010
Posts: 78
Re: HP Mini 110 with Ubuntu 10.04 but no sound

Thanks a lot guys the last post really did the trick for me and I am really happy that I have the sound back on the system. Well I even searched the Internet for the drivers for the Ubuntu but I ended up with the old drivers. I think that the previous drivers were really fine and the connection was also established. Really but the reply from Dolsy_bendal really helped in bringing the difference. Well if I will have any further problem I will post regarding the same. Thanks a lot again.
Reply With Quote
  #8  
Old 29-01-2012
Member
 
Join Date: Jan 2012
Posts: 5
Re: HP Mini 110 with Ubuntu 10.04 but no sound

I am a newbi and do not know anything about this stuff. I have no sound and do not know where the file that I am supposed to change with the code is located. Can someone tell me how to locate it. Thanks.
Reply With Quote
  #9  
Old 29-01-2012
Member
 
Join Date: Jun 2011
Posts: 796
Re: HP Mini 110 with Ubuntu 10.04 but no sound

Quote:
I am a newbi and do not know anything about this stuff. I have no sound and do not know where the file that I am supposed to change with the code is located. Can someone tell me how to locate it. Thanks.
You will have to enter "sudo nano /etc/modprobe.d/alsa-base.conf" in the title without the quote and then alsa-base.conf file will get opened so you just have to add options snd-hda-intel model=ref at the end of the file, just try it out and then let me know if you are able to solve it out.
Reply With Quote
  #10  
Old 31-01-2012
Member
 
Join Date: Jan 2012
Posts: 5
Re: HP Mini 110 with Ubuntu 10.04 but no sound

ok i did all that, but it did not do anything. I added options snd-hda-intel model=ref at the end.
Reply With Quote
  #11  
Old 31-01-2012
Member
 
Join Date: Dec 2007
Posts: 1,586
Re: HP Mini 110 with Ubuntu 10.04 but no sound

Can you first try to open a terminal and run alsamixer and turn all the volume levels all the way up. Then see if you have sound. After running aplay -l and lspci -v and determining that your sound card is indeed detected, then run lsmod and see if the proper drivers are being loaded for your card.
Reply With Quote
  #12  
Old 31-01-2012
Member
 
Join Date: Jan 2012
Posts: 5
Re: HP Mini 110 with Ubuntu 10.04 but no sound

Well I have tried Alsa Mixer many times already. The volume is up. I dont know what aplay -l and lspci -v are, but I did enter a code I found a few days ago to see if my sound card is detected, and it is detected. What are aplay -l and lspci -v? remember I am a newbi and do not have the knowledge of these things.
Reply With Quote
  #13  
Old 31-01-2012
Member
 
Join Date: Jan 2012
Posts: 5
Re: HP Mini 110 with Ubuntu 10.04 but no sound

I entered aplay-I and got this:

**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: HDA Generic [HDA Generic]
Subdevices: 1/1
Subdevice #0: subdevice #0

in ISPCI-v I got :


00:00.0 Host bridge: Intel Corporation N10 Family DMI Bridge
Flags: bus master, fast devsel, latency 0
Capabilities: <access denied>
Kernel driver in use: agpgart-intel
Kernel modules: intel-agp

00:02.0 VGA compatible controller: Intel Corporation N10 Family Integrated Graphics Controller
Subsystem: Hewlett-Packard Company Device 148a
Flags: bus master, fast devsel, latency 0, IRQ 28
Memory at 54180000 (32-bit, non-prefetchable) [size=512K]
I/O ports at 30c0 [size=8]
Memory at 40000000 (32-bit, prefetchable) [size=256M]
Memory at 54000000 (32-bit, non-prefetchable) [size=1M]
Capabilities: <access denied>
Kernel driver in use: i915
Kernel modules: i915

00:02.1 Display controller: Intel Corporation N10 Family Integrated Graphics Controller
Subsystem: Hewlett-Packard Company Device 148a
Flags: bus master, fast devsel, latency 0
Memory at 54100000 (32-bit, non-prefetchable) [size=512K]
Capabilities: <access denied>

00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
Subsystem: Hewlett-Packard Company Device 148a
Flags: bus master, fast devsel, latency 0, IRQ 16
Memory at 54200000 (64-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: HDA Intel
Kernel modules: snd-hda-intel

00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 02)
Flags: bus master, fast devsel, latency 0
Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
I/O behind bridge: 00002000-00002fff
Memory behind bridge: 53000000-53ffffff
Prefetchable memory behind bridge: 0000000050000000-0000000050ffffff
Capabilities: <access denied>
Kernel driver in use: pcieport
Kernel modules: shpchp

00:1c.1 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 2 (rev 02)
Flags: bus master, fast devsel, latency 0
Bus: primary=00, secondary=02, subordinate=02, sec-latency=0
I/O behind bridge: 00001000-00001fff
Memory behind bridge: 52000000-52ffffff
Prefetchable memory behind bridge: 0000000051000000-0000000051ffffff
Capabilities: <access denied>
Kernel driver in use: pcieport
Kernel modules: shpchp

00:1d.0 USB Controller: Intel Corporation N10/ICH7 Family USB UHCI Controller #1 (rev 02)
Subsystem: Hewlett-Packard Company Device 148a
Flags: bus master, medium devsel, latency 0, IRQ 16
I/O ports at 3080 [size=32]
Kernel driver in use: uhci_hcd

00:1d.1 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 02)
Subsystem: Hewlett-Packard Company Device 148a
Flags: bus master, medium devsel, latency 0, IRQ 18
I/O ports at 3060 [size=32]
Kernel driver in use: uhci_hcd

00:1d.2 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 02)
Subsystem: Hewlett-Packard Company Device 148a
Flags: bus master, medium devsel, latency 0, IRQ 17
I/O ports at 3040 [size=32]
Kernel driver in use: uhci_hcd

00:1d.3 USB Controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 02)
Subsystem: Hewlett-Packard Company Device 148a
Flags: bus master, medium devsel, latency 0, IRQ 19
I/O ports at 3020 [size=32]
Kernel driver in use: uhci_hcd

00:1d.7 USB Controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 02) (prog-if 20)
Subsystem: Hewlett-Packard Company Device 148a
Flags: bus master, medium devsel, latency 0, IRQ 16
Memory at 54204400 (32-bit, non-prefetchable) [size=1K]
Capabilities: <access denied>
Kernel driver in use: ehci_hcd

00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2) (prog-if 01)
Flags: bus master, fast devsel, latency 0
Bus: primary=00, secondary=03, subordinate=03, sec-latency=32
Capabilities: <access denied>

00:1f.0 ISA bridge: Intel Corporation NM10 Family LPC Controller (rev 02)
Subsystem: Hewlett-Packard Company Device 148a
Flags: bus master, medium devsel, latency 0
Capabilities: <access denied>

00:1f.2 SATA controller: Intel Corporation N10/ICH7 Family SATA AHCI Controller (rev 02) (prog-if 01)
Subsystem: Hewlett-Packard Company Device 148a
Flags: bus master, 66MHz, medium devsel, latency 0, IRQ 26
I/O ports at 30b8 [size=8]
I/O ports at 30cc [size=4]
I/O ports at 30b0 [size=8]
I/O ports at 30c8 [size=4]
I/O ports at 30a0 [size=16]
Memory at 54204000 (32-bit, non-prefetchable) [size=1K]
Capabilities: <access denied>
Kernel driver in use: ahci
Kernel modules: ahci

00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 02)
Subsystem: Hewlett-Packard Company Device 148a
Flags: medium devsel, IRQ 10
I/O ports at 3000 [size=32]
Kernel modules: i2c-i801

01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 04)
Subsystem: Hewlett-Packard Company Device 148a
Flags: bus master, fast devsel, latency 0, IRQ 27
I/O ports at 2000 [size=256]
Memory at 50004000 (64-bit, prefetchable) [size=4K]
Memory at 50000000 (64-bit, prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: r8169
Kernel modules: r8169

01:00.1 Class ff00: Realtek Semiconductor Co., Ltd. Device 5288 (rev 01)
Subsystem: Hewlett-Packard Company Device 148a
Flags: bus master, fast devsel, latency 0, IRQ 10
Memory at 53000000 (32-bit, non-prefetchable) [size=64K]
Capabilities: <access denied>

02:00.0 Network controller: RaLink RT3090 Wireless 802.11n 1T/1R PCIe
Subsystem: RaLink RT3090 Wireless 802.11n 1T/1R PCIe
Flags: bus master, fast devsel, latency 0, IRQ 17
Memory at 52000000 (32-bit, non-prefetchable) [size=64K]
Capabilities: <access denied>
Kernel driver in use: rt2860
Kernel modules: rt3090sta


in Ismod :
Module Size Used by
binfmt_misc 6587 1
ppdev 5259 0
fbcon 35102 71
tileblit 1999 1 fbcon
font 7557 1 fbcon
bitblit 4707 1 fbcon
softcursor 1189 1 bitblit
snd_hda_codec_idt 52042 0
vga16fb 11385 0
vgastate 8961 1 vga16fb
joydev 8740 0
snd_hda_intel 22069 1
snd_hda_codec 74201 2 snd_hda_codec_idt,snd_hda_intel
snd_hwdep 5412 1 snd_hda_codec
snd_pcm_oss 35308 0
snd_mixer_oss 13746 1 snd_pcm_oss
snd_pcm 70694 3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd_seq_dummy 1338 0
snd_seq_oss 26722 0
snd_seq_midi 4557 0
snd_rawmidi 19056 1 snd_seq_midi
snd_seq_midi_event 6003 2 snd_seq_oss,snd_seq_midi
snd_seq 47263 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer 19130 2 snd_pcm,snd_seq
snd_seq_device 5700 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
i915 289715 3
drm_kms_helper 29329 1 i915
snd 54244 14 snd_hda_codec_idt,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_os s,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
drm 163747 4 i915,drm_kms_helper
i2c_algo_bit 5028 1 i915
uvcvideo 57438 0
lp 7028 0
rt3090sta 905769 1
psmouse 63677 0
intel_agp 24375 2 i915
video 17375 1 i915
videodev 34425 1 uvcvideo
v4l1_compat 13251 2 uvcvideo,videodev
serio_raw 3978 0
cfg80211 126528 1 rt3090sta
soundcore 6620 1 snd
snd_page_alloc 7076 2 snd_hda_intel,snd_pcm
agpgart 31724 2 drm,intel_agp
output 1871 1 video
parport 32635 2 ppdev,lp
r8169 34140 0
mii 4381 1 r8169
ahci 32680 2

I do not understand this stuff, so if you do, I would love some help understanding what to do. Thanks.
Reply With Quote
  #14  
Old 31-01-2012
Member
 
Join Date: May 2008
Posts: 5,837
Re: HP Mini 110 with Ubuntu 10.04 but no sound

Try to add the below and see if it works:

add:
options snd-hda-intel model=ref

To:
/etc/modprobe.d/alsa-base.conf

If that doesnt work then try to change the 'Connector' option in the 'Output' tab in sound preferences to 'Analog Headphones'. After change the 'Connector' option back to 'Analog Output' everything seems fine.
Reply With Quote
  #15  
Old 31-01-2012
Member
 
Join Date: Jan 2012
Posts: 5
Re: HP Mini 110 with Ubuntu 10.04 but no sound

I already tried those things. And in the output it only gives me one option. Internal Audio Analog Stereo. No headphone option or anything. Its weird.
Reply With Quote
Reply

  TechArena Community > Software > Operating Systems
Tags: , , , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "HP Mini 110 with Ubuntu 10.04 but no sound"
Thread Thread Starter Forum Replies Last Post
Installing Ubuntu on the Mac Mini 2011 Akbarha Operating Systems 10 26-01-2012 02:11 AM
Low sound in Sony xperia x10 mini/pro sound Thanos Portable Devices 6 13-05-2011 10:06 PM
Ubuntu Optimized for Dell Mini with SSD SoftWore Tips & Tweaks 2 28-06-2010 01:33 PM
No sound on ubuntu 9.04 on hp mini netbook Patinux Operating Systems 3 23-09-2009 01:25 PM
HP 2133 Mini-Note and ubuntu NavinS Operating Systems 4 03-02-2009 08:37 PM


All times are GMT +5.5. The time now is 11:24 PM.