Go Back   TechArena Community > Software > Operating Systems
Become a Member!
Forgot your username/password?
Register Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



Trouble installing Linksys WUSB600N v2 in backtrack 4 final under VM Workstation 6.5

Operating Systems


Reply
 
Thread Tools Search this Thread
  #1  
Old 07-05-2010
Member
 
Join Date: Apr 2010
Posts: 89
Trouble installing Linksys WUSB600N v2 in backtrack 4 final under VM Workstation 6.5
  

I am having latest release of the backtrack 4 that is installed under VM workstation 6.5.3, now the thing I need to know is how to installs the drivers for Linksys WUSB600N v2 so that backtrack 4 can recognize it.
I have also checked the card compatible with the aircrack suite.

Does anyone know if Linksys WUSB54GC works out of the box or what I have to do to make it work?

Reply With Quote
  #2  
Old 07-05-2010
Member
 
Join Date: Jan 2008
Posts: 3,758
Re: Trouble installing Linksys WUSB600N v2 in backtrack 4 final under VM Workstation 6.5

Here are the steps through which you can get the WUSB600N v2 to work.

First get the RT3572USB driver from Ralink
After that unpack and stuff, cd into directory
Follow the steps that are mentioned in the README, such as enabling wpa_supplicant and networkmanager support
After that search in the file common/rtusb_dev_id.c for similar to this

Code:
{USB_DEVICE(0x1690,0x0744)}, /* 3572 */
{USB_DEVICE(0x5A57,0x0284)}, /* Zinwell 3572 */
{USB_DEVICE(0x167B,0x4001)}, /* 3572 */
After that add this line below it, so that the driver can recognize your WUSB600N as a device that it must support. You can find the actual device id through lsusb, hence it can be applied to any device.


Code:
{USB_DEVICE(0x1737,0x0079)}, /* WUSB600N v2 */
Then make or make install
After that do the distribution-specific stuff for enabling interfaces etc.
My stick is now working without any problem at throughputs of about 7MB/s; I recommend buying it if you need such an adapter.
Reply With Quote
  #3  
Old 07-05-2010
Member
 
Join Date: Apr 2010
Posts: 82
Re: Trouble installing Linksys WUSB600N v2 in backtrack 4 final under VM Workstation 6.5

I am interested in knowing that whether the devices,
1. Linksys WUSB600N (802.11a/b/g/n compliant)
2. DLINK DWL-AG132 (802.11a/b/g compliant)

Can be used on any Linux platforms such as; Redhat Enterprise Linux V5, Fedora 8/9, Ubuntu, SUSE, etc. If yes then are the drivers for these devices are available or not.

Any related reply will be appreciated.
Reply With Quote
  #4  
Old 07-05-2010
Member
 
Join Date: May 2008
Posts: 4,564
Re: Trouble installing Linksys WUSB600N v2 in backtrack 4 final under VM Workstation 6.5

All work with some help, but it is a chip on the card is not a company to sell them. But I am not sure what all the chips CIP I now work with ndiswrapper then program and then use Windows drivers. I have mine set up both ways. I am a hard ware geek, but you can search Google for more information and the driver you need.
Reply With Quote
  #5  
Old 07-05-2010
Member
 
Join Date: May 2008
Posts: 4,344
Re: Trouble installing Linksys WUSB600N v2 in backtrack 4 final under VM Workstation 6.5

The only option for these devices is to use ndiswrapper
But I want to know what will be the performance price one has to pay for this. I mean is the driver for these devices are provided by the product vendor or it is distributed by the chip vendor?
One more thing, will it be available to me? Or I have to buy RED HAT ENT Edition 5 along with the support or maintenance?
Reply With Quote
  #6  
Old 08-05-2010
Member
 
Join Date: Feb 2010
Posts: 207
Re: Trouble installing Linksys WUSB600N v2 in backtrack 4 final under VM Workstation 6.5

I am facing problem with the installation of the wusb600n driver, I have downloaded it from the Linksys website. The which I am using are the one are used for XP:
Driver.2K* rt2870.cat* rt2870.inf* rt2870.sys*
Currently I am using ndiswrapper for loading the rt2870.inf and it is displaying the message that ndiswrapper is not having an interface. My operating system is linux on KDE, Kernel version is 2.6.18.8.

Any help will do, thank you
Reply With Quote
  #7  
Old 10-05-2010
Member
 
Join Date: Feb 2010
Posts: 766
Re: Trouble installing Linksys WUSB600N v2 in backtrack 4 final under VM Workstation 6.5

I have had success with the WUSB600N driver comes with XP on disk and ndiswrapper but it is unstable when in WPK1 encryption mode and stops receiving after a short time of any slightly aggressive load.

I would like to stress that I tried Ralink usb2870 ndiswrapped driver and it crashed when I tried to install it? Any suggestions anyone
Reply With Quote
Reply

  TechArena Community > Software > Operating Systems
Tags: , , , , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Trouble installing Linksys WUSB600N v2 in backtrack 4 final under VM Workstation 6.5"
Thread Thread Starter Forum Replies Last Post
Linksys WUSB600N Cadence Networking & Security 5 10-09-2010 11:56 PM
Any one using backtrack 4?I have trouble installing it on VIrtualBox.please help? silvercats Operating Systems 2 20-07-2010 05:12 PM
Problem installing OpenVAS on BackTrack 4 Final Luis-Fernando Operating Systems 6 12-05-2010 11:33 PM
Backtrack 4 Final with VMWare Workstation 6.5.3 Kusumakar Operating Systems 6 10-05-2010 09:53 AM
Trouble Installing BackTrack 4 Final From Live DVD Or USB Laurense Operating Systems 5 07-05-2010 10:41 PM


All times are GMT +5.5. The time now is 05:06 AM.