Go Back   TechArena Community > Software > Operating Systems
Become a Member!
Forgot your username/password?
Tags Active Topics RSS Search Mark Forums Read

Reply
 
Thread Tools Search this Thread
  #1  
Old 21-04-2010
Member
 
Join Date: Mar 2010
Posts: 184
Power management Under Fedora

Hello,
I installed a fresh Fedora 10. Unfortunately (compared to my previous F7 installation on the same NB), the CPU frequency is not in the 800 MHz turned down on.
Here is what I do
Code:
# Cat / sys/devices/system/cpu/cpu0/cpufreq/
Can I manually add the Power safe governor? My CPU supports, according to
Here is the code
Code:
Cat / sys/devices/system/cpu/cpu0/cpufreq/scaling_available_frequencies
Still, I have the problem with it. So, if you have any solution for this then please let me know. Thanks in advance.
__________________
www.techarena.in
Reply With Quote
  #2  
Old 21-04-2010
Member
 
Join Date: Nov 2009
Posts: 347
Re: Power management Under Fedora

Hello,
You should check the file
Code:
/ etc / sysconfig cpuspeed intervene /.
There you should find the line
Code:
GOVERNOR =
Normally the value is empty, this means that by default the governor on demand is loading. But here you can enter the appropriate Governor. In your case this would look like this
You have to modify it in this way
Code:
GOVERNOR = powersave
Reply With Quote
  #3  
Old 21-04-2010
Member
 
Join Date: Apr 2008
Posts: 264
Re: Power management Under Fedora

Hello,
Thanks for the reply, even i am facing the same problem. That would mean that I always Powersafe Mode, or on the road would always would have to change manually. Apart from the fact, I can not imagine that this works, because the "Powersafe" Governor loud "scaling_available_governors not exist? Any more guidance regarding this topic will be appreciated. Thank you for your help .
Reply With Quote
  #4  
Old 21-04-2010
Member
 
Join Date: Nov 2009
Posts: 330
Re: Power management Under Fedora

Hello,
I am indeed just in front of a CentOS, but the same phenomenon here. You can do the following times. Load the module manually by using the command
Here is the code
Code:
modprobe cpufreq_powersave
then you can use
Code:
cat / sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors
check whether the Governor is available. You must then reboot one time to see whether the module also is loaded from the system permanently then.
Reply With Quote
  #5  
Old 21-04-2010
Member
 
Join Date: Mar 2010
Posts: 184
Re: Power management Under Fedora

Hello,
I tried your tip and it worked
The line
Code:
- scaling_available_governors
This line contained Powersafe. However, the module was gone after a restart. How can I convince the kernel, the module to load at startup? That is it should work every time I start my computer. Thank you.
__________________
www.techarena.in
Reply With Quote
  #6  
Old 21-04-2010
Member
 
Join Date: Nov 2009
Posts: 333
Re: Power management Under Fedora

Hello,
Open views to the file / etc / init.d / cpuspeed. At about line 140 rum, it should be a section that looks about.
Code:
# Figure out default governor to use 
case "$ drv" in 
centrino | powernow-k8 | p4-clockmod | acpi-cpufreq | powersaver) 
default_governor = ondemand 
default_governor = user space 
;;
Instead of on demand times you can here powersave about. The file is editable, but only as root.
Reply With Quote
Reply

  TechArena Community > Software > Operating Systems
Tags: , , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Power management Under Fedora"
Thread Thread Starter Forum Replies Last Post
Power management of AMD FX-8120 Bulldozer Cheeru Motherboard Processor & RAM 9 13-04-2012 03:28 PM
power management problem with MSI 870A-G54 Eleder Motherboard Processor & RAM 5 08-04-2011 10:31 PM
Power management grayed out; power options in control panel won't Norika Windows Security 2 04-02-2011 09:41 PM
Need SEO management power in Firefox Sheena_thakkar Technology & Internet 6 27-02-2010 04:32 PM
Windows 7 Power Management darshit Guides & Tutorials 3 28-04-2009 11:27 AM


All times are GMT +5.5. The time now is 10:35 AM.