Go Back   TechArena Community > Software > Operating Systems
Become a Member!
Forgot your username/password?
Register Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



Autoplay not working on fresh Windows 7 x64 install

Operating Systems


Reply
 
Thread Tools Search this Thread
  #1  
Old 02-04-2010
Member
 
Join Date: Oct 2009
Posts: 38
Autoplay not working on fresh Windows 7 x64 install
  

Hi -

Smallish yet irritating problem with my Win 7 Ultimate 64-bit install - Autoplay doesn't work, and hasn't since I was forced to reinstall a couple of weeks back. Doesn't work for discs inserted, USB flash drives, memory cards, external HDDs plugged in etc (Firewire & ExpressCard/34 not tested). I have of course gone to the Autoplay settings and restored defaults, also tried setting every category (DVD, CD, etc) at "Ask me every time". No luck. I was working fine on the same OS before before I had to reinstall fresh, also on x86 version of Win 7, and on Vista. Nothing wrong with the USB ports/disc drive, inserted media is still detected.

Any ideas?

Cheers

Sony VAIO VGN-NR280E
Win 7 Ultimate x64 + OS X 10.5.7 dual-boot with BootThink v.1
Mobile Intel 965 Express Chipset
Intel Core 2 Duo 1.7 T5450
4GB DDR2 667
Intel GMA X3100 (358MB)
Fujitsu 200GB Fast SATA

__________________
'n00b' is just 'boon' spelled backwards. We all had to start somewhere.
Reply With Quote
  #2  
Old 03-04-2010
Member
 
Join Date: Nov 2005
Posts: 3,022
Re: Autoplay not working on fresh Windows 7 x64 install

Try the steps which i have mentioned below:
  • Go to Start Menu,Select All Programs,
  • Go to Accessories and right-click Command Prompt, Select Run as administrator.
  • You may be prompted for the password input the password and press enter.
  • Open command prompt simply type net start shellhwdetection hit Enter.
  • Reboot the machine
Reply With Quote
  #3  
Old 03-04-2010
Member
 
Join Date: Oct 2009
Posts: 38
Re: Autoplay not working on fresh Windows 7 x64 install

OK, tried that, said that service is started already. Have a feeling it may be something to do with incorrect registry values but till I know exactly where to go and what the value should be in Regedit I won't go there
Reply With Quote
  #4  
Old 05-04-2010
Member
 
Join Date: Oct 2009
Posts: 38
Re: Autoplay not working on fresh Windows 7 x64 install

OK, got it... here's the answer for anyone else having the same issue -


Check if the Group Policy Setting has been disabled for the Autoplay feature.

Note: Changing Group Policy Setting applies to only Windows 7 Ultimate and Windows Enterprise editions.

1. Click Start and in the Search box, type gpedit.msc and press Enter.
Now browse to Computer Configuration\ Administrative Templates\ Windows Components\ Autoplay Policies\ Turn off Autoplay.

2. To Enable:
Change the value of Turn off Autoplay to Disabled.

Note: This will enable the Autoplay feature.

Refer this link to which provides solutions to some common problems with AutoPlay:

Troubleshoot AutoPlay problems
http://windows.microsoft.com/en-us [...] y-problems

(many thanks to Divya R Microsoft Support for this help
__________________
'n00b' is just 'boon' spelled backwards. We all had to start somewhere.
Reply With Quote
Reply

  TechArena Community > Software > Operating Systems
Tags: , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Autoplay not working on fresh Windows 7 x64 install"
Thread Thread Starter Forum Replies Last Post
Autoplay and Disk Defragmentation not working in Windows 7 GoutamB Operating Systems 8 17-09-2011 11:45 PM
DVDs not working on fresh installation of windows 7 Roxie Operating Systems 4 01-03-2011 08:11 PM
Fresh Install of Windows 7 64-bit - Bootmgr is missing Omaar Operating Systems 6 18-08-2010 11:38 PM
Autoplay option is not working in Windows XP Becse Operating Systems 1 03-01-2009 09:24 AM


All times are GMT +5.5. The time now is 05:50 AM.