Go Back   TechArena Community > Software > Operating Systems
Become a Member!
Forgot your username/password?
Register Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



win XP SP2 Changed Default Boot

Operating Systems


Reply
 
Thread Tools Search this Thread
  #1  
Old 11-05-2009
Member
 
Join Date: Apr 2009
Posts: 67
win XP SP2 Changed Default Boot
  

Hello,

I have purchased two hard disk one is of 40 GB and another one is also is of 40 GB, I have decided to keep the dual boot for my PC and hence when i select second HD for win XP SP2 but the boot order automatically changes.

When i checked in the boot.ini but the only thing that changed was the addition of:"/NoExecute=OptIn"; the boot order was the same, but second HD became the default, where i had selected for the first one.Now i wanted to make it for second HD, does i need to do any changes in the BIOS.

How this has happened I became nook at this, please help.

Reply With Quote
  #2  
Old 11-05-2009
Member
 
Join Date: Oct 2008
Posts: 68
Re: win XP SP2 Changed Default Boot

To edit the file go to the boot.ini File then check for the further options /boot/grub/menu.lst. There will be a line that says.
Quote:
default 0
and to do the necessary changes you have to first decide which HD you wanted to make it '0' and '1' and so on. Simply change '0' to the number of your install. For example, if your grub has three entries and your second HD will be third, change default to 2 (0 is the first entry, not 1).
Reply With Quote
  #3  
Old 11-05-2009
Member
 
Join Date: Jan 2006
Posts: 7,144
Re: win XP SP2 Changed Default Boot

can think of is using the Windows bootloader to select which OS to boot. As far as I know, within XP, you can change the boot order depending on which OS you want as the default one to load.

If you're using two seperate HDs you can use this method.

1.Configure in BIOS the Second HD at first, the first HD as second boot HD.

2.You need to copy from C:\ the file CHAIN0. It's 512 bytes long and you'll find it on the Windows side of your WinOS Install DVD.

3. Edit boot.ini. Normally it's hidden and write-protected.you need to unhide that and check off the write protected box.

To boot Windows first add this line to boot.ini (backup first):

C:\chain0="MacOS X x86 10.4.x my personal system"

Tips: enter /noexecute=alwaysoff and Windows will disable the file execution thing. You may set the timeout period there, as you may set the timeout to 5 or so and change the timeout as per your need.
And at next reboot it should show off with the Windows boot selector and you may select which OS you want on each HD.
Reply With Quote
  #4  
Old 11-05-2009
Member
 
Join Date: Oct 2008
Posts: 80
Re: win XP SP2 Changed Default Boot

  1. Right-click My Computer, and then click Properties.
    -or-
    Click Start, click Run, type sysdm.cpl, and then click OK.
  2. On the Advanced tab, click Settings under Startup and Recovery.
  3. Under System Startup, click Edit. This opens the file in Notepad ready for editing.
  4. In Notepad, click File on the Menu bar, and then click Save As.
  5. Right click in an empty area of the Save As dialog box, point to New in the context menu, and then click Folder.
  6. Type a name for the new folder, for example temp, and then press the ENTER key to create the folder named temp.
  7. Double-click the new folder named temp, and then click the Save button to save a backup copy of the Boot.ini file.
Reply With Quote
Reply

  TechArena Community > Software > Operating Systems
Tags: , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "win XP SP2 Changed Default Boot"
Thread Thread Starter Forum Replies Last Post
The default date format has changed into Microsoft Word 2011 lUcCIlLA Windows Software 3 12-09-2011 10:43 PM
Shortcuts getting changed to default icon or disappears in Windows 7 Kaufman Operating Systems 4 02-04-2010 06:41 AM
Windows 7 boot logo changed ! Philip Neri Customize Desktop 4 06-12-2009 08:21 PM
Font changed after updating firmware...How to set default?" rashmi_ay Portable Devices 3 18-11-2009 01:54 PM
I changed my default image viewer by accident... Agilent Windows XP Support 3 04-12-2007 05:14 PM


All times are GMT +5.5. The time now is 05:23 AM.