Results 1 to 8 of 8

Thread: Windows XP Folder Access Denied

  1. #1
    Join Date
    Jan 2007
    Posts
    19

    sad Windows XP Folder Access Denied

    Hi Everyone,

    I am using Windows XP Media center edition. I think its similar to windows xp pro with added media features. Anyways I have 1 user account which is my account and its an administrator account. What I wanted is if anyone else log in my pc then he/she should not get persmission to view certain folders that I wanted. So I created another account with the name "User" and set it to limited account. Then I logged into my admin account and disabled simple file sharing. Then I right clicked on a folder and did properties. And in security I selected the user account named "User" and selected deny for most options (like modify, read & execute , read ) etc.

    Now when I logged in thru account "User" then I am unable to access that folder. Thats okay and its what I intended. But the problem is when I login thru my own account (which is admin a/c) I also get the same error. If I double click on that folder it says access denied. I am unable to set its security properties.

    Now how do I fix this problem and achieve what I originally planned to do. I am myself now unable to access that folder thru my own admin a/c.

    If I enable simple file sharing and goto folder properties I do not see security tab.

    If anyone can help me I would be glad.

    Thanks,
    Jack
    Last edited by jackgreat; 28-04-2009 at 11:08 PM.

  2. #2
    Join Date
    Dec 2008
    Posts
    1,108

    Re: Windows XP Folder Access Denied

    The difference between stupidity and genius is that genius has its limits. - Albert Einstein

    What we think, we become (Please don't think you are a superhero and don't try to fly)

    "SUCCESS IS NOT A DESTINATION , IT'S A JOURNEY"

  3. #3
    Join Date
    May 2008
    Posts
    4,088

    Re: Windows XP Folder Access Denied

    To resolve this issue, you must turn off Simple File Sharing, and then take ownership of the folder:

    1. Turn off Simple File Sharing:
    1) Click Start, and then click My Computer.
    2) On the Tools menu, click Folder Options, and then click the View tab.
    3) Under Advanced Settings, click to clear the Use simple file sharing (Recommended) check box, and then click OK.
    2. Right-click the folder that you want to take ownership of, and then click Properties.
    3. Click the Security tab, and then click OK on the Security message, if one appears.
    4. Click Advanced, and then click the Owner tab.
    5. In the Name list, click your user name, Administrator if you are logged in as Administrator, or click the Administrators group.
    If you want to take ownership of the contents of that folder, click to select the Replace owner on subcontainers and objects check box.
    6. Click OK. You may receive the following error message, where Folder is the name of the folder that you want to take ownership of:
    You do not have permission to read the contents of directory Folder. Do you want to replace the directory permissions with permissions granting you Full Control? All permissions will be replaced if you press Yes.
    7. Click Yes.
    8. Click OK, and then reapply the permissions and security settings that you want for the folder and the folder contents.

  4. #4
    Join Date
    Jan 2007
    Posts
    19

    ThumbsUp Re: Windows XP Folder Access Denied

    Thanks. It worked and I now have ownership of the folder.

    Can you tell me what do I need to do if I want to prevent other users from accessing a particular folder. I have 2 user accounts, one is mine which is admin account and other is account name is "user" which is limited. If I want that a/c not to access a folder then what do I do.

    Thanks,
    Jack

  5. #5
    Join Date
    Feb 2006
    Posts
    159

    Re: Windows XP Folder Access Denied

    I will provide you some details regarding how to prevent user from accessing one particular folder, This sort of thing is normally done by using groups. First create a group for the special folder. Then add all of the users to that group except the one user to exclude. Then make the folder owned by the group and remove access for "other". Here is an example where there are user accounts user01, user02, and user03. We want to exclude user02 from the special folder. All user accounts already belong to the users, video, and disk user groups.

    groupadd specialfolder
    usermod user01 -G specialfolder,video,disk
    usermod user03 -G specialfolder,video,disk
    chown root:specialfolder /specialfolder
    chmod 770 /specialfolder
    That's how I would do it.

  6. #6
    Join Date
    May 2008
    Posts
    2,684

    Re: Windows XP Folder Access Denied

    Go to the properties of the folder that you want to protect from other user accounts. In that select the Security tab. In that, select the user account and below are the permissions check boxes. In the 'Deny' column, check that boxes for the permissions that you want to deny for that user. Click OK.

    Now, whatever permissions you have denied to that user, he/she cannot access those permissions in that account. For example, if you have set 'read' deny, then the person will not able to open that folder from that account. So simple...

    Enjoy.

  7. #7
    Join Date
    Jan 2007
    Posts
    19

    ThumbsUp Re: Windows XP Folder Access Denied

    Thanks a lot for your help guys. What I did was remove the user from that group (for the particular folder) and it worked.

    SalVatore, earlier I had done exactly what you said but then my troubles started. I think because all permissions etc were being inherited by the group so once I clicked on deny for a particular user it did that for everyone.

  8. #8
    Join Date
    Oct 2009
    Posts
    1

    smile Re: Windows XP Folder Access Denied

    THanks Dude...

    Now I am able to open the old windows group folder....

    Thanks again

    Quote Originally Posted by Solomon View Post
    To resolve this issue, you must turn off Simple File Sharing, and then take ownership of the folder:

    1. Turn off Simple File Sharing:
    1) Click Start, and then click My Computer.
    2) On the Tools menu, click Folder Options, and then click the View tab.
    3) Under Advanced Settings, click to clear the Use simple file sharing (Recommended) check box, and then click OK.
    2. Right-click the folder that you want to take ownership of, and then click Properties.
    3. Click the Security tab, and then click OK on the Security message, if one appears.
    4. Click Advanced, and then click the Owner tab.
    5. In the Name list, click your user name, Administrator if you are logged in as Administrator, or click the Administrators group.
    If you want to take ownership of the contents of that folder, click to select the Replace owner on subcontainers and objects check box.
    6. Click OK. You may receive the following error message, where Folder is the name of the folder that you want to take ownership of:

    7. Click Yes.
    8. Click OK, and then reapply the permissions and security settings that you want for the folder and the folder contents.

Similar Threads

  1. Access Denied while trying to delete a folder in windows 7
    By cobra55 in forum Operating Systems
    Replies: 3
    Last Post: 06-01-2011, 04:54 PM
  2. Destination Folder Access Denied
    By alanbriggs in forum Vista Help
    Replies: 7
    Last Post: 17-10-2010, 10:50 PM
  3. My Documents folder access denied after Windows XP reinstall
    By Gaganadipika in forum Operating Systems
    Replies: 5
    Last Post: 25-03-2010, 10:13 AM
  4. Access denied to a folder!
    By Swaraj in forum Operating Systems
    Replies: 4
    Last Post: 27-03-2009, 05:22 PM
  5. Destination Folder Access Denied error on Windows Vista
    By IpsA in forum Windows Vista Performance
    Replies: 1
    Last Post: 08-05-2007, 01:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •