Results 1 to 9 of 9

Thread: No sound after Windows 7 upgrade

  1. #1
    Join Date
    Dec 2008
    Posts
    119

    sad No sound after Windows 7 upgrade

    Hello Friends,

    Recently i had upgraded my system from Windows Vista to Windows 7. The problem currently i'm having on my pc is that i'm not getting any sound from my pc, whereas Windows 7 works absolutely fine on my system. I had copied the drivers that are been used in Vista to Windows 7. But i'm unable to use that particular drivers for my windows 7. Whenever i try to play any music on my system i get the following error message "installer missing". Can any one tell me that how do i get my sound card working on Windows 7? Does any body have any idea about the above issue? Kindly help me out to resolve the above issue.

    Thanks in advance.

  2. #2
    Join Date
    Apr 2008
    Posts
    3,526

    Re: No sound after Windows 7 upgrade

    Try to download an updated sound driver from the internet. Then uninstall the old driver from your system and then try to reinstall this new drivers on your pc. And then check out whether you still face the same sound problem on your pc.

  3. #3
    Join Date
    Apr 2008
    Posts
    3,297

    Re: No sound after Windows 7 upgrade

    I fixed my audio problem by going into the control panel. I changed it to the classic display and then selected "Sound". After opening sound, I selected the SB Live speaker option and made it my default. Then I clicked on "properties and selected the "Levels" tab. This is where you can adjust your sound levels.

  4. #4
    Join Date
    Nov 2005
    Posts
    3,026

    Re: No sound after Windows 7 upgrade

    Make a restore point first. Open command prompt as administrator, run this command:

    bcdedit.exe -set loadoptions disable_integrity_checks
    bcdedit.exe -set testsigning on


    Then reboot your system

  5. #5
    Join Date
    Nov 2005
    Posts
    1,203

    Re: No sound after Windows 7 upgrade

    Usually a clean install is recommended instead since Windows 7 is still in the testing phases to avoid potential issues with remnants from the previous OS installation. However, you might see if doing a repair install may be able to fix this for you.

  6. #6
    Join Date
    Dec 2009
    Posts
    2

    Re: No sound after Windows 7 upgrade

    I have a similar problem and would greatly appreciate some help.

    I used to have Windows Vista Home Premium x64-bit on my Gateway p-6860FX laptop. I'm a student so I got that $30 upgrade to Windows 7 Home Premium x64-bit. Everything is running very well except one problem. When I'm watching a video on-line and I click on the full-screen option to maximize the video, the sound gets distorted after about 30-50 seconds. The best way I can describe that distortion is that the noises and the voices in the video start crackling in a way. I hope that makes sense. At first I thought it was just all flash videos on-line but then I noticed that it doesn't happen when I watch YouTube videos.

    If you want a good example of what I'm talking about, go to www.msn.com and look at the tiny little video screen on the left titled "Video Highlights". They always have some interesting video over there to watch but I can't watch it in that tiny screen. That is a problem because I also get my news from MSN Video.

    Please help me out.

    Thank You.
    Andy

  7. #7
    Join Date
    Jan 2009
    Posts
    1,738

    Re: No sound after Windows 7 upgrade

    Did you try upgrading the Video and Audio drivers? That is worth trying... Windows 7 is faster then Vista but it too requires some strong hardware. Make sure your Graphics Card is supported by Windows 7.

  8. #8
    Join Date
    Dec 2009
    Posts
    2

    Re: No sound after Windows 7 upgrade

    Quote Originally Posted by Rudra.J View Post
    Did you try upgrading the Video and Audio drivers? That is worth trying... Windows 7 is faster then Vista but it too requires some strong hardware. Make sure your Graphics Card is supported by Windows 7.
    Thanks for the reply. I went to update my sound driver but it said that I already have the most up to date software on my computer. In regards to the Graphics Card issue...I downloaded a little software from Microsoft and did a compatibility check before upgrading to Windows 7. I got approval in all 4 areas that it checked and I think the Graphics Card was one of the things it checked for. I hope that's not all I can do...this is going to be tough not being able to watch videos online since I don't have a good TV.

    If there is anything else please let me know.

    Thanks again.
    Andy

  9. #9
    Join Date
    Dec 2008
    Location
    Colombo
    Posts
    121
    Hello
    I had the same problem. After I upgraded from Vista to Windows 7, my laptop had no sound. After trying different settings without success. I inserted the first upgrade disc back in and there were all the drivers required. (I dont think the installation process said to put the first disc back in after the final installation reboot, but I could be wrong).
    anyway, now my laptop has sound again.

    Hello Viso, could you provide additional details? I am using a full Install disc, but did just the upgrade from Vista Ultimate to 7 Ultimate. No Audio devices are found on my Gateway FX desktop. When you reloaded the Installation disk, did you go through the Install Process again? What do you mean the devices were there? thanks

    Earlier releases of Windows 7 does not support all the sound devices due to driver incompatibility. As you have just done the upgrade, you will have to update Windows 7 installation on your system. There are patches and upgrade disks available which have all the required drivers needed for Windows 7 to run properly.

    Hi Solomon, thanks for the info, but when I did the install I did select the latest online version. Can you provide details on how to update the Windows 7 installation and where to get the patches and upgrade disks you mentioned?
    Thanks

    Check Driver maker web and find new up to date drivers.

    Was able to get the correct driver for my Gateway Sound Blaster Creative X-Fi at the following link. http://support.gateway.com/support/d...ef=DX&id=21529

    Installed driver 9538501.exe - Creative Sound Blaster X-Fi Sound Card Driver Version: 5.12.08.1201
    Supports: Windows Vista (32-bit)
    Note: This file contains the Windows Vista (32-bit) Creative audio driver for the computer models and components listed below.
    I am now working.
    Appreciate everyones help

    hi jasper 96
    Glad you got your problem sorted out. If it helps anyone else, my upgrade was Vista Home premium to Windows 7 Home premium. After the install with both discs, I re-inserted the disc labelled "HP Upgrade Manager" and the list of drivers came up.
    Hope this helps

    vizo

    Thanks a million lillebror. Ur idea worked great. Relived a big pain in my neck.

Similar Threads

  1. Replies: 4
    Last Post: 06-04-2011, 11:36 AM
  2. No sound in Dell Latitude D510 after upgrade to windows 7
    By Kardashian in forum Portable Devices
    Replies: 6
    Last Post: 08-12-2010, 11:03 AM
  3. Lost sound after upgrade Windows 7 X64
    By Iopex in forum Operating Systems
    Replies: 4
    Last Post: 23-11-2010, 05:15 PM
  4. Mac mini no sound after upgrade
    By Noah in forum Portable Devices
    Replies: 5
    Last Post: 22-10-2010, 02:16 PM
  5. Windows 7 X64 Upgrade lost Sound P105-S6114
    By Obessed in forum Portable Devices
    Replies: 3
    Last Post: 03-09-2010, 10:01 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •