Go Back   TechArena Community > Software > Operating Systems
Become a Member!
Forgot your username/password?
Register Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



Problem installing nam 1.13

Operating Systems


Reply
 
Thread Tools Search this Thread
  #1  
Old 21-02-2009
Member
 
Join Date: Nov 2008
Posts: 85
Problem installing nam 1.13
  

Hi guys,

I am having some problem regarding installation of ubuntu 8.04 operating system. As I try to install ns 2.33 on ubuntu 8.04 operating system, everything gets installed successfully except for nam 1.13 and I recieve a message that Please compile your nam separately.

Please give a solution regarding this problem.

Any help will be appreciated .

Reply With Quote
  #2  
Old 21-02-2009
Member
 
Join Date: Jan 2008
Posts: 3,384
Re: Problem installing nam 1.13

I am assuming that you have downloaded ns-allnone-2.33.tar.gz and unzipped it and executed "./install" from the ns-allinone-2.33 directory. If you have done something different, then you will have to tell us exactly what you did.

For best chances of meaningful help with fewest iterations, I'm thinking you should give as much information as you can. For example during the install procedure if "make nam" failed, there would have been a message to that effect. Of course that would have scrolled off of the screen some 20,000 or so lines into the procedure, and you wouldn't have seen it.

So, if you have any further problems, you can try something like:

Code:
./install >install.log 2>& 1
This redirects all output from the install script to a file that you can inspect later. To see the progress of the install script, then after starting "./install" you can open another terminal window and navigate to the ns-allinone-2.33 directory and enter
Code:
tail -f install.log

(When it is finished, hit Ctrl-C in the window showing the tail.)


Now back to what I think might have happened:

Under my assumption about what you have tried to do, that message about compiling nam separately means that the "make nam" failed during the ns-allinone-2.33 install script.

In my experience, the most likely reason that "make nam" would fail is that you don't have all of the X11 development packages on your system.

Make sure you have the following packages installed:

libxt-dev libx11-dev libxmu-dev


Use the synaptic package manager to install them and try the ns-allinone-2.33 install script again.
Reply With Quote
  #3  
Old 21-02-2009
Member
 
Join Date: May 2008
Posts: 4,080
Re: Problem installing nam 1.13

Try this one:

You didn't give the complete command line, but there should be a "-lz" in there somewhere.

All of the messages indicate problems with zlib. Things might work if you install zlib-devel on your system. Here's something to try:

Use the package manager to search for zlib-devel, or from a command line execute the following
Code:
yum info zlib-devel

If it doesn't say "installed", then install it. Use the package manager, or from a command line execute the following as root:
Code:
yum install zlib-devel

Note that everything else should be done as a "normal" user, not as "root."

Try the ns-allinone install script again. You might want to delete the allinone installation directory tree and unzip the tarball to start from the beginning.

Now, if zlib was already installed and/or if the above didn't work then here's another approach.

Note that I don't have access to or interest in Fedora 9 systems, so I can't be absolutely sure about the cause of your problems. (In other words: As always, I have to advise you that Your Mileage May Vary.)

Start all over again: Unzip the allinone tarball into a brand new directory.

Navigate to the ns-allinone-2.33 directory and execute the following:
Code:
./install >install.log 2>& 1

This redirects the couple of thousand lines of output to a file that you can inspect at your leisure (instead of having everything scroll off of the screen). Lots of times the real problem is hundreds of lines before it bails out of the installation script but you don't see it unless you capture the output in a file as I showed.

If you want to see the progress as it builds the stuff, you can open another terminal window, navigate to ns-allinone-2.33 and enter
Code:
tail -f install.log

(Hit Ctrl-C in the "tail" window when it is through.)

Now, open the install.log file in a text editor.

Somewhere (probably 500-600 lines from the top) there will be a section that starts something like

Code:

Build zlib
Checking for gcc.
Building static library libz.a version 1.2.3 with gcc.
Checking for unistd.h... Yes.
Reply With Quote
  #4  
Old 21-02-2009
Member
 
Join Date: Apr 2008
Posts: 3,260
Re: Problem installing nam 1.13

Do you have the following package installed:

libX11 libX11-devel

If so, then do the following:
Navigate to the nam-1.13 directory

execute
Code:
make distclean
./configure >configure.log 2>& 1

It doesn't take very long to finish this.
Do you see anything in configure.log that hints at a problem?
If configure.log looks OK, try

Code:
make >make.log 2>& 1
What do you see here?

I forgot to ask: Did you install the 64-bit version of Fedora or the 32-bit version?
Although I have installed ns2 on a 64-bit Centos 5.2 workstation, previous versions had problems that required a few helpful clues to the install script. All systems that I currently use are 32-bit systems.
Reply With Quote
  #5  
Old 21-02-2009
Member
 
Join Date: Apr 2008
Posts: 3,518
Re: Problem installing nam 1.13

Maybe there is some conflict between i386 and x86_64 versions of tools and libraries. Since I can't reproduce your problems, and I can't see cluttering the board with more and more of your error messages, and it's hard to tell which of the messages may be significant, how about trying the following:

cd into the nam-1.13 directory. Execute the following:

Code:
make distclean
./configure >configure.log 2>& 1
make >make.log 2>& 1
zip nam_stuff.zip config.log configure.log make.log Makefile

Then reply to this post and attach the nam_stuff.zip file. (Under the "Addidional Options part of the reply window, click "Manage Attachments"
Then to the right of the "Upload File from your Computer" box, "Browse..." to your directory and file, and click "Upload")
Reply With Quote
  #6  
Old 21-02-2009
Member
 
Join Date: Apr 2008
Posts: 3,291
Re: Problem installing nam 1.13

I downloaded and installed the 64-bit version Fedora 9 on a spare disk partition that I keep for experimentation.

I untarred the ns-allinone-2.33 distribution and did the "./install" thing.

I got the "Please compile your nam separately" message, just as you did.

I went to the nam-1.13 directory and executed the following, as I recommended to you:

Code:
make distclean
./configure >configure.log 2>& 1
make >make.log 2>& 1

Sure enough, make.log contained the errors about undefined references to gzread, gzeof, etc., and there was no "-lz" in the final compiler line where it was linking all of the object files.

Now for a little detective work. (See Footnote.)
Near the middle of the nam configure.log were the following lines:
Code:
checking for zlib.h... -I/usr/include
checking for libz1.1.4... no

Since the allinone distribution included its own zlib stuff and it was built successfully (as indicated in the configuration.log for the ns-allinone install script), I decided to use that zlib. The question is" How?

From things I previously learned about good program distributions like ns, I guessed that configure might be able to give me some clues. (Of course, I could have looked at configure with a text editor, but I always try to let the program itself help me before I really dig into things.)

In the nam-1.13 directory, I executed
Code:
./configure --help

And, among other things I saw:
Code:
Optional Packages:
--with-PACKAGE[=ARG] use PACKAGE [ARG=yes]
--without-PACKAGE do not use PACKAGE (same as --with-PACKAGE=no)
-with-defaultoptions=filename use <filename> as default options file

Now, looking at these, I perceive that I could have executed the nam configure script "--without-zlib" to delete the zlib stuff completely, but what I did was:
Code:
./configure --with-zlib=../zlib-1.2.3 >configure.log 2>& 1
make >make.log 2>& 1

This time the nam build was successful
I looked back at the end of the ns-allinone configure.log to change path and other environment variables to be able to run ns and nam.
Bottom line: When dealing with Linux, my experience is that, generally speaking, 32-bit installations may be less likely to give problems than 64-bit installations.

The reason that I use 32-bit distributions for just about all of my workstations is that I just had too many problems with drivers for the 64-bit distributions (video drivers, ethernet drivers, and, especially Wi-fi drivers). So far (as far as I can tell) I haven't had a single actual application that would have benefited from having a 64-bit version of Linux instead of a 32-bit version. That doesn't mean that I think no one should install 64-bit Linux; it just means that I think it's somewhat harder to support them. (If I were getting paid by the hour, maybe I would create my own personal economic stimulus package by recommending 64-bit installations for all of my paying customers.)

This may be even more important when using "bleeding edge" distributions like Fedora. Note that neither my Centos 5.2 32-bit workstations or my Centos 5.2 64-bit "sandbox" had any problems installing ns distributions with no human intervention required.
Reply With Quote
  #7  
Old 02-02-2012
Member
 
Join Date: Feb 2012
Posts: 1
star Re: Problem installing nam 1.13

Quote:
Originally Posted by Coldman View Post
Hi guys,

I am having some problem regarding installation of ubuntu 8.04 operating system. As I try to install ns 2.33 on ubuntu 8.04 operating system, everything gets installed successfully except for nam 1.13 and I recieve a message that Please compile your nam separately.

Please give a solution regarding this problem.

Any help will be appreciated .


Reply:

This is the problem with nam file .NAM is not installed correctly
you have to correct it
Goto ns-allinone-2.34/nam-1.14
then open Xwd.c file
there delete the header file #include <X11/Xmu/WinUtil.h>
save the file.
goto command prompt n(or terminal ) and move to /ns-allinone-2.34/nam-1.14
$ sudo make
then only nam-1.14 will be installed and nam.exe will be appear

then move to /ns-allinone-2.34/bin

create link for nam

$ ln -s $CUR_PATH/nam-$NAMVER/nam${EXE} nam${EXE}

Now it will work
Reply With Quote
Reply

  TechArena Community > Software > Operating Systems
Tags: , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Problem installing nam 1.13"
Thread Thread Starter Forum Replies Last Post
Problem in installing 8GB RAM MicroDon Motherboard Processor & RAM 4 30-11-2010 08:01 AM
Problem installing IE9 Anja Windows Software 4 01-10-2010 07:13 PM
Problem Installing XP Juancho19 Operating Systems 2 03-12-2009 06:22 AM
Having problem while installing SP2 Taipai Operating Systems 3 31-01-2009 01:31 PM
Problem while installing a cd.. Samsher Operating Systems 3 10-01-2009 09:14 AM


All times are GMT +5.5. The time now is 04:20 PM.