Go Back   TechArena Community > Hardware > Official GIGABYTE Motherboard Forum
Become a Member!
Forgot your username/password?
Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



Gigabyte GA-970A-DS3P booting issue

Official GIGABYTE Motherboard Forum


Reply
 
Thread Tools Search this Thread
  #1  
Old 23-09-2014
Member
 
Join Date: Jun 2014
Posts: 11
Gigabyte GA-970A-DS3P booting issue
  

I have recently bought a new Gigabyte GA-970A-DS3P motherboard and I am using it with AMD FX-8350 processor. I am also using 8gb of RAM and Radeon R7 260X video card. After powering on the motherboard the fans will start without much trouble but the is nothing on the monitor. There is no beep or anything else as well. Am I missing something or there is some additional things that is needed to boot the board? Thanks

Reply With Quote
  #2  
Old 24-09-2014
Member
 
Join Date: May 2009
Posts: 1,060
Re: Gigabyte GA-970A-DS3P booting issue

Have you checked for the connector on the ATX 12v on your Gigabyte GA-970A-DS3P motherboard? You will need to recheck if you are missing some connections on your motherboard and power supply. I am betting that you will have to connect the 4 pin CPU power connector (12v) on the motherboard since it is not optional. Have you got a power supply that has a 4+4 connector which can be split? If not then you should look for some more PSU for this connector.
Reply With Quote
  #3  
Old 25-09-2014
Member
 
Join Date: Sep 2005
Posts: 1,427
Re: Gigabyte GA-970A-DS3P booting issue

If you got a good power supply then it should be enough to power your motherboard. You need to also ensure that both power connections to the motherboard are snug and you should also try to drop and start with 1 stick of RAM. I think that there might be some issue with the RAM sticks and therefore you should try to test it with memtest to see whether any of the RAM stick is giving errors or not.
Reply With Quote
  #4  
Old 26-09-2014
Member
 
Join Date: Nov 2005
Posts: 1,170
Re: Gigabyte GA-970A-DS3P booting issue

Could you please tell us what is the make and model of your Power Supply? Have you properly connected the 6 or 8 pin power connetor to the graphics card? You will also have to connect the 1.1 x 24-pin Atx main power connector along with the 2.1 x 4-pin Atx 12v power connector. This connector is used for powering the CPU and if it is not connected then the CPU is not going to get any electrical power and hence you are facing the problem of booting.
Reply With Quote
Reply

  TechArena Community > Hardware > Official GIGABYTE Motherboard Forum
Tags: , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Gigabyte GA-970A-DS3P booting issue"
Thread Thread Starter Forum Replies Last Post
Gigabyte Z68XP-UD3P booting issue with intel graphics Punati Official GIGABYTE Motherboard Forum 4 13-06-2013 03:34 PM
booting issue with newly purchased gigabyte mother board. h61m-ds2 kaly422000 Official GIGABYTE Motherboard Forum 25 01-05-2013 11:35 AM
Why Gigabyte GA-970A-UD3 is freezing randomly? Super-Man Motherboard Processor & RAM 8 19-12-2011 11:13 AM
MSI 970A-G45 booting is very slow SIK Motherboard Processor & RAM 2 17-12-2011 09:04 AM
MSI 970A-G45 shows Black screen when booting Windows 7 Tikoo Motherboard Processor & RAM 9 09-12-2011 10:54 PM


All times are GMT +5.5. The time now is 12:12 AM.