Go Back   TechArena Community > Hardware > Official GIGABYTE Motherboard Forum
Become a Member!
Forgot your username/password?
Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



no response from Gigabyte Radeon R9 270X in my computer

Official GIGABYTE Motherboard Forum


Reply
 
Thread Tools Search this Thread
  #1  
Old 09-07-2014
Member
 
Join Date: Jun 2014
Posts: 17
no response from Gigabyte Radeon R9 270X in my computer
  

I am using a Asus M5A97 motherboard along with all other hardwares and Gigabyte Radeon R9 270X video card. After putting the computer together and running a system boot I am getting response from the CPU Fan, hard drive, and PSU. But the main problem is that I am not getting any fan response from the graphics card? I put this card in my other computer and it is working fine. I am using a Corsair 600W power supply, so do I need to change it or what? Thanks

Reply With Quote
  #2  
Old 10-07-2014
Member
 
Join Date: Oct 2005
Posts: 1,206
Re: no response from Gigabyte Radeon R9 270X in my computer

Can you try to recheck all the connections that are made are solid. There is no thermal paste that got where it doesnt have to be and also check all standoffs are in place. Since you have already found that the graphics card is working in your other computer so probably it is time for you to test the Power Supply in your new build. Test the RAM as well and see if it is working fine. When you turn on your computer then do you get any sort of beeping sound or such? If yes then please let us know about it.
Reply With Quote
  #3  
Old 11-07-2014
Member
 
Join Date: Sep 2005
Posts: 1,427
Re: no response from Gigabyte Radeon R9 270X in my computer

Are you actually connecting the eight pin 12v CPU pin block the the motherboard? Normally, the power to start the card fan comes through the PCIE slot. So, the eight pin gives an extra power phase to drive the CPU. And it also gives about 75w of power to the actual PCIE slots where the graphics card is plugged into. So, I am assuming that you have not connected the eight pin and therefore you are not getting any post from the system. Also install the latest BIOS for your motherboard.
Reply With Quote
  #4  
Old 12-07-2014
Member
 
Join Date: May 2008
Posts: 804
Re: no response from Gigabyte Radeon R9 270X in my computer

Yes, the graphics card wont work if you have forgotten to plug the eight pin from the PSU to the motherboard. You will not get any kind of post even if you have plugged in the extra PCIE 12v power that is required for the video card. The PCIe slot will need the 74w to signal and recognize the graphics card. Then only the BIOS can see it in the slot and the 75w from the PCIe slot gives the card as much as any extra pcie 12v supplies to the card. Hence, the CPU and card fans was spinning and not the card fan.
Reply With Quote
Reply

  TechArena Community > Hardware > Official GIGABYTE Motherboard Forum
Tags: , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "no response from Gigabyte Radeon R9 270X in my computer"
Thread Thread Starter Forum Replies Last Post
screen flickering issue with Gigabyte Radeon R9 270X Piyush Patel Official GIGABYTE Motherboard Forum 3 26-05-2014 12:17 PM
Weird tab key response in my computer mbangali Hardware Peripherals 3 24-08-2011 11:15 PM
GIGABYTE to Launch World's First Z68 Motherboards with Onboard mSATA and Smart Response Technology AbiCgail Motherboard Processor & RAM 6 10-08-2011 11:18 PM
intel smart response technology is not working with Gigabyte Z68A-D3H-B3 Biswaroop Motherboard Processor & RAM 6 05-08-2011 10:28 PM
How to get Intel smart response using Gigabyte GA-Z68X-UD7-B3 motherboard Cococo Motherboard Processor & RAM 5 25-07-2011 11:01 PM


All times are GMT +5.5. The time now is 01:21 PM.