Go Back   TechArena Community > Hardware > Official GIGABYTE Motherboard Forum
Become a Member!
Forgot your username/password?
Tags Active Topics RSS Search Mark Forums Read

Reply
 
Thread Tools Search this Thread
  #1  
Old 12-06-2013
Member
 
Join Date: Feb 2009
Posts: 64
HD 7850 not detected on GIGABYTE GA-Z77-D3H

I am using a Gigabyte GA-Z77-D3H motherboard and recently I purchased a new Radeon HD 7850 graphics card and when I was trying to hook it up on this board then it was not getting recognized? I have made sure that the graphics card is working fine by connecting it to my cousins motherboard without any issues. I have checked that it is firmly placed in but still to no avail. All that is shown on my monitor is no signal message? Does anyone know how to get this video card to work on this mobo? Thanks.
Reply With Quote
  #2  
Old 13-06-2013
Member
 
Join Date: May 2006
Posts: 2,328
Re: HD 7850 not detected on GIGABYTE GA-Z77-D3H

Well, did you make sure that you have the latest BIOS installed in your machine to support the video card? If not then go to the below link and download the latest BIOS as per your region wise and install it in your system, once you have installed it, then check to make sure by placing the graphics card firmly into its slot, whether it is working or not:

http://www.gigabyte.com/products/pro...?pid=4144#bios
Reply With Quote
  #3  
Old 14-06-2013
Member
 
Join Date: May 2008
Posts: 1,144
Re: HD 7850 not detected on GIGABYTE GA-Z77-D3H

I also think that it is a BIOS problem and it used to reset all the integrated or pci all the time. Also, dont use the F19 beta bios because it will not work, simply use the F18 BIOS which is working properly. Also change the OPROM setting to legacy and gen type to gen2 and the first adapter to boot to peg, although it will change back to auto, but there is nothing to worry about.
Reply With Quote
  #4  
Old 15-06-2013
Member
 
Join Date: Dec 2007
Posts: 1,542
Re: HD 7850 not detected on GIGABYTE GA-Z77-D3H

I would recommend you to download the F6 Bios of this GIGABYTE GA-Z77-D3H motherboard and install it. After that download also the latest version of the Catalyst drivers from AMD website. Now try to remove the CMOS battery to reset the mobo to get back to its onboard GPU. After that connect the video card using HDMI cable and boot to the operating system and install the latest drivers that you have downloaded.
Reply With Quote
Reply

  TechArena Community > Hardware > Official GIGABYTE Motherboard Forum
Tags: , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "HD 7850 not detected on GIGABYTE GA-Z77-D3H"
Thread Thread Starter Forum Replies Last Post
Gigabyte HD 7850 Fan problem Anikait Official GIGABYTE Motherboard Forum 3 16-08-2013 11:55 AM
LSI SAS 9211-8i HBA PCIe Card not detected on Gigabyte GA-Z77X-UD5H D1 Motherboard Processor & RAM 4 26-05-2012 03:39 PM
Gigabyte GTX 560 superclocked or Sapphire Radeon HD 7850 Farren Monitor & Video Cards 9 12-04-2012 11:19 PM
Network adapter is not detected on Gigabyte GA-EG41MF-US2H motherboard gywin Motherboard Processor & RAM 4 10-01-2011 11:02 AM
Hard disk not detected by Gigabyte GA-MA790FX-DQ6 Motherboard Oliver Khan Motherboard Processor & RAM 5 18-02-2010 09:40 PM


All times are GMT +5.5. The time now is 08:36 AM.