Results 1 to 6 of 6

Thread: Cisco Linksys E1500 is having slow wifi after upgrade

  1. #1
    Join Date
    Mar 2012
    Posts
    77

    Cisco Linksys E1500 is having slow wifi after upgrade

    I have been using Cisco Linksys E1500 and it was working fine by now but then as it was notifying me for upgrading router, so I did the same and since then I have been facing slow wifi connection speed, I have tried using other hardwire to connect and I am getting better speed with the same, I donít know what is the issue all about is there anyone who can help me out.

  2. #2
    Join Date
    May 2011
    Posts
    234

    Re: Cisco Linksys E1500 is having slow wifi after upgrade

    I have been using Cisco Linksys E1500 and it was working fine by now but then as it was notifying me for upgrading router, so I did the same and since then I have been facing slow wifi connection speed, I have tried using other hardwire to connect and I am getting better speed with the same, I donít know what is the issue all about is there anyone who can help me out.
    I just wanted to know that have you tried out doing a factory reset?? If not then try out the same and then let me know if it is making any difference or not, make sure or make a note of the router setting as you will have to configure it again. If that does not help then the other thing that you can try out is looking out for an upgraded wireless network interface driver and see if the issue is getting solved or not. Other than this make sure that you're using WPA2 wireless security mode, just check out these things and then let me know what you get.

  3. #3
    Join Date
    Jun 2011
    Posts
    294

    Re: Cisco Linksys E1500 is having slow wifi after upgrade

    I will inform you that if there are other wireless devices like cordless phones etc near the router then they might be conflicting so make sure that they are not near it, other than this if you have installed the router with Cisco Connect Software then you can try out the below solution as well and see if it is making any difference:
    • First open the software and then check out for the "Router Settings" in options
    • After that just click on the "Advanced Settings" option which will further lead you to the router's configuration page
    • When you are navigated to the router's configuration page then click on the Wireless tab and make sure that you are keeping the network mode as mixed and changing the Channel width to 20 MHz and then save the settings

    Just try it out and then post back the result that you get.

  4. #4
    Join Date
    Nov 2011
    Posts
    120

    Re: Cisco Linksys E1500 is having slow wifi after upgrade

    You can try out these possible solutions as well and see if they are helping you out or not:
    1. First try disabling WMM support in the settings which will be In applications and gaming
    2. Try resetting router through the configuration page, I mean Administration > Factory Defaults

    Just try them out and then let me know if they are making any difference.

  5. #5
    Join Date
    Mar 2012
    Posts
    77

    Re: Cisco Linksys E1500 is having slow wifi after upgrade

    Resetting the router to Factory Defaults and upgrading the firmware did not helped, anyways I have now tried disabling WMM support and have found that I am getting better speed now, I just wanted to know if this is an firmware issue issue or there is something wrong with the WMM??? Is there anyone who has an idea about the same???

  6. #6
    Join Date
    Mar 2012
    Posts
    112

    Re: Cisco Linksys E1500 is having slow wifi after upgrade

    I was facing the same issue and I think that there is nothing wrong with the WMM but then it is something related to the firmware, one can say that it is a firmware issue. I have found a no of people facing the same and disabling WMM is the only solution that has been found to be effective, if anyone find any other solution for the same then please let me know, on the other hand I have raised the same issue to the tech support and the said that they are aware of the same and looking in to the matter, may be they will come up with an update to solve the firmware issue soon.

Similar Threads

  1. "Cisco connect" cannot find Cisco Linksys E1200 router
    By $Iain$ in forum Networking & Security
    Replies: 5
    Last Post: 25-03-2012, 07:41 PM
  2. WAN connection is too slow with Cisco Linksys WRT320N
    By servan$ in forum Networking & Security
    Replies: 6
    Last Post: 25-03-2012, 06:46 PM
  3. Wireless speed is too slow in Cisco Linksys E1200
    By Mr.Ryszard in forum Networking & Security
    Replies: 7
    Last Post: 25-03-2012, 05:08 PM
  4. Internet Connection is slow with Linksys e1500 Router
    By Loganathan in forum Networking & Security
    Replies: 5
    Last Post: 25-01-2012, 04:49 AM
  5. Replies: 6
    Last Post: 19-09-2011, 12:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •