Go Back   TechArena Community > Technology > Networking & Security
Become a Member!
Forgot your username/password?
Tags Active Topics RSS Search Mark Forums Read

Reply
 
Thread Tools Search this Thread
  #1  
Old 17-12-2011
Member
 
Join Date: Nov 2011
Posts: 142
Not able to visit normal web sites with ?web shield? activated in Avast Mac Antivirus Beta

I have recently installed avast mac beta on my computer and the problem that I have started facing is that when I am activating the web shield then I am not able to visit any normal websites as well the only thing sites that I can visit is Secure (https) websites but then when I am deactivating the web shield then everything is working fine. Is there anyone who has faced the same and has an idea about it and can help me out as well? Any help regarding the same will be appreciated.
Reply With Quote
  #2  
Old 17-12-2011
Member
 
Join Date: Jul 2011
Posts: 325
re: Not able to visit normal web sites with ?web shield? activated in Avast Mac Antivirus Beta

Quote:
I have recently installed avast mac beta on my computer and the problem that I have started facing is that when I am activating the web shield then I am not able to visit any normal websites as well the only thing sites that I can visit is Secure (https) websites but then when I am deactivating the web shield then everything is working fine. Is there anyone who has faced the same and has an idea about it and can help me out as well? Any help regarding the same will be appreciated.
Before I suggest you anything just provide me the following details:
  • Application version?
  • VPS version?
  • OSX version?
Also provide me the log file of that will be in /var/log/system.log, you can copy the log file in notepad and then send it to me through the personal message for further help.
Reply With Quote
  #3  
Old 17-12-2011
Member
 
Join Date: Nov 2011
Posts: 142
re: Not able to visit normal web sites with ?web shield? activated in Avast Mac Antivirus Beta

I am having the following:
  • Application version: 1.0(35600b)
  • VPS version: 111128-2
  • OSX version: 10.7.2
I have also sent you the log file from the path that you had specified just check it out and then see if you are able to find the cause for the same. Thanks in advance.
Reply With Quote
  #4  
Old 17-12-2011
Member
 
Join Date: Jul 2011
Posts: 263
re: Not able to visit normal web sites with ?web shield? activated in Avast Mac Antivirus Beta

Quote:
I have recently installed avast mac beta on my computer and the problem that I have started facing is that when I am activating the web shield then I am not able to visit any normal websites as well the only thing sites that I can visit is Secure (https) websites but then when I am deactivating the web shield then everything is working fine. Is there anyone who has faced the same and has an idea about it and can help me out as well? Any help regarding the same will be appreciated.
Your problem appears to be weird but then I just wanted to know that have you tried using different browsers in order to check if they are making any difference and so. If you have not done so then try it out and then let me know what you get.
Reply With Quote
  #5  
Old 17-12-2011
Member
 
Join Date: Nov 2011
Posts: 142
re: Not able to visit normal web sites with ?web shield? activated in Avast Mac Antivirus Beta

Yes I have tried using the different browsers as well but then I have got different response from them but then I am still having the same problem. Just check out what I have found:
  • Safari- It is just giving me a blank message.
  • Chrome- It is giving me an error message saying ?error code: Error 324 (net::ERR_EMPTY_RESPONSE): The server closed the connection without sending any data.?
Are you aware of this??
Reply With Quote
  #6  
Old 17-12-2011
Member
 
Join Date: Jul 2011
Posts: 325
re: Not able to visit normal web sites with ?web shield? activated in Avast Mac Antivirus Beta

I have gone through you output, I will suggest you to enable the root account first, in order to do the same just make sure that you are having the admin right and then run the below command.
sudo lsof -p `cat /var/run/avast/proxy.pid`
After running the above command proceed with the below one:
lsof -p `cat /var/run/avast/proxy.pid`
After this just sent me the output as you had sent me before.
Reply With Quote
  #7  
Old 17-12-2011
Member
 
Join Date: Nov 2011
Posts: 142
re: Not able to visit normal web sites with ?web shield? activated in Avast Mac Antivirus Beta

Hey I have run both the command in the manner you have specified and I have sent you the output of it as well. Just check it out and help me with the issue further. Hoping for a solution this time.
Reply With Quote
  #8  
Old 17-12-2011
Member
 
Join Date: Jul 2011
Posts: 325
re: Not able to visit normal web sites with ?web shield? activated in Avast Mac Antivirus Beta

I have checked the output and I have found that the web shield was still on when you executed the lsof command for the last time. I was thinking that the problem might be because the file descriptor has been exhausted and so but then I don?t think that it is so after looking at your output. The problem here is something else. I just wanted to know if you are having some kind of firewall set up in your computer?? Just try to run the below commands in the respected manner and then just post the output here itself.
  • sudo ipfw list
  • grep proxy /var/log/system.log
Reply With Quote
  #9  
Old 17-12-2011
Member
 
Join Date: Nov 2011
Posts: 142
re: Not able to visit normal web sites with ?web shield? activated in Avast Mac Antivirus Beta

I have tried disabling and enabling the apple firewall but then it did not made any difference.
I have run the 1st command and I have go this “65535 allow ip from any to any”
The second command gave me this “see .txt, too many characters to just put it in this post”
Reply With Quote
Reply

  TechArena Community > Technology > Networking & Security
Tags: , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Not able to visit normal web sites with ?web shield? activated in Avast Mac Antivirus Beta"
Thread Thread Starter Forum Replies Last Post
delay in launching File System Shield programes on avast antivirus. Missilism Networking & Security 8 18-12-2011 02:32 PM
How to visit trusted sites without listing under Security in Internet Explorer 9? Ramanujan Technology & Internet 9 05-12-2011 07:57 AM
Cant switch back to normal browser from safezone browser of avast antivirus Baebi Networking & Security 7 30-10-2011 07:27 PM
Avast! Free Antivirus 5.0 beta available for download BiGMaCHiNe Networking & Security 1 14-05-2011 09:51 AM
Avast 4.8 antivirus needs to be activated Hecter Windows Software 3 23-11-2009 08:50 PM


All times are GMT +5.5. The time now is 03:56 PM.