Go Back   TechArena Community > Technology > Networking & Security
Become a Member!
Forgot your username/password?
Register Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



Windows 7: how to disable Automatic Private IP Addressing (APIPA)

Networking & Security


Reply
 
Thread Tools Search this Thread
  #1  
Old 10-01-2011
Member
 
Join Date: Sep 2010
Posts: 27
Windows 7: how to disable Automatic Private IP Addressing (APIPA)
  

Using a HP Compaq desktop computer from few years, this is running with windows vista OS. I basically sue this machine for internet access, for both my official and sometimes for the personal purpose. The machine is worked fine till the last days, but from yesterday it shows a error message regarding the Automatic Private IP Addressing (APIPA) and with a window message for disable this service in my machine, but the problem i am not having no having any information regarding this topic, so I am here to get some of the information regarding this. How to disable to this service? Any other suggestion regarding this will be thankful greatly.

Reply With Quote
  #2  
Old 10-01-2011
Member
 
Join Date: May 2008
Posts: 923
Re: Windows 7: how to disable Automatic Private IP Addressing (APIPA)

I had the similar issue in my machine, so I think this will can be solved by the reconfiguration of the wireless network service with the machine, for that go to the network wizard setting window in your machine, and from there select the network service that you are using. Reconfigure all settings those you configured earlier in your machine, along with the IP address, this is very important. Now along with that also reconfigure the router that you are using, restart the machine and the route, now try to open the internet connection and, I hope this time you will not found the problem that you mentioned in your post.
Reply With Quote
  #3  
Old 10-01-2011
Member
 
Join Date: May 2009
Posts: 969
Re: Windows 7: how to disable Automatic Private IP Addressing (APIPA)

I don’t think so that the APIPA network service can be disabled in windows vista and windows 7 OS. For that I recommend you to run a DHCP server in the network which you are using. I had the similar issue, where as I also got the error message regarding the APIPA network service, and I did not allowed to access the service, but after that I searched everywhere for the solution but did not found any solution anywhere. Then one of my friend suggest running the DHCP server, I install the server, and make it authentication. After that when I tried to open DHCP server, the APIPA network disables and from then the network does not shows this message regarding the network service. So I am suggesting you to install DGCP server, along with that you need to configure the IP address, go through this, I think this is the only solution for the problem that you mentioned in your post.
Reply With Quote
  #4  
Old 10-01-2011
Member
 
Join Date: May 2009
Posts: 759
Re: Windows 7: how to disable Automatic Private IP Addressing (APIPA)

I have a solution or the APIPA network service, you can disable this service by a simple way, you need to disable this one from the registry editor. Use the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\adapter name registry editor, where the adapter name should be the Dynamic Host Configuration Protocol (DHCP). Now add some opf the values in eth registry editor, like value name: IPAutoconfigurationEnabled, hexadecimal value of the registry is 0 and the value type is REG_DWORD. If the IP autoconfiguration is not present then change the value with 1. Now reboot your machi8ne. and the APIPA is disabled from after make the changes. Go through this, it will definitely helps you to overcome from the problem.
Reply With Quote
  #5  
Old 11-01-2011
Member
 
Join Date: May 2008
Posts: 976
Re: Windows 7: how to disable Automatic Private IP Addressing (APIPA)

Go to the run command lien argument from the start menu, type and insert regedit and hit one ENTER, this will open the registry editor of your machine. Now from there locate HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\Adapters, registry key and from there look for the IPAuto configuration, make sure that the option is enabled, change the value of from the default one to 0. Now close the registry editor and reboot your machine. I think by this you will be able to resolve the issue in your network service. Remember that during changes in the registry editor, you might be lose the windows file from your machine, so for that I suggest you to back up the windows file I n your machine or some other place before the operation.
Reply With Quote
Reply

  TechArena Community > Technology > Networking & Security
Tags: , , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Windows 7: how to disable Automatic Private IP Addressing (APIPA)"
Thread Thread Starter Forum Replies Last Post
How to disable windows 7 automatic wireless connects tjboy Operating Systems 3 09-03-2011 01:46 AM
Disable automatic lock with Windows 7 Chitamacha Windows Software 6 07-08-2010 07:00 AM
How to disable windows automatic update RockeЯ Operating Systems 3 11-06-2009 08:53 PM
Disable automatic restart after updates in Windows xp Computer_Freak Tips & Tweaks 1 13-05-2009 11:36 PM
How to disable automatic restart feature after Windows Vista update matthewforu Operating Systems 2 29-08-2008 02:42 PM


All times are GMT +5.5. The time now is 11:41 AM.