Results 1 to 7 of 7

Thread: Acer Aspire One ZG5 unable to connect internet via Wireless

  1. #1
    Join Date
    Oct 2010
    Posts
    66

    Acer Aspire One ZG5 unable to connect internet via Wireless

    I have recently brought a new Acer Aspire one ZG5 netbook. Everything was fine and working perfectly till yesterday. I never used the internet via wireless. Yesterday I gave it a try but I was unable to connect. I can connect the net via Ethernet but having problem with wifi. The indicator in my Belkin SURF N300 wireless router shows that it is connected successfully. I tried several time to connect but every time I get the same result. What should I do now? How can I connect it? I never used this type of connection before. Please help me to get out of this trouble.

  2. #2
    Join Date
    Feb 2010
    Posts
    644

    Re: Acer Aspire One ZG5 unable to connect internet via Wireless

    I think it is the problem of your netbook itself. I think that the wifi on your netbook is not responding perfectly. Have tried to use the wifi other than net, like file sharing, LAN services etc? See this before connecting to the internet. Try the power setting utility in your netbook and also make sure that the SSID is from the router is fine. If nothing going to changed with these this then disconnect and reconnect the modem and update the driver to latest version. I hope that you will find out the solution by yourself.

  3. #3
    Join Date
    Feb 2010
    Posts
    766

    Re: Acer Aspire One ZG5 unable to connect internet via Wireless

    I think that your netbook running from the compatibility issues. If your internet connection is dropping or unable to connect then it must be issue of netbook hibernating. I tried the several settings but one setting was successfully worked for me. What I have done is I turned on the network adapter power saver mode option to off and the issue was automatically stopped. To change the mode follow these steps:
    • Open Start>control panel>classic view
    • A control panel window will appear, in that double click on system icon.
    • Select the Hardware tab in system preferences dialog box and click the Device manager button,
    • Now browse or scroll to Network Adapters and click the + symbol on the left.
    • Next double click on the Atheros AR5007EG....
    • It is the name of network adapter, click advance tab in that.
    • At last select the "Power Save Mode", select off and to confirm click OK

  4. #4
    Join Date
    Feb 2010
    Posts
    701

    Re: Acer Aspire One ZG5 unable to connect internet via Wireless

    Here is my solution and it worked for me.
    • When the First time the wireless adapter on the netbook detects router's connection, it will ask for a wep key.
    • Get the right wep key and click on the connection found.
    • Next click on 'change advanced settings' and choose the second tab in that window, i.e. is 'wireless connection' tab.
    • Now you have to remove your main connection's router on the list.
    • Then refresh the list for a new available connection.
    • Again click on the main connection again and re enter the wep key
    • Now you will find the icon that is showing as “Connected”

  5. #5
    Join Date
    Feb 2010
    Posts
    796

    Re: Acer Aspire One ZG5 unable to connect internet via Wireless

    Once I had the same issue with my friend’s Acer ZG5 netbook . I tried several settings like ipconfig, winsockfix, disabling and enabling wireless, uninstalling antivirus with different options, but nothing worked at all. At last I decided to change the security password of my wireless router. In my case also I have same router like you and it is showing that it is connected with my netbook. But I couldn’t able to find the internet connection as well. So I change the password and rejoin the network again. After entering the new password everything works perfectly and till no issues at all.

  6. #6
    Join Date
    Feb 2010
    Posts
    530

    Re: Acer Aspire One ZG5 unable to connect internet via Wireless

    First you have to find out which wireless part is making issue with internet connection. It may either your Aspire one wifi card or the wifi router. First connect the both via Ethernet cable. You said that it is working fine. So with these settings find your system IP and the router IP. This is because there might be a chance that the router is came with encryption enabled you can spin it off primarily. Next time is finding out what the recommended settings are needed on your netbook and the shared key. Also try to change the MAC address of our computer because the MAC address performs the important role in detecting your computer for ISP. When you are connecting internet via wireless router there may be chance that the ISP cannot able to recognize your system MAC address.

  7. #7
    Join Date
    Jan 2012
    Posts
    1

    Re: Acer Aspire One ZG5 unable to connect internet via Wireless

    I already tried all the solutions given in here but to no avail. After 3 days of searching for answer this is the only one that worked for my Acer. I looked for the best driver of my Atheros AR5007EG and the latest is 9.2.0.104

    100% it will work

Similar Threads

  1. Acer Aspire won't connect to wireless network
    By Magikdethmonkey in forum Networking & Security
    Replies: 3
    Last Post: 06-01-2014, 10:06 AM
  2. Acer Aspire One ZG8 - No Wireless internet
    By Abhaa in forum Portable Devices
    Replies: 3
    Last Post: 09-01-2011, 06:26 PM
  3. Acer Aspire 5740-6378 cannot connect to Internet using Wireless
    By Chauncey in forum Technology & Internet
    Replies: 5
    Last Post: 08-04-2010, 06:08 PM
  4. wireless internet not working on Acer Aspire
    By Sibi.D in forum Networking & Security
    Replies: 4
    Last Post: 29-03-2010, 04:16 PM
  5. Acer aspire 8935g won't connect to internet
    By marcman in forum Hardware Peripherals
    Replies: 3
    Last Post: 24-10-2009, 09:59 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •