Go Back   TechArena Community > Technology > Networking & Security
Become a Member!
Forgot your username/password?
Tags Active Topics RSS Search Mark Forums Read

Reply
 
Thread Tools Search this Thread
  #1  
Old 19-10-2010
Member
 
Join Date: Sep 2010
Posts: 57
XP Port 3389 Not Listening

I have installed Windows XP Professional on my desktop computer system with the Service pack 3. I am having a problem with regarding the Port 3389 as it is not able to listen to this port. I have started the Terminal Services and there were no errors on an event viewer. What could be the problem for this kind of blindness of port. Please help me as i am not much familiar with the computer stuffs. I am not able to telnet to this port.
Reply With Quote
  #2  
Old 19-10-2010
Member
 
Join Date: Apr 2008
Posts: 3,336
Re: XP Port 3389 Not Listening

I found a computer ip scan following the several ports open as, for example
3389 -> Terminal Server and Windows 2000 RDP Protocol
88, 110,143,135,389,366,443,464,563,593;
Now I have time I tried using telnet to connect what works in some ports such as 110 POP3, you need a login and password. I found lots of articles on the net via the remote access control but now to my question. I can telnet to port 3389 irgenwas undertake if I can figure out what on the computer whether it is safe or not. and as alternate to the I? telnet I always get a black window (WHY?) and can make unlimited long typed. Gibts there any review of the RDP protocol? Is it possible to send commands? I could write a c progy which is connected to the port but does it matter? Certain strings send buffer overflow? so now what? And what about the rest of the ports -> Where I was looking on as the computer runs and if the port is open?
Reply With Quote
  #3  
Old 19-10-2010
Member
 
Join Date: May 2008
Posts: 2,944
Re: XP Port 3389 Not Listening

If the port to the outside correct? And when? I think there were problems from RDP. I am Not sure. Where I'm quite sure, however: This is not a good idea what you are up to. RDP is not encrypted and opens a lot of fun time socializing is a gateway to your computer. If on the web via: use SSH or a VPN such as OpenVPN if the box for this already exists and works. Either for the box (the version is but a little fiddly, I think) or you install the the corresponding directly to the computer.
Reply With Quote
  #4  
Old 19-10-2010
Member
 
Join Date: Jan 2006
Posts: 3,782
Re: XP Port 3389 Not Listening

Without port forwarding of 3389 to your target PC, the nix. Since your router will also provide an answer to any port scans since no case of it, "listening" and could give an answer.
  1. from 3389 to 3389 over TCP to 192.168.178.21 PC (PC1)
  2. Port 3390 on TCP port 3389 to PC 192.168.178.22 (for PC2)
However FUNZ not Never wasit because you have no fixed IP. As you can trick with DynDNS. Register with DynDNS to create, free DynDNS account, hack your data. No idea whether serving FritzBox DynDNS support, if so DyDNS hack account in DynDNS section of your router's Port Forwarding set. If available on your firewall box is allowed input and output control for the unused port [See Port Forwarding] share. Now RDP permission to use your gun controlled remotely.
Reply With Quote
  #5  
Old 19-10-2010
Member
 
Join Date: Jan 2006
Posts: 4,215
Re: XP Port 3389 Not Listening

On the PC with which you want to remotely control the IP then you need to enter provided by DynDNS. If you use NOT the standard ports, you need to remotely control the PC is to give to the RDP and port number changes and possibly change the RDP port remotely controlled PC's RDP port].
1. Start Registry Editor.
2. Click the following subkey in the registry:
HKEY_LOCAL_MACHINE \ System \ CurrentControlSet \ Control \ Terminal Server \ WinStations \ RDP-Tcp \ portnumber
3. On the Edit menu, click Modify, and then click Decimal.
4. Enter the new port number, and click OK.
5. Exit Registry Editor.
Reply With Quote
  #6  
Old 19-10-2010
Member
 
Join Date: Feb 2008
Posts: 2,631
Re: XP Port 3389 Not Listening

To change the default port for all new connections created on the Terminal Server:
1. Run Regedt32 and go to this key:
- HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp
2. Find the "PortNumber" subkey and notice the value of 00000D3D, hex for (3389). Modify the port number in Hex and save the new value. To change the port for a specific connection on the Terminal Server, Run Regedt32 and go to this key:
- HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Terminal Server\WinStations\connection
3. Find the "PortNumber" subkey and notice the value of 00000D3D, hex for (3389). Modify the port number in Hex and save the new value.
Please Note : Because the use of alternate ports has not been fully implemented for Terminal Server 4.0, support will be provided as "reasonable effort" only, and Microsoft may require you to set the port back to 3389, if any problems occur.
Reply With Quote
  #7  
Old 30-12-2010
Member
 
Join Date: Dec 2010
Posts: 2
Re: XP Port 3389 Not Listening

If Terminal Services and Remote procedure call services are up, and no 3389 port listed on netstat -na then do the following (as a last option before repairing SO):

1) Download devcon.exe from (http://support.microsoft.com/kb/311272) and run devcon.exe.

2) An Extractor will popup, extract to "C:\devcon" or otherwise folder u like.
3) Open a cmd prompt and navigate to the i386 folder extractor made.
4) Type: devcon.exe -r install %windir%\inf\machine.inf root\rdpdr (All connections will be closed and machine will restart, save your work before execute that, and proceed)

The machine will do a process, and then restart, wait until windows start, and then do an netstat -na, if the port 3389 appears listening it's all done.

Good luck!
Reply With Quote
Reply

  TechArena Community > Technology > Networking & Security
Tags: , , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "XP Port 3389 Not Listening"
Thread Thread Starter Forum Replies Last Post
Terminal Services not working - Port 3389 not listening mgorman@elitefoodco.com Windows Server Help 4 30-12-2010 10:57 PM
When Listening port vs Proxy SOCKS port are used? rooki Windows Software 3 24-06-2010 04:05 PM
How to allow TCP port 3389 on Windows Firewall DotNetUser Networking & Security 2 31-07-2009 06:05 PM
Unable to make connection to SSL tunnel through port 3389 Rixwel Networking & Security 3 20-06-2009 12:19 PM
How do I open Port 3389 MilesAway Small Business Server 10 01-07-2008 10:30 AM


All times are GMT +5.5. The time now is 04:15 AM.