Results 1 to 7 of 7

Thread: Help to connect to network with WPA-PSK wpa_supplicant

  1. #1
    Join Date
    Dec 2009
    Posts
    67

    Help to connect to network with WPA-PSK wpa_supplicant

    It turns out that I'm trying to run the latest wifi in openSUSE 10.2 but there is no way to connect to the access point. The network card is a Realtek 8187 USB, specifically the one that comes with the motherboard Asus P5B Deluxe wifi. Opensuse did not recognize her at first but I went to realtek website and found a driver I could install and seems to work. That itself within the network settings Yast I see this card, only the two integrated cards that also brings the motherboard (which I do not use disabled ) The card should have a fixed IP 192.168.100.2, mask 255.255.255.0. The wireless router is 192.168.100.1 and channel 12. The network is called "Home Network" and works by WPA-PSK with TKIP encryption. Well this is what I've done so far but does not connect. Wpa.conf My file is as follows:
    Code:
    network = (
    	 proto = WPA
    	 key_mgmt = WPA-PSK
    	 pairwise = TKIP
    	 ssid = "Home Network"
    	 psk = "password"
    	 # Psk = f6b13ae655af91c4be036375afaa6bbc9e105f753dbcf3be2614cd6e516d9254
    	 priority = 5
     )
    What am I doing wrong or what am I forgetting to do? I tried setting the other ways I've found over the network (adding ap_scan = 2, scan_ssid = 1, etc ...) and I can connect no. Please help me to sort out my issue.

  2. #2
    Join Date
    Mar 2008
    Posts
    151

    Re: Help to connect to network with WPA-PSK wpa_supplicant

    I have little experience with the issue of wireless cards in linux but you could try another distribution, I mean you could try a Knoppix Live CD to see if it works ... Also mine friend was having the similar problem. But his card is an Atheros and my Fedora distribution, and end up using WPA rather than WEP (although obviously less secure), and it works perfectly. In a message for this forum, I remember seeing the solution for WPA.

  3. #3
    Join Date
    Dec 2009
    Posts
    67

    Re: Help to connect to network with WPA-PSK wpa_supplicant

    I was also thinking about trying to use WEP (although I have not tried yet) but I prefer to exhaust the possibilities before WPA, pq I think I have it very close In my other PC with opensuse 10.0 and c54ru conceptional card could connect without problems using wpa, but the same steps you followed to configure not working now.

  4. #4
    Join Date
    Oct 2008
    Posts
    107

    Re: Help to connect to network with WPA-PSK wpa_supplicant

    I try one wep encryption to 128, closing the DHCP settings on the router to the amount of PC to wait to connect, to capture the MAC of the wireless and configure the router to always assign the same IP to that MAC thus closing a few more chances to steal signals. In my case I had a wireless card D-Link DWL-G520 (Atheros is). In SuSe 10 recognized it went down in 10.1 and Atheros drivers reconoción, but in 10.2 I could not help but question, however I downloaded the Atheros drivers for SuSe 10.2, I did it manually, I did for yast, including the link Installation Source, but nothing. I showed the card in yast, the configured for WEP but give it a iwconfig, I sent several messages that they said no wireless extensions. I tried to configure it for several days (formatting and reconfigure again) but nothing. So before returning to the 10.1, I decided to put the wireless on this pc with windows and physically connect the other with Linux.

  5. #5
    Join Date
    Oct 2008
    Posts
    119

    Re: Help to connect to network with WPA-PSK wpa_supplicant

    What surprises me is that you will not show the card in YAST but good. If you want to continue intentanto found this RMP for openSUSE 10.2 wpa_supplicant-gui-0.4.9-27 RPM for i586, look at the dependencies you'll need. OpenSuSe distro is the most I've used (and not learned hehe) but removing it from going support to the things with each new version and not documented as adequately resolve it bothers me. What I always scrub in the case of wireless and my TV card Pinnacle PCTV USB. In versions 9 through 10.0 thoroughly. As I was fond of this distribution I have, I'm going to keep staying with it, to see what will happen with the convention Novell / Microsoft, but I have been testing other objects like Kubuntu, Ubuntu, Mandriva, CentOS, Fedora.

  6. #6
    Join Date
    Oct 2008
    Posts
    161

    Re: Help to connect to network with WPA-PSK wpa_supplicant

    If you talk about security and say the only only way to make your network secure WLAN is to create a VPN into your LAN, so are two encryptions, especially VPN encryption is more secure than WAP or WPE, on the other side is me you happen to like working network card will put a sniffer to see if it detects traffic or what happens ...

  7. #7
    Join Date
    Oct 2008
    Posts
    137

    Re: Help to connect to network with WPA-PSK wpa_supplicant

    To tell you the truth they are just as insecure, only one has more security levels than others, definitely these encryption algorithms are useless. That is why it is developing a new encryption algorithm to protect networks REAL. But tell us what happened to your network and if you could connect, you have not said what manages the Realtek chipset, maybe it is easier and help us ...

Similar Threads

  1. Replies: 5
    Last Post: 15-03-2012, 03:40 PM
  2. Replies: 9
    Last Post: 01-10-2011, 12:14 AM
  3. "windows unable to connect with sky network" in my home wifi network
    By Baby bon bon in forum Networking & Security
    Replies: 4
    Last Post: 03-02-2011, 10:44 AM
  4. Fails to connect to network on boot, have to reset network adapter
    By Gopieee in forum Windows Vista Network
    Replies: 4
    Last Post: 15-04-2009, 07:24 PM
  5. Can't Connect to Juniper Network Connect 5.4.0
    By Ulupy in forum Vista Help
    Replies: 1
    Last Post: 01-05-2008, 02:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •