Go Back   TechArena Community > Technology > Networking & Security
Become a Member!
Forgot your username/password?
Register Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



Networking skipped in installing Solaris 9, 10 behind a Linksys router

Networking & Security


Reply
 
Thread Tools Search this Thread
  #1  
Old 15-07-2010
Member
 
Join Date: Mar 2010
Posts: 29
Networking skipped in installing Solaris 9, 10 behind a Linksys router
  

I am facing difficulty in installing Solaris 9 or 10 on a computer which is behind Linksys router. It does not gives me the option to enter the ISP details like IP address, subnet mask, gateway etc. Basically Solaris was installed but the only thing is that there is no network connection. I don't see anything when I try to see it with ifconifig -a command. Is this the problem related to my NIC or the router? Can you suggest me some help in this matter?

Reply With Quote
  #2  
Old 15-07-2010
Member
 
Join Date: Mar 2009
Posts: 1,223
Re: Networking skipped in installing Solaris 9, 10 behind a Linksys router

Did you checked it your card has been detected? If you don't know how to see this then use 'dladm show-dev' command and post back its output. This command will show you if Solaris has recognized your card. If it has then you just have to plumb it up with the 'ifconfig [ifname] plumb' command. If it didn't, then you may need to load up some drivers and for that we need some details about your nic.
Reply With Quote
  #3  
Old 15-07-2010
Member
 
Join Date: May 2008
Posts: 945
Re: Networking skipped in installing Solaris 9, 10 behind a Linksys router

Is your network card too old? If it is then I doubt if it is supported under Solaris. However if you want then you can try out finding some drivers for your card via google. May be an older driver might even help you to get your networking. If possible (if you have a cardbus or pci slot) then I would recommend you to purchase a new NIC.
Reply With Quote
  #4  
Old 15-07-2010
Member
 
Join Date: Jun 2009
Posts: 1,205
Re: Networking skipped in installing Solaris 9, 10 behind a Linksys router

Is your card in the hardware comparison list found on this website? Just visit the site and see if it is present to be compatible with Solaris OS. Even I had some similar issue when installing Solaris 10 on my computer. After a lot of research I found out that my network card was not on the list of HCL for Solaris OS.
Reply With Quote
  #5  
Old 15-07-2010
Member
 
Join Date: Nov 2008
Posts: 1,068
Re: Networking skipped in installing Solaris 9, 10 behind a Linksys router

Are you using Intel network card? If it is then Solaris will not recognize the PCI
number and Vendor ID. So add the line:
Quote:
elxl "pci10b7,7646"
to /etc/driver_aliases and also add the line:
Quote:
setprop acpi-user-options '0x2'
to /boot/solaris/bootenv.rc
Reply With Quote
Reply

  TechArena Community > Technology > Networking & Security
Tags: , , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Networking skipped in installing Solaris 9, 10 behind a Linksys router"
Thread Thread Starter Forum Replies Last Post
No internet, both isp router and linksys router not working Rumblebuffin Networking & Security 2 02-11-2011 06:50 AM
Not able to connect Linksys AE2500 adaptor and Linksys E4200 router. Barnard Networking & Security 9 20-09-2011 11:44 AM
Problem Installing Solaris 10 Anthony12 Windows Software 3 28-07-2010 03:24 PM
Installing Firefox on Solaris 10 Rivan Operating Systems 4 15-07-2010 05:50 AM
Installing Solaris 10 blindsleeper Operating Systems 3 15-09-2008 06:01 PM


All times are GMT +5.5. The time now is 02:20 AM.