Results 1 to 5 of 5

Thread: Networking skipped in installing Solaris 9, 10 behind a Linksys router

  1. #1
    Join Date
    Mar 2010
    Posts
    29

    Networking skipped in installing Solaris 9, 10 behind a Linksys router

    I am facing difficulty in installing Solaris 9 or 10 on a computer which is behind Linksys router. It does not gives me the option to enter the ISP details like IP address, subnet mask, gateway etc. Basically Solaris was installed but the only thing is that there is no network connection. I don't see anything when I try to see it with ifconifig -a command. Is this the problem related to my NIC or the router? Can you suggest me some help in this matter?

  2. #2
    Join Date
    Mar 2009
    Posts
    1,221

    Re: Networking skipped in installing Solaris 9, 10 behind a Linksys router

    Did you checked it your card has been detected? If you don't know how to see this then use 'dladm show-dev' command and post back its output. This command will show you if Solaris has recognized your card. If it has then you just have to plumb it up with the 'ifconfig [ifname] plumb' command. If it didn't, then you may need to load up some drivers and for that we need some details about your nic.

  3. #3
    Join Date
    May 2008
    Posts
    945

    Re: Networking skipped in installing Solaris 9, 10 behind a Linksys router

    Is your network card too old? If it is then I doubt if it is supported under Solaris. However if you want then you can try out finding some drivers for your card via google. May be an older driver might even help you to get your networking. If possible (if you have a cardbus or pci slot) then I would recommend you to purchase a new NIC.

  4. #4
    Join Date
    Jun 2009
    Posts
    1,205

    Re: Networking skipped in installing Solaris 9, 10 behind a Linksys router

    Is your card in the hardware comparison list found on this website? Just visit the site and see if it is present to be compatible with Solaris OS. Even I had some similar issue when installing Solaris 10 on my computer. After a lot of research I found out that my network card was not on the list of HCL for Solaris OS.

  5. #5
    Join Date
    Nov 2008
    Posts
    1,066

    Re: Networking skipped in installing Solaris 9, 10 behind a Linksys router

    Are you using Intel network card? If it is then Solaris will not recognize the PCI
    number and Vendor ID. So add the line:
    elxl "pci10b7,7646"
    to /etc/driver_aliases and also add the line:
    setprop acpi-user-options '0x2'
    to /boot/solaris/bootenv.rc

Similar Threads

  1. No internet, both isp router and linksys router not working
    By Rumblebuffin in forum Networking & Security
    Replies: 2
    Last Post: 02-11-2011, 06:50 AM
  2. Replies: 9
    Last Post: 20-09-2011, 11:44 AM
  3. Problem Installing Solaris 10
    By Anthony12 in forum Windows Software
    Replies: 3
    Last Post: 28-07-2010, 03:24 PM
  4. Installing Firefox on Solaris 10
    By Rivan in forum Operating Systems
    Replies: 4
    Last Post: 15-07-2010, 05:50 AM
  5. Installing Solaris 10
    By blindsleeper in forum Operating Systems
    Replies: 3
    Last Post: 15-09-2008, 06:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •