Results 1 to 7 of 7

Thread: BT4 VMWare image: networking broken

  1. #1
    Join Date
    Apr 2010
    Posts
    80

    BT4 VMWare image: networking broken

    Hello,
    I downloaded the vmware version of BT4 and when I did "ifconfig" it is only the inferface "lo" which appears. When I type iwconfig, I "lo", "eth0" and "eth1" with marked face no wireless extension. Under VMware, I created a second network card, I configured in different ways: NAT, bridge, ... but nothing works!! My wireless card is an Intel Pro 3945ABG. If you have any ideas or advice, please share with me.!!

  2. #2
    Join Date
    Feb 2008
    Posts
    75

    Re: BT4 VMWare image: networking broken

    It may not sound bad, do you only thought SEARCH before asking your question? 90% of subjects that contain "VMWare" give the answer to your problem: the internal cards are not supported in virtual machine. If you want to do WiFi pen-testing like that, you need an external adapter (USB).

  3. #3
    Join Date
    Oct 2008
    Posts
    107

    Re: BT4 VMWare image: networking broken

    You should try the following three ways :
    1. In a shell:
      / Etc / init.d / wicd start
    2. internet menu:
      launch wicd and configure your interfaces.
    3. shell
      / Etc / init.d / update-rc.d wicd defaults

      (So that the service starts at every boot)

  4. #4
    Join Date
    Mar 2008
    Posts
    151

    Re: BT4 VMWare image: networking broken

    I know the wifi interface does not appear under vmware. What I do not understand is that I have no interface to connect to the net. While under the BT3, I was also running under VM they appear, as well as Ubuntu. As the BT4 is based on Ubuntu I would say that I tried, iwconfig, / etc / init.d Networking start and / etc / init.d start NetworkManager and dhclient but nothing seems to be worked. There is an error somewhere.

  5. #5
    Join Date
    Oct 2008
    Posts
    161

    Re: BT4 VMWare image: networking broken

    Type "ifconfig-a" to see all your interfaces. "Ifconfig" alone displays only active ones. The evidence, eth0 and eth1 appear in iwconfig. Start by removing the second network card that you created in VMWare, it is probably unnecessary. And let the primary interface with NAT is good. Then type "dhclient eth0" to enable VMware and let him give an address. If it does not work, give us the result of "dhclient eth0" here, and "ifconfig eth0". Hope that it helps you.

  6. #6
    Join Date
    Feb 2008
    Posts
    130

    Re: BT4 VMWare image: networking broken

    Hello to all, is starting back on track four I have one question :
    I Backtrack4 under vmware with vista. My problem is that I have internet at backtrack4 but in regard to: / etc / init.d / NetworkManager start [fail]. I have tried many things to activate this but nothing is working. So I thought that there would be someone who would be interested in helping me. Please tell me how to activate it..??

  7. #7
    Join Date
    Oct 2008
    Posts
    137

    Re: BT4 VMWare image: networking broken

    If you go to your network administrator VMWare virtual preconfigured really two examples, the VMNet1 and VMNet8. The concerns you in your case is VMNet1, host only. Using teams is like having a subset of network in which the machines are at each other and the allocation of IPS is done via DHCP. Try setting up two virtual machines and enables VMNet1 so the DHCP service, q default I think it is enabled. If you view the network administrator and VMWare virtual mask options, DHCP and VMNet1 rest of haras you an idea of how it works, that is the virtual switch. From DOS ipconfig look at both and see the IPs that receive and the Gateway. From there is up to you if you want to disable the DHCP service and manually assign IPs respecting the mask, but stay with the IP of the virtual switch. As both virtual machines online documentation says that having a proxy service enabled on the host or simply by enabling the option to share internet connection in the connection properties that will host shoots.

Similar Threads

  1. How to get MacOSXLion VMWare image in MBs - PLEASE ANSWER!
    By sairohit123 in forum Operating Systems
    Replies: 1
    Last Post: 25-06-2012, 07:10 PM
  2. VMWare Image - OVF
    By Niantic in forum Windows Software
    Replies: 6
    Last Post: 11-05-2010, 09:16 AM
  3. Convert Vmware Image to Virtualbox Image
    By rashmi_ay in forum Windows Software
    Replies: 5
    Last Post: 23-12-2009, 01:56 PM
  4. Unable to delete broken image icons on n85
    By Luther in forum Portable Devices
    Replies: 3
    Last Post: 13-11-2009, 10:46 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •