Go Back   TechArena Community > Technology > Networking & Security
Become a Member!
Forgot your username/password?
Register Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



Schannel error on Windows 7 Pro

Networking & Security


Reply
 
Thread Tools Search this Thread
  #1  
Old 04-12-2009
Member
 
Join Date: Sep 2009
Posts: 87
Schannel error on Windows 7 Pro
  

Just few days back i had bought a new Dell Latitude laptop. i had installed Windows 7 Pro as my operating system on it. Now the problem is that after installing Windows 7 Pro on my Dell Latitude laptop, i get the following error message in my System Event Log:
Quote:
Source: Schannel
Event ID: 36888
Level: error
User: SYSTEM
Task Category: none
Can any one tell me that why i'm getting Schannel error on Windows 7 Pro? Does any body knows about it? What i need to do in order to get rid of the above issue? Any help you can provide would be greatly appreciated. Thanks in advance.

Reply With Quote
  #2  
Old 04-12-2009
Member
 
Join Date: Jan 2006
Posts: 3,778
Re: Schannel error on Windows 7 Pro

This behavior is caused by the SMTP service processing an incoming EHLO command if no certificate is assigned to an SMTP site. When you enable Schannel event logging on a computer that is running any Microsoft Windows NT Server 4.0, or Microsoft Windows 2000 Server, or Microsoft Windows XP Professional, detailed information from Schannel events can be written to the Event Viewer logs, in particular the System event log.
Reply With Quote
  #3  
Old 04-12-2009
Member
 
Join Date: May 2008
Posts: 2,946
Re: Schannel error on Windows 7 Pro

This error usually indicates that your computer cannot complete the trust chain on the certificate that you are using for schannel. Check to see whether the certification services are running on the server, if yes, either disable the service or uninstall the Certificate server component. Use "dsstore -dcmon" and look at a verbose display. Correct the trust chain on the certificate that you are using for schannel.
Reply With Quote
  #4  
Old 04-12-2009
Member
 
Join Date: Feb 2008
Posts: 2,632
Re: Schannel error on Windows 7 Pro

I solved the problem by granting NETWORK SERVICE the same permissions on =Machinekeys folder as to SYSTEM. Opened up MMC and loaded the Certificates Store for theLocal Computer (while on the Domain Controller), I found the Certificate I was having troubles with and right clicked on it, went to All Tasks and then "Renew with Citrix XTE service is run under the NETWORK SERVICE account and it was = not accepting SSL relayed connections. Now all is fine. Same Key". This put the private key back into the certificate.
Reply With Quote
  #5  
Old 04-12-2009
Member
 
Join Date: Apr 2008
Posts: 3,343
Re: Schannel error on Windows 7 Pro

Your software needs write permission of that Temporary folder. This event is logged when a server application (for example, Active Directory) attempts to perform a Secure Sockets Layer (SSL) connection, but no server certificate is found. To provide write permission to NT Authority\Network Services account for your "Temporary ASP.Net Files" folder, Simple right click on that folder -> select Security tab -> Click Add -> Click Advance button -> Click Find Now button -> Select NT Authority\Network Services from the list -> Click Ok -> Click Ok again -> select Allow write -> Click Ok.
Reply With Quote
Reply

  TechArena Community > Technology > Networking & Security
Tags: , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Schannel error on Windows 7 Pro"
Thread Thread Starter Forum Replies Last Post
Schannel Error causing laptop to freeze SteveEdson Operating Systems 3 11-10-2011 01:33 PM
Schannel Error 36888 ^Saraniya^ Operating Systems 5 05-01-2011 06:17 PM
Windows 7: What is Schannel Indulal Operating Systems 5 05-08-2010 03:23 AM
Schannel 36882 troy Active Directory 0 17-09-2007 06:38 PM
schannel error 36870 (extended 0x80090016) Justvicks Windows Security 3 06-09-2007 05:40 PM


All times are GMT +5.5. The time now is 09:05 PM.