Go Back   TechArena Community > Technology > Networking & Security
Become a Member!
Forgot your username/password?
Register Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



How to configure pppoe on Fedora ?

Networking & Security


Reply
 
Thread Tools Search this Thread
  #1  
Old 23-03-2009
Member
 
Join Date: Oct 2008
Posts: 62
How to configure pppoe on Fedora ?
  

Hello ,I am having some problem with pppoe configuration on fedora Can you Tell me How can We Configure pppoe on Fedora operating system Thanks in advance for your replies

Reply With Quote
  #2  
Old 23-03-2009
Member
 
Join Date: May 2008
Posts: 181
Re: How to configure pppoe on Fedora ?

Hello , in fedora it is "pppoe-setup" for "pppoeconf". open terminal go to superuser becoz fedora doesn't allow normal users to configure pppoe. if it says command not found probably you may not have included /sbin in your path, in that case run /sbin/pppoe-setup and answer to all questions as you have done in ubuntu and start pppoe with "pppoe-start" command and you can stop it with "pppoe-stop" command don't try pppd or any thing as this is easy and convenient way.
Reply With Quote
  #3  
Old 23-03-2009
Member
 
Join Date: Feb 2008
Posts: 2,631
Re: How to configure pppoe on Fedora ?

Browse to the "System Tools" menu (in the start menu) and click "Network Device Control". It will open the window as shown below.

If you have properly configured the network during installation then you can directly jump to step 'Creating an xDSL connection'. But in case you have not, then we first need to configure the network. In the "System Tools" select "Internet Configuration Wizard". This will bring up the following window. Select "Ethernet Connection" from the available options.


Select the appropriate Ethernet card that you need to configure. Please note that this guide explains setup considering a single NIC in the system. In case the system has multiple cards then the respective steps need to be repeated accordingly in case to configure each of them.


Provide the IP address and the subnet mask. This will be provided by the local cable guy who installed the connection. Secondly it is highly likely that you will have a dual boot system. So one way to obtain this is to logon to windows and issue the command "ipconfig" at the windows command prompt (make sure you are not connected to the Internet). Note down your IP and the Subnet mask from the output of "ipconfig".

Once this is done you will see a summary of the settings. Click "Apply" to complete setup of the Ethernet connection (eth0). Once done the "Network Device Control" window pops up. It will list the newly created connection eth0, but it will be in "Inactive" state. To activate eth0, select it and click on the "Activate" button. The status will be reflected as shown in the image below.

With this you have successfully setup the ethernet connection. Now we proceed to setup the PPPOE connection over this ethernet connection

Now we are setting up the xDSL connection i.e. we are setting up the PPPOE connection so as to use the Point to Point Protocol Over Ethernet (eth0). Please note that eth0 needs to be in "Active" state for further step to work. So now to to the "Internet Configuration Wizard " in the "System Tools" menu. This time select "xDSL Connection" as shown below.

Now we need to configure this xDSL connection. We first need to specify which Ethernet connection is to be utilized to setup the PPPOE connection. We use connection eth0 which we configured in steps 1 to 5 above. Also provide a name for this connection and the username and password (provided by the ISP). Clicking "Next" displays the summary. Click "Apply"

This will bring up the "Network Configuration Window" again. However note that the VSNL connection will be in "Inactive" state.

We still need to configure it further. Select the VSNL connection and click "Edit". This will bring up the following window. Here in the "General" tab you can make additional configuration settings. In case you need to connect to the Internet (i.e. activate connection VSNL) during boot time them tick the check box "Activate device when computer starts". See screenshot below.

Leave the other tabs as it is and select the "Advanced" tab. Here we need to specify the service name and the access concentrator. To obtain a list of access concentrators, use the command "/sbin/pppoe -A". It will list the various access concentrators. Since I have a Tata Indicom (VSNL) broadband service it shows VSNL_BRAS_1 as one of the access concentrators. You can leave the service blank. You can contact your ISP and request for the service name and the access concentrator for their service. Enter them and click on OK button.

Once done you will be at the "Network Configuration Window". Select the VSNL connection and click on "Activate" button. After some delay (approx 10 seconds) the connection status will change to "Active".
Reply With Quote
  #4  
Old 23-03-2009
Member
 
Join Date: May 2008
Posts: 2,944
Re: How to configure pppoe on Fedora ?

Hello , there is a script which is called adsl-setupit will do all the configuration for you and it comes with the distribution. I had this problem once and, after readeang and configuring pppoe and the network setting, i found this script which did the job in 2 minutes you can search for it on google
Reply With Quote
Reply

  TechArena Community > Technology > Networking & Security
Tags: ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "How to configure pppoe on Fedora ?"
Thread Thread Starter Forum Replies Last Post
Disabling Nat and Firewalls on PPPoE Eashta^devata Networking & Security 3 19-09-2011 01:01 AM
How to configure repeater for PPPoE Connection? GiveNTake Networking & Security 6 29-05-2011 01:17 AM
Fedora Linux: How to configure Oracle with the server? Viraana Operating Systems 5 11-11-2010 03:53 AM
Windows 2008 RRAS and PPPoE Massimo Windows Server Help 9 20-08-2009 09:37 PM
2 PPPOE dial up connections Xena Technology & Internet 3 17-04-2009 03:11 PM


All times are GMT +5.5. The time now is 04:46 AM.