Go Back   TechArena Community > Technical Support > Computer Help > Office Help > MS Office Support
Become a Member!
Forgot your username/password?
Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



Auto spell check not working in Word 2007

MS Office Support


Reply
 
Thread Tools Search this Thread
  #1  
Old 24-04-2007
Member
 
Join Date: Sep 2004
Posts: 74
Auto spell check not working in Word 2007

While creating any new doc in Word 2007I am getting issue with spell check. Word is not at all detecting my mistake and it is a bit annoying to work on the same. Still in the end when I read the article again I found tons of mistake. I am not able to locate that before so that I can simply fix the error and save some time in reading the article again and again.

Reply With Quote
  #2  
Old 24-04-2007
Member
 
Join Date: Aug 2008
Posts: 1
After installing Office 2007 the english spell checker in outlook express was in french only. By doing as i did I was able to use an english spell checker on outlook express. My problem is that the Spell Checker has a life of its own. Every time i run it it crashes my Word 2007. Anybody any ideas ?? I've tried the diagnostics etc, closed it down, started it up again, done what suggested earlier. I'm running a trial version of Office Professional 2007.
Reply With Quote
  #3  
Old 22-07-2007
Member
 
Join Date: Jul 2007
Posts: 1
Well, the following worked for me while I was having this problem:

Go to the review tab. Under the proofing section, click on select language. A dialog box will open allowing you to select your language (this should be your preferred language with a check mark on the side and a little abc icon). There are two boxes at the bottom. One says, do not check spelling or grammar. Make sure there is NOT a check mark in this box. The other box says, detect language automatically. This one should be checked. I don't know why, but I have had one document open with the right boxes checked, and have opened another document and had the wrong one checked. If the wrong box is checked, fix it. Close the document and reopen. Like I said, this is what has happened to me and this fixed it. Sounds like a lot of things could be wrong since it appears there are way too many ways to disable the checker.

I know I was pulling my hair out trying to figure out why my spell checker wouldn't work. I am also no techie. I like office 2007, but it seems a little more difficult to control all of the options, and I certainly do not like having more than one place to change settings, like turning off or on spellchecker. Especially when it seems the software turns off settings by itself.

I opened the registry editory and could not find the file listed that you mentioned to delete: "HKEY_CURRENT_USER\Software\Microsoft\Shared
Tools\ProofingTools\1.0\Override\en-US" The only file listed was "Default." Per another posting, I switched my Language Preferences to English (Australia) and restarted. This did not fix issue. The preferences to hide spelling errors isn't checked. Any other suggestions?

You may try doing this also.

Click on Office button (top left) in word.
Click on word oprions button.
Click on Add-ins.
In the Manage box select "Disabled items" and click on Go.
In the dialog box select en-US spell checker if it is there and Click on
Enable.
Reply With Quote
  #4  
Old 16-08-2007
Member
 
Join Date: Oct 2005
Posts: 38
Try to install some new Office updates and then check back. I think the problem can be fixed by performing some updates. That would be a easy way to get rid of problem. Spell check is a part of office suite and it would not be working well unless you had installed it properly. You can run office diagnostic and if that does not help you simply re-install office once again.
Reply With Quote
  #5  
Old 17-08-2007
Member
 
Join Date: Oct 2005
Posts: 39
It is possible that it is disabled due to which you cannot use it. You can check out the settings and other add-ins. Click on Microsoft Office button first and there you can find out the settings related to Spell Check. You can click on Options to find out more stuff. I hope there would be some way to restore the default settings of Microsoft Office. That is one of the easiest way to get rid of problem that we are facing right now.
Reply With Quote
  #6  
Old 28-09-2007
Member
 
Join Date: Oct 2008
Posts: 1
I was having an intermittent problem with Word 2007 not spell checking text when pasted from other applications. Word would indicate that the spell check was complete with no errors, and clearly there where errors.

I did the process
Go to the review tab. Under the proofing section, click on select language. A dialog box will open allowing you to select your language (this should be your preferred language with a check mark on the side and a little abc icon). There are two boxes at the bottom. One says, do not check spelling or grammar. Make sure there is NOT a check mark in this box. The other box says, detect language automatically. This one should be checked. I don't know why, but I have had one document open with the right boxes checked, and have opened another document and had the wrong one checked.
I tried everything to get my spell check working, but your suggestion with the disabled add-in worked!!!!

I am not a hooplehead when it comes to PC's and software, but this one had me stumped for days.
I have even tried the registry deletion to no avail.

So, for those of you with issue who have tried everything else, try this:
Click on top left Word circle Icon
Go to bottom click on Word Options
Go to Add-ins
At bottom, should say "Manage: CD Add-ins" - change to "Disabled Items" then hit Go...
This should bring up Spell-check add in - select this.
Try spell check... IT WORKS!!

My spell checker now works! I have a vista so just searched regedit and then delete the keys as specified!

My spell checker works great now in all my programs - word, One Note etc!

Please note in the above chain that Beth Melton indicated the following
registry key needs to be deleted. I did it and it worked. Make sure that
Office programs are closed.

HKEY_CURRENT_USER\Software\Microsoft\Shared
Tools\ProofingTools\1.0\Override\en-US

Spell check was not working in Word 2007, but grammar check was OK. This is the solution that worked for me.
Reply With Quote
  #7  
Old 24-11-2007
Member
 
Join Date: Nov 2007
Posts: 1
I believe I have read everything posted, but am still not sure why spell check will not recognize the obvious errors. I believe I have double checked everything that has been mentioned and with the exception of the registry key >> HKEY_CURRENT_USER\Software\Microsoft\Shared
Tools\ProofingTools\1.0\Override\en-US

which I did not find, I am at a loss. The machine was recently updated from Office 2003 to Office 2007. I am not too familiar with working with the registry, so more information on creating a new entry would need to be provided.

First since I did not see my original post I assumed I messed up. If I ended up duplicating it, I apologize.

I believe I have read everything posted, but am still not sure why spell check will not recognize the obvious errors. I believe I have double and triple checked everything that has been mentioned and with the exception of the registry key >> HKEY_CURRENT_USER\Software\Microsoft\Shared
Tools\ProofingTools\1.0\Override\en-US

which I did not find, I am at a loss. The machine was recently updated from Office 2003 to Office 2007. I went through the other Office apps and made sure that their settings were not conflicting with Word's. There is a custom Dictionary, I can get rid of it if required. I thought of looking for the default dictionary so I could copy one from another machine, but now I do not think that will work, as I could not find it. I am not too familiar with working with the registry, so more information on creating a new entry would need to be provided.

First, the why it happened. When we finally called Microsoft, the nice support person indicated, Office 2003 used 32 bit encryption or format (something) and Office 2007 used 64 bit whatever. The numbers could also have been 16 to 32 but you get the drift. Anyway, if you open Word, go to options, get to the addins dialog box, then set it to look for disabled addins. Guess what should be there, spell checker. Re-enable it and everything will work fine.
I would give the specific steps but my daughter has her machine back and I'm still on 2003.
Reply With Quote
  #8  
Old 24-12-2007
Member
 
Join Date: Sep 2005
Posts: 58
Auto spell check not working in Word 2007

I had bought Office Enterprise 2007. I had not ordered a CD. I downloaded that from web. I had installed the same on a pc that has Windows Vista in it. The installation was fine. I open some old documents in Microsoft Word and activated Spell Check. But it is not working. The Auto Spell Check feature is disabled and it is not notifying any red or green line under sentences. The same thing works when I hit F7. Now in Excel there is no issue with that. Auto Spell Check is working fine in it but the same is causing trouble in Word.
Reply With Quote
  #9  
Old 15-04-2008
Member
 
Join Date: Sep 2005
Posts: 76
There are some settings that can help you. For that click on the Office Button on top left and then there click on Word Option. In that click on Proofing and click on Custom Dictionary. You have to enable custom.dic here. Once it is done close word and start it again. Open your documents and then see. It would start working.
Reply With Quote
  #10  
Old 30-04-2008
Member
 
Join Date: Apr 2008
Posts: 1
Yahoo..I am so glad I found this site! I felt like complete goof! Just tryin to make sure I spelled enormous correctly and then a spell check problem. Thanks for your help. However...I tried to post what I learned before I read all the other responses....so I put the instruction on a post too. But I am just trying to figure this posting site out. Anyway...until the next problem. Bye!
Reply With Quote
  #11  
Old 20-05-2008
Member
 
Join Date: May 2008
Posts: 1
This was the ticket for me. Thanks so much for the help.

I usually don't reply to posts like this but it worked for me too the 1st time. This was the 1st site I visited also. So I using the rest of the time that it should have taken to solve the problem to post a reply so anyone else looking for the solution will see that it works. Also, you don't need to restart the whole pc, just delete the key and restart Word and BOOM, it will start spell checking on the fly.

I'm running WinXP, just had office 2003 installed and upgraded to 2007 just for the spell checker in Outlook. I purchased 2007 because it's the Outlook of choice for the iPhone but the spell checker DIED in the e-mail. So installed 2007 and no spell checker. Thanks a lot Microsoft. Once again their inability to program has kept me in business for the 10th straight year.
Reply With Quote
  #12  
Old 11-09-2008
Member
 
Join Date: Sep 2008
Posts: 1
It is not a file but a KEY in the registry. Are you sure you wish to do this, as the thread you replied to is months old and no longer exists on the Microsoft server.
Reply With Quote
  #13  
Old 14-04-2009
Member
 
Join Date: Sep 2004
Posts: 63
I can provide you the setup that would allow you to manage spell check. Go in Tools and then there click on Options menu. In that click on Spelling and Grammar Tab. Click on Check Spelling as you type. Enable this option and then again tick on Check grammar with spelling. The last thing you have to do is remove the tick from hide spelling error and hide grammatical error. Those would be easy way to fix the problem that you are facing.
Reply With Quote
  #14  
Old 29-04-2009
Member
 
Join Date: Apr 2009
Posts: 1
re: Auto spell check not working in Word 2007

I was searching for about 10 minutes and found my REALLY simple problem.

1. Go to a word document that the spell check is not working.
2. Go to the "Review" Tab at the very top (It's the sixth one.)
3. Click the button "Set Language" right next to translate.
4. At the bottom of the new window, will be two checked boxes, the second one says "Detect Language Automatically" which should be checked. However if the first one IS checked, you found your problem. Uncheck the box that says "Do not check spelling and grammar" and, bingo you got it!

Hope This Helps!
Reply With Quote
  #15  
Old 17-07-2009
drwiremore
 
Posts: n/a
I've noticed something odd about my word 2007 spell checker: it doesn't
catch all of my errors. Given I have two paragraphs, with the same
words misspelled in both paragraphs: it found and corrected the error in
the 1st paragraph, but doesn't find it in the 2nd paragraph. I'm
stumped.

Windows XP SP3, Word 2007: That was the short of it, and for sanity,
I did the regedit and cleared out /12/word; as well as confirmed in
windows options that I have a US English spell/grammar AND in those same
options I reset the document. But I don?t have a non working spell
checker; I have a mostly working spell checker.

The paragraph: two words clearly spelled.

Those are the highlights from my notes, and my apologies if I?ve left
something out that was important. You seemed to believe that we had a
good fit: my skills, _experneice_ and _requireZments_. <<my spell
checker didn?t catch these misspelling as I wrote this note?. (copied
the offending paragraph)

The attachment has two ?identical? paragraphs, without the underline.
I can fix it by doing a format painter on the top paragraph, but can?t
find a way to ?recognize? that there is something that needs to be
fixed. Your help as always is appreciated. What about the 12 page
document with who knows how many errors not caught?

Some background:
I'm viewing all hidden characters, have the document being viewed in
draft and paragraph 1 and paragraph 2 are both "normal" and have
confirmed that everything is the same. (although ? is different)

Now: while it doesn't solve anything, here is what didn't work:
- MOB>word options > proofing > recheck document.

So, I used the format pointer: selected the first paragraph > double
click format pointer > then clicked the 2nd paragraph.
Now: this worked in flagging the spelling errors in the 2nd paragraph,
after I:
- MOB>word options > proofing > recheck document.

The question: what is the root cause?. Because trial/error on a large
more complex document, won?t work. And yes, I've already set show all
formatting marks. and hidden text. Figuring my solving this may help
someone else. A spell check that catches some of your errors... is
useless in professional writing. dw

Solved: Seems that a paragraph can be "set" to "do not check spelling or
grammar." But you have to go look and find it. How does this happen you
ask: "I don't know."

Best would be, if you suspect an issue, select the entire document, and
click: review> set language (to the right of thesaurus, with a red
check mark on it) > uncheck the "Do not check spelling or grammar. Who
would put a do-not-check spelling or grammar buried under thesaurus....
dw

Full credit to the person who described it:

In a blank document in Word 2007, select the lone paragraph mark. On
the Review ribbon, in the Proofing group, click the Set Language
button. In the dialog, I think you'll find that the "Do not check
spelling or grammar" box is checked. Uncheck it, and then click the
Default button to apply the setting to the Normal template. Click Yes
in the message that asks whether to change the default, and click OK
to close the Language dialog.
Reply With Quote
Reply

  TechArena Community > Technical Support > Computer Help > Office Help > MS Office Support
Tags: , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Auto spell check not working in Word 2007"
Thread Thread Starter Forum Replies Last Post
How to change language in Word 2007 spell check??? Samarth MS Office Support 1 04-02-2013 01:52 PM
Word 2007 spell check stopped working NGV BalaKrishna MS Office Support 2 04-02-2013 01:00 PM
Word 2007 Spell Check not working. ridergroov MS Office Support 12 19-10-2011 05:02 AM
Word 2007 Spell Check burnedfaceless MS Office Support 2 03-03-2011 01:06 AM
Possible Fix for nonfunctioning spell check in Word 2007? LavRaj MS Office Support 3 09-07-2010 06:45 PM


All times are GMT +5.5. The time now is 05:53 AM.