Go Back   TechArena Community > Technical Support > Computer Help > Office Help > MS Office Support
Become a Member!
Forgot your username/password?
Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



Auto spell check not working in Word 2007

MS Office Support


Reply
 
Thread Tools Search this Thread
  #16  
Old 15-09-2009
Member
 
Join Date: Sep 2004
Posts: 81
I got the problem when I upgraded to 2007. I am not able to find out any relative settings behind, which can relatively help me to fix it. I later on removed Office 2007 and then installed the same from scratch. Things went fine there. There was no problem at all.
Reply With Quote
  #17  
Old 07-01-2010
Member
 
Join Date: Jan 2010
Posts: 1
Go to "Start"->"Run", then type "regedit" and follow the link as it is mentioned before:
"HKEY_CURRENT_USER\Software\Microsoft\Shared Tools\Proofing
Tools\1.0\Override"

After trying everything listed here, I realized that the user was typing everything in caps for his powerpoint. In proofing options it is set to ignore words in uppercase. Hope it helps! :)
Reply With Quote
  #18  
Old 12-01-2010
DJC DJC is offline
Member
 
Join Date: Jan 2010
Posts: 1
Re: Word 2007 Spell Check Issues

Point to note: The bottom left of the word screen where the page and word count is located there is an tab telling you which language your program is spell checking in. Despite what the proofing language setting says or the word options are this one is the one you need to change.

Things mentioned by other people which failed for me but might work for you
Click on the language tab mentioned above in the bottom left of the Word application, make sure the Detect Language option is ticked and the Do Not Check Spelling option is not ticked, then select English UK and click Default followed by OK. This changes the Language to English UK but then reverts back to the other Language shortly after.

Click the Office button (top left corner) of word, select Word Options, go to Proofing and check Auto correct and Custom Dictionary.

Click the Office button, select Word Options and select Add-Ins, go to the Manager at the bottom and from the menu select Disabled Items and click GO. If you see the en-US or en-UK spell check enable it. This worked for some people but not for me.

Click the Office button, select Word Options and go to Resources and check for updates to Office and Windows to see if anything got missed.

In word click on the Review tab then go into the proofing section and click Set Language, this works the same as the first options I mentioned.

Delete the following registry entry. On my PC this does not exist and its not advisable to mess with the registry unless you know what you are doing.
HKEY_CURRENT_USER\Software\Microsoft\Shared Tools\ProofingTools\1.0\Override\en-US

Repair Office 2007 through the control panel add/remove programs (Change) function.

Various other options of making changes, closing the program and starting it again but all failed.

The only way I found to solve this problem was to do the following
Click Start - Settings - Control Panel - Regional Language Options - Language Tab - Details Button - Add Button - Select "English UK" as the Input Language and click OK, then select English UK from the Default Input Language drop down menu, then Apply. Now you should find when you load the application the spell check is working correctly.
Reply With Quote
  #19  
Old 18-02-2010
Member
 
Join Date: Feb 2010
Posts: 1
re: Auto spell check not working in Word 2007

To turn off automatic spelling checking and automatic grammar checking, follow these steps, as appropriate for your situation.

Word 2007
1. Click the Microsoft Office Button


, and then click Word Options.
2. Click Proofing.
3. Click to clear the Check spelling as you type check box.
4. Click to clear the Check grammar as you type check box.
Important The Check spelling as you type and Check grammar as you type settings will affect any open documents in Word 2007. If other people use the documents, you may want to notify the people that you made this change.

Outlook 2007
1. On the Tools menu, click Options.
2. Click the Spelling tab, and then click Spelling and AutoCorrection.
3. Click to clear the Check spelling as you type check box.
4. Click to clear the Check grammar as you type check box.

PowerPoint 2007
1. Click the Microsoft Office Button


, and then click PowerPoint Options.
2. Click Proofing.
3. Click to clear the Hide spelling errors check box.
4. Click to clear the Check spelling as you type check box.

InfoPath 2007, OneNote 2007, Publisher 2007, SharePoint Designer 2007, and Visio 2007
1. On the Tools menu, click Spelling, and then click Spelling Options.
2. Click to clear the Hide spelling errors check box.
3. Click to clear the Check spelling as you type check box.

Word 2003, Word 2002, and Word 2000
1. On the Tools menu, click Options, and then click the Spelling & Grammar tab.
2. Click to clear the Check spelling as you type check box.
3. Click to clear the Check grammar as you type check box.
Important The Check spelling as you type and Check grammar as you type settings will affect any open documents in Word. If other people use the documents, you may want to notify the people that you made this change.

Outlook 2003 and Outlook 2002
1. Compose a new message.
2. On the Tools menu, click Options and then click the Spelling & Grammar tab..
3. Click to clear the Check spelling as you type check box.
4. Click to clear the Check grammar as you type check box.
Back to the top
PowerPoint 2003, PowerPoint 2002, and PowerPoint 2000
1. On the Tools menu, click Options, and then click the Spelling and style tab.
2. Click to clear the Hide spelling errors check box.
3. Click to clear the Check spelling as you type check box.
Publisher 2003
1. On the Tools menu, point to Spelling, and then click Spelling Options.
2. Click to clear the Hide spelling errors check box.
3. Click to clear the Check spelling as you type check box.
FrontPage 2003, FrontPage 2002, and FrontPage 2000
1. On the Tools menu, click Page Options, and then the General tab.
2. Click to clear the Hide spelling errors check box.
3. Click to clear the Check spelling as you type check box.
OneNote 2003
1. On the Tools menu, click Options, and then click the Spelling category.
2. Click to clear the Hide spelling errors check box.
3. Click to clear the Check spelling as you type check box.
InfoPath 2003
1. On the Tools menu, click Options, and then click the Spelling tab.
2. Click to clear the Hide spelling errors check box.
3. Click to clear the Check spelling as you type check box.
Reply With Quote
  #20  
Old 25-02-2010
Member
 
Join Date: Feb 2010
Posts: 1
re: Auto spell check not working in Word 2007

[quote='garfield-n-odie [MVP];3434217']In your Windows registry, if the key
"HKEY_CURRENT_USER\Software\Microsoft\Shared Tools\Proofing
Tools\1.0\Override" exists, delete it

That key DOES NOT EXIST!!!

Any other suggestions?

Where can I find my Windows registry and this key?
Reply With Quote
  #21  
Old 15-04-2010
Member
 
Join Date: Apr 2010
Posts: 1
My spell check also doesnt pick up spelling errors. It picks up grammar but not spelling, even with my trial version it did not. I use Windows 7 on a laptop and word 2007 is all its ever had. I have looked at all the forums and tried everything. I have tried deleting the key, spell check is not in disabled add ins,i have tried the fix where you use change program, language settings are fine, i have searched thoroughly through options and settings and cannot find an incorrect ticked box anywhere.
Is there any other solution?

never mind, i went into uninstall programs, clicked change microsoft office and instead of changing it i repaired it, and restarted the computer, spell check now works perfectly! that is probably with all of my previous attempts, including deleting the proofing tools 1.0 key.

For those of you who have tried various permutations of all the above suggestions, this combination worked for a client. Both must be performed, and in the order shown:

1. Delete this registry key:
HKEY_CURRENT_USER\Software\Microsoft\SharedTools\ProofingTools\1.0\Override\en-US

2. Repair Office 2007 through the control panel's add/remove programs (Change) function

No reboot was necessary. As soon as the repair completed, the spell checker worked. Note that this worked for MS Word only, and not for MS Outlook.
Reply With Quote
  #22  
Old 10-06-2010
Member
 
Join Date: Jun 2010
Posts: 1
I had a user who's Outlook would only spell check the subject line. I followed this thread trying all the steps and nothing worked. I finally started to change the format from HTML to Rich Text to Plain Text back to HTML all the while trying to see if spell check would find errors and it did. When i openned a new email it was back to the same issue. I changed the default font in Outlook from Sans Serif to Arial and it resolved the problem. I was curious if it was a profile issue and found that if I logged into this users computer the issue wasn't there. Satisfied with the font change I called the issue resolved. Hope this helps someone else.

Thank you for these ideas. This page started me off well. I too tried every one of these fixes - and about 20 other ideas, including deleting the signature, 'repairing' Outlook, checking all the spelling/proofing/language settings, checking the settings in Word, checking the registry keys - none worked.

I was just about to attempt to reinstall Outlook when I thought I would try something, and to my astonishment, it worked, so it might work for you.

I noticed that, when logged in as administrator on my user's computer, the Outlook spell checker would behave perfectly, yet for the user, it just would not work. (It worked on Word ok for her, just not Outlook).

After checking the registry a bunch of times before, I thought I would compare the settings in the administrator account to those of my user. To cut a long story short, I found two keys on the account that did *not* work, that were simply not present in the administrator profile - where it *did* work.

I copied down the details and then deleted the keys, started up Outlook and Hey Presto - Outlook started spelling again. I could barely believe it. I was going on a hunch.

Anyway, here's what I changed. In the following folder:
HKEY_CURRENT_USER\Software\Microsoft\Shared Tools\Proofing Tools\1.0

There was a sub folder called "Office" containing two keys as follows:
OutlookSpellingOptions Reg_DWORD (value = 5)
WordSpellingOptions Reg_DWORD (value = 7)

This "Office" folder hadn't appeared in the registry on the administrator account, so after noting down these details I deleted this "office" folder completely. When I restarted Outlook, the spelling worked.

I don't know how these files got there. All I know is that this worked for me. Good luck!

*Always back up your registry before tinkering - and do so with care!*
Reply With Quote
  #23  
Old 10-07-2010
Member
 
Join Date: Jul 2010
Posts: 1
Office 2007 Word spell check doesn't pick up 'appliction' as an error

can someone explain the solution proferred in respect of the inactive spell checker.
It seems to me that the solution is far too technical for a mere user of word processing software...back up to registry etc? Is there not a simpler explanation and solution that can be posted...or perhaps a step by step talk through of the rectification process?
Reply With Quote
  #24  
Old 04-08-2010
Member
 
Join Date: Aug 2010
Posts: 1
Re: Spell check not working in Office 2007

Mine was the same so just put your old office in and choose custom and just install office share tools to do this make not available till you come to office share feature click that and click run from my computer on the drop down then scrol down till you come to proofing tools click that like above and click english which should be there but make sure everything else is marked with a X then just install hope this helps and if anyone can explain better than me please update thanks good luck
Reply With Quote
  #25  
Old 09-08-2010
Member
 
Join Date: Aug 2010
Posts: 1
I have a document that is 263 pages. The spell check stops exactly at a paragraph on page 208. At the end of the previous paragraph the spell check works but then stops on the first line of the next paragraph. Have tried all options stated on this forum but nothing works. Any suggestions or pointers on what I might be doing wrong>

do I select all of the text of the entire document or just the portion that the spell check does not work?

How do get to Windows Registry?

Also is there a step before Tools because I cannot find the word Tools anywhere on my Word 2007 Home page
Reply With Quote
  #26  
Old 10-08-2010
Member
 
Join Date: Dec 2007
Posts: 1,592
Re: Word 2007 Spell Check Issues

You can try to do a Ctrl+A to Select All, then go to Tools | Language | Set Language. Make sure that the correct language is applied and that the box for "Do not check spelling or grammar" is clear. More clear explanation given below:

Open the Word document,
Press the Ctrl and A keys down to select the entire document:
Tools > Language > Set Language
Uncheck: Do not check spelling or grammar
Uncheck: Detect Language automatically
Click the Default... button

Click: Yes to allow the default language change.
Click: OK

Tools > Options > Spelling & Grammar tab
Verify Check spelling as you type has a check mark (and if your preference) Check grammar as you type has a check mark as well.

Click the Recheck Document button.
Click Yes to the message about resetting the spelling and grammar checker.
Click OK
Reply With Quote
  #27  
Old 10-08-2010
Member
 
Join Date: Dec 2007
Posts: 994
Re: Word 2007 Spell Check Issues

You will need to select all the text of the entire document. In anycase if the above solutions dont work then try closing the word document. In your Windows registry, if the key "HKEY_CURRENT_USER\Software\Microsoft\Shared Tools\Proofing Tools\1.0\Override" exists, delete it and then restart your computer.
Reply With Quote
  #28  
Old 11-08-2010
Member
 
Join Date: Feb 2009
Posts: 455
Re: Word 2007 Spell Check Issues

Quote:
Originally Posted by spiral52 View Post
How do get to Windows Registry?
Its very simple dude. just open the command prompt by pressing Win Key + R, or simply go to start menu and click on RUN. Now type regedit and hit Enter. You will get a new windows where on the left side keep clicking in the following manner:
HKEY_CURRENT_USER
Software
Microsoft
Shared Tools
Proofing Tools
1.0
Override.

Thats it!
Reply With Quote
  #29  
Old 13-08-2010
Member
 
Join Date: Aug 2010
Posts: 3
re: Auto spell check not working in Word 2007

I have msWord 2007. My Auto Spell Check doesn't work and none of the suggested fixes above solved my problem. I pasted the instructions that I tried to follow below. The problem is I'm unable to follow instruction #4 because the checkbox is disabled (and I don't mean it's unchecked). I can neither check or uncheck the box because the feature is greyed out and disabled. If I could enable that checkbox and then select it, I'm pretty sure the automatic spell checker would start working.

1.Click the Office Button, and then click Word Options.
2.Click Proofing.
3.Click AutoCorrect Options.
4.On the AutoCorrect tab, select the Automatically use suggestions from the spelling checker check box.
Reply With Quote
  #30  
Old 11-09-2010
Member
 
Join Date: Sep 2010
Posts: 1
re: Auto spell check not working in Word 2007

Yes...that Worked For Me! As I Was Typing In All Caps. Easy Fix! Thanks
Reply With Quote
Reply

  TechArena Community > Technical Support > Computer Help > Office Help > MS Office Support
Tags: , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Auto spell check not working in Word 2007"
Thread Thread Starter Forum Replies Last Post
How to change language in Word 2007 spell check??? Samarth MS Office Support 1 04-02-2013 01:52 PM
Word 2007 spell check stopped working NGV BalaKrishna MS Office Support 2 04-02-2013 01:00 PM
Word 2007 Spell Check not working. ridergroov MS Office Support 12 19-10-2011 05:02 AM
Word 2007 Spell Check burnedfaceless MS Office Support 2 03-03-2011 01:06 AM
Possible Fix for nonfunctioning spell check in Word 2007? LavRaj MS Office Support 3 09-07-2010 06:45 PM


All times are GMT +5.5. The time now is 06:57 PM.