Go Back   TechArena Community > Technical Support > Computer Help > Office Help > MS Office Support
Become a Member!
Forgot your username/password?
Register Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



How to copy/paste content from Text Editor to Excel without unwanted characters

MS Office Support


Reply
 
Thread Tools Search this Thread
  #1  
Old 02-02-2012
Member
 
Join Date: Nov 2011
Posts: 114
How to copy/paste content from Text Editor to Excel without unwanted characters

I have a formula composed of 3 lines in one cell:

=" IF c_MSISDN_NDC" & $E3 & " IS NOT NULL THEN
utl_file.put_line (l_file_handle, '
'||c_pkg||LOWER(l_curr_table)||'(c_new_point +" & $E3 & ", 1,
c_oper_name);');
utl_file.put_line (l_file_handle, '
'||c_pkg||LOWER(l_curr_table)||'(c_new_point +" & $E3 & ", 2,
c_oper_name);');"

this produces a text string, e.g. as below:

" IF c_MSISDN_NDC70 IS NOT NULL THEN
utl_file.put_line (l_file_handle, '
'||c_pkg||LOWER(l_curr_table)||'(c_new_point +70, 1, c_oper_name);');
utl_file.put_line (l_file_handle, '
'||c_pkg||LOWER(l_curr_table)||'(c_new_point +70, 2, c_oper_name);');"

when i try to copy/paste it into a text editor, i get the following:

" IF c_MSISDN_NDC69 IS NOT NULL THEN
utl_file.put_line (l_file_handle, '
'||c_pkg||LOWER(l_curr_table)||'(c_new_point +69, 1, c_oper_name);');
utl_file.put_line (l_file_handle, '
'||c_pkg||LOWER(l_curr_table)||'(c_new_point +69, 2, c_oper_name);');"

as you can see there are unwanted double-quotes at the beginning and end of the line. this is nothing to do with the texteditor as i get the double-quotes in notepad also (but there i dont get the linebreaks i need so i'm using an alternative). I also tried copy/paste-as-special the results of my formula to another column, then copy/pasting that new column. same result as above, still double-quotes. this issue only seems to occur where a cell contains linebeaks. Any ideas how to not get the double-quotes.

Reply With Quote
  #2  
Old 02-02-2012
Member
 
Join Date: Jul 2011
Posts: 409
Re: How to copy/paste content from Text Editor to Excel without unwanted characters

I think it does have something to do with the receiving application. I got the double quotes in NotePad and UltraEdit (another text editor). But I didn't get them when I pasted into MSWord or WordPad. And then I could copy from MSWord or Wordpad into NotePad and no double quotes showed up. Another option may be to write to a text file directly. Maybe you could use a macro that writes your data.
Reply With Quote
  #3  
Old 02-02-2012
Member
 
Join Date: Jul 2011
Posts: 418
Re: How to copy/paste content from Text Editor to Excel without unwanted characters

There is one more thing you can try here. You can copy the content from Text editor and copy it in Notepad. Then again copy and move the same to Excel. It can be due to additional formatting which is causing the unwanted characters in Excel.
Reply With Quote
Reply

  TechArena Community > Technical Support > Computer Help > Office Help > MS Office Support
Tags: , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "How to copy/paste content from Text Editor to Excel without unwanted characters"
Thread Thread Starter Forum Replies Last Post
Is it possible to copy paste Excel content directly in Gmail Thedevotee MS Office Support 3 19-11-2013 11:08 AM
I cannot do Copy and Paste or Paste Special between Excel Workbooks Acca-OR Windows Software 5 26-04-2012 04:16 AM
How to copy paste content in Merge Cells HangOver MS Office Support 2 27-01-2012 03:13 PM
Copy and paste from word to InDesign - foreign characters Lohitaksha Windows Software 6 13-07-2010 12:18 AM
Copy Text from One Cell to Another in Microsoft Excel without copy & paste Computer_Freak Tips & Tweaks 0 18-03-2009 10:00 PM


All times are GMT +5.5. The time now is 05:41 AM.