Go Back   TechArena Community > Hardware > Motherboard Processor & RAM
Become a Member!
Forgot your username/password?
Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



error 0X80075070 with new Asus Rampage Extreme IV mobo

Motherboard Processor & RAM


Reply
 
Thread Tools Search this Thread
  #1  
Old 27-11-2014
Member
 
Join Date: Oct 2014
Posts: 9
error 0X80075070 with new Asus Rampage Extreme IV mobo
  

I have tried to solve this issue with various method but I am out of luck each time. I had just used my new motherboard Asus Rampage Extreme IV with all my older hardware except for a new Intel Core i7 CPU. My old computer build was woking fine without any problems with any of the hardware. After installing this new motherboard I started getting error code 0X80075070. However after getting into Windows there has been problems with all type of softwares crashing with error "program stopped working". Since all the hardware were working on previous mobo without any issues, so do you think that this new motherboard has got any problems? Thanks

Reply With Quote
  #2  
Old 28-11-2014
Member
 
Join Date: Oct 2005
Posts: 1,206
Re: error 0X80075070 with new Asus Rampage Extreme IV mobo

Have you even tried to install a fresh copy of Windows operating system on your computer? Whenever you are changing any major hardware's such as the motherboard itself, you should first of all try to install a new fresh operating system always. The Chipset driver which is installed on your hard drive or SSD will be for the old mobo that you were using, hence now it is not able to detect the old mobo and giving you all sorts of error message.
Reply With Quote
  #3  
Old 29-11-2014
Member
 
Join Date: Nov 2005
Posts: 1,170
Re: error 0X80075070 with new Asus Rampage Extreme IV mobo

You should also try to update UEFU to the latest version possible. You need to check which version your board has, you can simply find that on the serial number sticker or else you can check within UEFI by going to BIOS and then Advanced > CPU section. Once you get the version then try to update it by using a FAT32 formatted drive in a USB 2.0 port, for this you should use the USB BIOS flashback port. If you have installed new OS and UEFI method is not working then try to load XMP for the memory modules and configure it properly.
Reply With Quote
  #4  
Old 01-12-2014
Member
 
Join Date: May 2008
Posts: 692
Re: error 0X80075070 with new Asus Rampage Extreme IV mobo

Have you checked whether the drive is plugged into one of the black Sata ports properly? If you have any additional hard drive in spare then can you use the same to debug the issue. If you are using any SSD then try to just use the hard drive one one of the black Sata ports. Also, it is always suggested that you should use one of the Sata cables that came with the motherboard. Also, try to test each RAM with memtest and see if thats the culprit.
Reply With Quote
Reply

  TechArena Community > Hardware > Motherboard Processor & RAM
Tags: , , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "error 0X80075070 with new Asus Rampage Extreme IV mobo"
Thread Thread Starter Forum Replies Last Post
Getting debug code error: 00 with Asus Rampage IV Extreme/BF3 Woodward Motherboard Processor & RAM 10 23-03-2012 10:23 PM
ASUS Rampage III Extreme LAN drivers Pritu Motherboard Processor & RAM 3 23-02-2012 07:21 AM
Asus Rampage III Extreme vs. Rampage III Formula Raja Ram Motherboard Processor & RAM 6 31-03-2011 10:28 PM
ROG Extreme OC Kit on Asus Rampage Extreme III Atsushi Motherboard Processor & RAM 5 30-12-2010 05:28 AM


All times are GMT +5.5. The time now is 01:14 AM.