Go Back   TechArena Community > Hardware > Motherboard Processor & RAM
Become a Member!
Forgot your username/password?
Tags Active Topics RSS Search Mark Forums Read

Reply
 
Thread Tools Search this Thread
  #1  
Old 12-05-2014
Member
 
Join Date: May 2014
Posts: 25
Xfast ram not working on ASRock Z77 Extreme6

My friend has a custom build that is loaded with ASRock Z77 Extreme6 motherboard and 8GB ram. We are trying to use Xfast RAm on the same. But is not working. There are no changes in the performance. Most of things are intact and does not put affect on overall output. A number of time I am just getting update to new version message. And I think it is already updated. Can anyone help me to get a proper fix on the same.
Reply With Quote
  #2  
Old 13-05-2014
Member
 
Join Date: Nov 2010
Posts: 420
Re: Xfast ram not working on ASRock Z77 Extreme6

Remove the utility from your system. Go on the official site of Asrock and download the latest version. Then try to run the same. If still it does not work then it means the utility is not compatible with your existing ram module. If you are having multiple sticks then test by removing them one by one. That will help. Most of the time re-installation fixes the problem. The system starts working fine. But if not then just skip using it.
Reply With Quote
  #3  
Old 14-05-2014
Member
 
Join Date: Nov 2010
Posts: 502
Re: Xfast ram not working on ASRock Z77 Extreme6

The issue also occur if there is compatibility problem in your system. Like different software conflicting with each other. You can fix that. You have to remove A-Tune and Xfast both from the system if they are installed. Once done just install back A-Tune and try it. This will resolve the issue. It is necessary that A-tune software must point he correct ram or else the utility will not work properly. So just remove it.
Reply With Quote
Reply

  TechArena Community > Hardware > Motherboard Processor & RAM
Tags: , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Xfast ram not working on ASRock Z77 Extreme6"
Thread Thread Starter Forum Replies Last Post
What is the use of ASRock XFast USB Forever Windows Software 3 03-09-2013 10:25 AM
How to recover BIOS of ASRock P67 Extreme6 Pirateous Motherboard Processor & RAM 5 10-04-2012 01:23 PM
ASRock p67 Extreme4 vs. Extreme6 SawalGuru Motherboard Processor & RAM 5 27-05-2011 10:42 PM
ASRock P67 Extreme6 PCI-E x1 Concern / P67 Motherboard option HatRix Motherboard Processor & RAM 5 30-01-2011 08:05 PM


All times are GMT +5.5. The time now is 06:25 PM.