Results 1 to 9 of 9

Thread: on Gigabyte P55 US3L, how to enable ahci with Agility 3 SSD

  1. #1
    Join Date
    Jun 2012
    Posts
    34

    unsure on Gigabyte P55 US3L, how to enable ahci with Agility 3 SSD

    My system is having Gigabyte P55 US3L motherboard and I have recently installed Agility 3 SSD. I wanted to know if there is a way by which I can enable ahci. I donít have much idea about it and I am not getting a way to enable ahci. Is there anyone using the same components and can help me out with the required steps??

  2. #2
    Join Date
    Nov 2011
    Posts
    199

    Re: on Gigabyte P55 US3L, how to enable ahci with Agility 3 SSD

    As far as I am aware you will have to enable it from bios, if you are using a Windows 7 or Windows Vista-based computer then enter the BIOS setup and change the Serial Advanced Technology Attachment (SATA) mode to Advanced Host Controller Interface (AHCI) from there. Just try it out and let me know it works out for you. If you have any further issues then let me know I will surely try to help you with the possible solution.

  3. #3
    Join Date
    Jun 2012
    Posts
    34

    Re: on Gigabyte P55 US3L, how to enable ahci with Agility 3 SSD

    Ok so now I have changed the Serial Advanced Technology Attachment (SATA) mode to Advanced Host Controller Interface (AHCI) in bios but when I rebooted the system then I got an error message saying the below thing.
    STOP 0x0000007B INACCESSABLE_BOOT_DEVICE
    I donít think I have done anything wrong, I simply did what you suggested. What should I do know? Are you aware of this error??

  4. #4
    Join Date
    Nov 2011
    Posts
    199

    Re: on Gigabyte P55 US3L, how to enable ahci with Agility 3 SSD

    In that case you can follow the below steps:
    1. First set the Serial Advanced Technology Attachment (SATA) mode to IDE and then enable the AHCI driver in the registry.
    2. For enabling driver in the registry close all the Windows-based programs, Go to start and type “regedit” without the quotes in the search box and hit enter.
    3. Now check out for one of the below registry.
    4. HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci
    5. HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\IastorV
    6. When you come across any one of them then right click on the same and choose the Modify option.
    7. Now in the Value data box type 0 and click on ok, after making this change click Exit on the File menu and close the registry.
    8. When you are done with the same then enter the bios setup utility again and change Serial Advanced Technology Attachment (SATA) mode to AHCI again.

    Try it and let me know if that’s helping.

  5. #5
    Join Date
    Jun 2012
    Posts
    34

    Re: on Gigabyte P55 US3L, how to enable ahci with Agility 3 SSD

    I have tried out the same and this time the system booted up fine and I did not have the same error but I feel that the ssd performance is not that good as compared to what it was with IDE enabled. Currently I have enabled AHCI again but I have heard that the ssd should perform better when in AHCI mode. That was the reason I had decided to switch the sata mode to AHCI, correct me if I am wrong? I also wanted to know if there is some solution by which I can get better performance from ssd in AHCI mode. Further help regarding the same will be highly appreciated.

  6. #6
    Join Date
    Nov 2011
    Posts
    199

    Re: on Gigabyte P55 US3L, how to enable ahci with Agility 3 SSD

    Yes the ssd should perform better in AHCI mode as compared to AHCI, I donít know why is it opposite in your case. Can you just let me know the disk transfer rate of the drive? You can check that out by going in to Start >Control Panel > click on System and Maintenance link> click on ďCheck Your Computerís Windows Experience Index Base Score linkĒ. Just post the disk transfer rate that you see there after enabling IDE and AHCI separately so that I can have a better idea of the issue you are facing.

  7. #7
    Join Date
    Jun 2012
    Posts
    34

    Re: on Gigabyte P55 US3L, how to enable ahci with Agility 3 SSD

    This is what I have found as Disk data transfer rate.

    When IDE is enabled Ė 7
    When AHCI is enabled - 6.5
    I was quite sure that I am not getting better performance with AHCI enabled.

    Is there anything else that I can do further or I should simply use the ssd with IDE enabled?? Any suggestion ?

  8. #8
    Join Date
    Nov 2011
    Posts
    199

    Re: on Gigabyte P55 US3L, how to enable ahci with Agility 3 SSD

    I wanted to know which Storage Driver you are using? If you are using something else than Intel Rapid Storage Drivers then download and install the same and see if the disk data transfer rate increases. If it does not then you can try switching sata port as well, if at all both these solutions doesnít make any difference in your case then you should update your Gigabyte P55 US3L bios, just make sure that you are updating the bios to the latest available at Gigabyte official site. Just try out the solutions that I have suggested and I am sure that one of these should help you in getting better disk transfer rate of the drive in AHCI mode as compared to IDE, best of luck.

  9. #9
    Join Date
    Jun 2012
    Posts
    34

    Re: on Gigabyte P55 US3L, how to enable ahci with Agility 3 SSD

    So now I have tried plugging my Agility 3 in to GSATA2_0 port rather than SATA2_0 port and have enabled AHCI as well but I donít see any difference in the performance. I have downloaded and have installed the Intel Rapid Storage Driver as suggested but no avail. Updating the bios to the latest did not help as well, the disk data transfer rate is not going above 6.5 when AHCI is enabled.

Similar Threads

  1. Enable Ahci or Raid mode in Gigabyte GA-P55-UD4P mobo
    By Japheth in forum Official GIGABYTE Motherboard Forum
    Replies: 4
    Last Post: 15-05-2013, 10:56 AM
  2. unable to install windows 7 on Agility 3 in ahci mode
    By Baanbhatt in forum Hardware Peripherals
    Replies: 7
    Last Post: 14-04-2012, 03:01 AM
  3. OCZ Agility 3 Series 60GB SSD works fine on IDE but not on AHCI
    By Run.DK in forum Hardware Peripherals
    Replies: 6
    Last Post: 13-04-2012, 06:42 AM
  4. Gigabyte GA-P55-US3L motherboard got Error at bootup
    By chyarte in forum Motherboard Processor & RAM
    Replies: 3
    Last Post: 10-01-2011, 06:44 PM
  5. Gigabyte GA-P55-US3L motherboard is not working properly
    By NaBaLik16 in forum Motherboard Processor & RAM
    Replies: 4
    Last Post: 10-01-2011, 10:06 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •