Results 1 to 4 of 4

Thread: SSD not recognized in first boot of ASRock H67M-ITX/HT

  1. #1
    Join Date
    Feb 2012
    Posts
    46

    SSD not recognized in first boot of ASRock H67M-ITX/HT

    I am having the ASRock H67M-ITX/HT and all the things in that were running as normal from last many months. But last night, when I was trying to boot my computer then my computer was not able to boot because it failed to detect the SSD. I tried it by restarting some more times but all the times it failed to detect SSD. I checked the connection and there seem to no problem with the connection as well. Now I am wondering that what can m be the reason for this problem. If someone of you can help me then I will really appreciate for that.

  2. #2
    Join Date
    Jul 2011
    Posts
    439

    Re: SSD not recognized in first boot of ASRock H67M-ITX/HT

    As per your explanation, I think that cable that you are using must be changed. Though the connection to both the ends of the cable is perfect but what if cable itself is buggy and cannot provide proper connection to the SSD. So it is worth to try once by changing the cable and see if that solves the problem. Other than this, you must also try by updating the driver to the latest available version. If the existing driver is crashed or outdated then it might show you that effect. Try with both of this and let me know whether this was helpful to you nor not.

  3. #3
    Join Date
    Jul 2011
    Posts
    237

    Re: SSD not recognized in first boot of ASRock H67M-ITX/HT

    It can be a cable issue. You can try checking that first. But if still it is not detecting then one by one check the drive on each slot you have in your system. If it does not work on any of them then it is simple the drive is damage. You have to ask for replacement. SSD's does not have anything special in terms of connectivity. They work like your similar drive. The only difference is in term of storage technology. It must be visible on the system bios once connected. If possible try to post your motherboard model here. Some really old boards does not support SSDs.

  4. #4
    Join Date
    Jul 2011
    Posts
    290

    Re: SSD not recognized in first boot of ASRock H67M-ITX/HT

    The issue can be due to drive mode. Some systems are configured on AHCI mode. You have to switch it back to IDE so that you can use the SSD on your system. You can do the same by changing the mode from bios. This is more easier process. Upon reboot you have to press either Del key or F10 to enter the bios. I am not sure about the exact place but you can try checking in every section. Once it is enable restart your pc and see whether it is detected or not. If not then the drive is damage. You have return from where you had purchased.

Similar Threads

  1. HD 7850 not recognized in Asrock Z77 Extreme 6
    By pele1200 in forum Motherboard Processor & RAM
    Replies: 4
    Last Post: 08-07-2013, 06:48 PM
  2. Radeon HD 5450 on ASRock 945GCM-S not recognized
    By Abhijoot in forum Motherboard Processor & RAM
    Replies: 3
    Last Post: 06-07-2013, 10:43 AM
  3. Replies: 10
    Last Post: 16-04-2012, 11:06 PM
  4. nvidia geforce 8800gt is not recognized by ASRock N68-S UCC
    By Arima in forum Motherboard Processor & RAM
    Replies: 10
    Last Post: 04-09-2011, 03:00 AM
  5. Need information about ASRock H67M
    By Buggers in forum Motherboard Processor & RAM
    Replies: 5
    Last Post: 27-05-2011, 10:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •