Results 1 to 2 of 2

Thread: ASRock Extreme4 Gen3 motherboard not accepting mouse and keyboard

  1. #1
    Join Date
    Feb 2012

    ASRock Extreme4 Gen3 motherboard not accepting mouse and keyboard

    I am building my own PC and I have brought all the parts that I will need. I am using an ASRock Extreme4 Gen3 motherboard on which I will attach all the parts. I assembled the whole system first time and tried switching on the computer. Everything worked fine except for one thing; mouse and the keyboard arenít being accepted by the motherboard. I have assembled many computers before this and I have worked on many motherboards including MSI, Gigabyte, Asus and many more. But this problem has occurred first time in my whole working experience. I know many times the motherboard doesnít accept graphic card or hard disk, but I had never seen a motherboard rejecting a mouse and a keyboard. They work fine in the BIOS menu but as soon as I exit it, they again get rejected by the motherboard. I am using generic mouse and keyboard. So I disable the USB port, this enables the keyboard in the system but still I couldnít mouse to work outside BIOS. I thought that ASRock motherboard must be incompatible with a specific brand of mouse and keyboard, but it seems like none of the mouse and keyboard is being accepted. I have tried five different brands of mouse and keyboard and none of them worked.

  2. #2
    Join Date
    Jul 2011

    Re: ASRock Extreme4 Gen3 motherboard not accepting mouse and keyboard

    Check the PCBs of your motherboard, there will be a jumper behind the USB port. You can try changing its position. I suggest that you should try 1-2 to 2-3 or vice versa. Did you check the version of BIOS the motherboard has? Maybe it is the BIOS that are causing the problem. You can try updating the current BIOS of your motherboard. If still the problem is not solved you can try downgrading the BIOS. Find the stable and proper version that will work with your motherboard and flash it in your motherboard. When flashing the BIOS, see to it that you use a pen drive of FAT32 system and not the NTFS system. The motherboard will support pen drive only up to 4 GB. So do not use external hard drives. After the BIOS are flashed, you can disable the USB mouse and keyboard ports. It will accept the generic mouse and keyboard. Chances are that the keyboard might not be accepted by the motherboard again. But I can confirm that the mouse will work properly. Once on the login screen of Windows, you can use on-screen keyboard to login. Once Windows is started, you can connect the keyboard and update the drivers it requires. Now your keyboard will too start working. If you face this problem again, that is, when you plug out the mouse and keyboard, you will need to overclock the motherboard. I canít say overclocking will help, but you can try it out.

Similar Threads

  1. Asrock z68 Extreme4 Gen3 motherboard showing Error Code: 0x19
    By Harry-Son in forum Motherboard Processor & RAM
    Replies: 6
    Last Post: 13-04-2012, 09:03 PM
  2. Asrock p67 Extreme4 Gen3 cannot detect graphic card
    By Mansukh in forum Motherboard Processor & RAM
    Replies: 3
    Last Post: 09-02-2012, 07:24 AM
  3. ASRock Z68 Extreme4 GEN 3 V/s Asus P8Z68-V PRO GEN3
    By Sheehan in forum Motherboard Processor & RAM
    Replies: 5
    Last Post: 06-02-2012, 04:17 PM
  4. Asrock p67 extreme4 (gen3) not booting from dvd drive
    By MashyB in forum Motherboard Processor & RAM
    Replies: 6
    Last Post: 06-01-2012, 02:20 PM
  5. AsRock Z68 Extreme3 (gen3) vs. AsRock Z68 Extreme4 (gen3)
    By Parnell in forum Motherboard Processor & RAM
    Replies: 2
    Last Post: 13-10-2011, 11:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts