Go Back   TechArena Community > Hardware > Motherboard Processor & RAM
Become a Member!
Forgot your username/password?
Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



Asus U80A, Intel wifi link 1000, radio won't turn on

Motherboard Processor & RAM


Reply
 
Thread Tools Search this Thread
  #1  
Old 20-11-2011
Member
 
Join Date: Nov 2011
Posts: 4
Asus U80A, Intel wifi link 1000, radio won't turn on
  

Last week I put a wanted ad on craigslist for broken laptops. A guy responds with an ASUS U80A in great condition with red dots all over the screen. I agree to $100, he brings me the laptop but no charger. It has 17% battery. I pay him $80 and agree to pay the other $20 upon receiving the charger. Well, I get home, boot it up and connect to the internet. I downloaded new drivers for the display adapter, motherboard, bios, etc. Everything is great except for the red dots. I reboot the computer, the drivers didn't help, so I popped the battery out, took it apart to check connections or see if I could find a cracked solder joint on the motherboard, put it back together and it wouldn't boot past the splash screen. I wasn't sure if I left something unhooked or if the battery was dead, so I took it apart yet again. Everything was hooked up, so I put it back together and got the same results. I figured the battery was dead, so anyway...a week later I get the charger...boot the laptop and one of the speakers isn't working and neither is the wifi. I took it back apart only to discover that the pair of speaker wires going to the left speaker had gotten wrapped around a screw as I was putting it back together and broke in 2 (and were touching the motherboard). I didn't even remove the wireless adapter from the board when I had it apart...just unhooked the antenna wires from it.

Anyway, I've updated the drivers for the wireless adapter, took it completely out and put it back in, checked and doublechecked the antenna connections and I still can't enable the radio. The card shows up in device manager and says the device is working properly. When I push the function key to turn wifi on, the graphic pops up on the screen showing a wireless antenna (no red x or anything on it) and no matter how many times I push the button the graphic doesn't change. The wireless indicator led doesn't light up, and windows says that the wifi radio isn't enabled. I hit the button again, windows still says it's not enabled.

Basically, I just want to know if I fried the adapter or the motherboard. I don't have another mini pci-e wifi adapter to swap into it at the moment. Is there a way to tell? Any help would be great, thanks

Reply With Quote
  #2  
Old 20-11-2011
Member
 
Join Date: Nov 2011
Posts: 4
Re: Asus U80A, Intel wifi link 1000, radio won't turn on

Just thought I might add that the spot the speaker wires touched the board and the wireless card are about 6 inches apart...and I don't KNOW for a fact that they made contact with the board, but that's the only logical thing I can come up with
Reply With Quote
  #3  
Old 20-11-2011
Member
 
Join Date: May 2006
Posts: 2,328
Re: Asus U80A, Intel wifi link 1000, radio won't turn on

It might be possible that the wireless card might be short circuited with the speaker wires lying. In any case, you should get it to a laptop repair shop and only then you would able to know where the problem lies, by the look of it and reading your post, it sure seems to be a hardware problem and something needs to be replaced.
Reply With Quote
  #4  
Old 20-11-2011
Member
 
Join Date: Nov 2011
Posts: 4
Re: Asus U80A, Intel wifi link 1000, radio won't turn on

Well, I fixed the wires, but...I'd like to figure it out without taking it to a repair shop. I was just wondering if there were any way to run diagnostics on the wifi adapter...I mean, if nothing else I'm sure I'll run across another laptop with a wifi adapter I can swap in. If that doesn't fix it, it will be in the motherboard. Any programs out there that will run hardware through some tests and see what's up? Are there any programs out there that I could use to try and turn the wifi on?
Reply With Quote
  #5  
Old 21-11-2011
Member
 
Join Date: Nov 2011
Posts: 4
Re: Asus U80A, Intel wifi link 1000, radio won't turn on

Wifi issue resolved. Aparently there WAS in fact a hardware switch on the side of the laptop...I never noticed it when taking the thing apart, so I assumed it had a software switch only. Anyway, I found the switch while pulling the card reader out. It was in the ON position, but wouldn't switch to off, so I took it back apart and surely enough I had put the case back off with the DIP switch in the OFF position and the case switch in the ON position. Wireless is working, but I had been in the registry earlier making changes earlier and my LED doesn't light up. Guess I gotta figure out what I changed and fix it lol
Reply With Quote
  #6  
Old 22-11-2011
Member
 
Join Date: Jun 2011
Posts: 443
Re: Asus U80A, Intel wifi link 1000, radio won't turn on

Are you talking about the laptop led. If not then please explain the issue in detail. Registry changes can be restored back by running System restore from safe mode. It is a easy option. Just press F8 on boot and go in Safe mode. Run system restore. If there any startup issue insert windows boot disc and run startup repair.
Reply With Quote
Reply

  TechArena Community > Hardware > Motherboard Processor & RAM
Tags: , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Asus U80A, Intel wifi link 1000, radio won't turn on"
Thread Thread Starter Forum Replies Last Post
Not getting accurate speed with Intel wifi link 1000 bgn PCI card on Hp laptop Tazz L Networking & Security 5 21-03-2011 10:14 AM
Unstable speed on wifi link 1000 bgn on my hp laptop Elazar Portable Devices 4 08-01-2011 11:43 PM
Not able to get Wireless-N from Intel WiFi Link 1000 BGN VeGA BacK Networking & Security 3 07-12-2010 07:20 AM
Radio Test Failed but switch is on - Intel WiFi Link 5100 AGN reetus Networking & Security 4 13-04-2010 04:21 PM
D-Link DIR-655, Intel WiFi Link 4965a/g/n, Vista and 802.11n CaspaR Windows Vista Network 1 14-07-2007 04:03 PM


All times are GMT +5.5. The time now is 11:09 AM.