Results 1 to 6 of 6

Thread: MSI CX620 + Radeon HD 5470 is making ATI Catalyst center non-responsive

  1. #1
    Join Date
    Jan 2012
    Posts
    66

    MSI CX620 + Radeon HD 5470 is making ATI Catalyst center non-responsive

    I have installed Radeon HD 5470 in my MSI CX620 and have installed the latest ATI GPU drivers as well but I donít know why ATI Catalyst center is acting non-responsive. I am just not able to switch graphics and I am using Intel Graphics currently. I donít think I have missed out anything during the installation but I donít know what is causing the issue. is there anything I can try out to get the ATI Catalyst center working?? Any help regarding this will be appreciated

  2. #2
    Join Date
    Jun 2011
    Posts
    2,008

    Re: MSI CX620 + Radeon HD 5470 is making ATI Catalyst center non-responsive

    I think you have not made a clean installation of the driver, anyways just uninstall the driver and use driver sweeper for removing the instance of the old driver completely and then install the latest driver for it. You can get the latest ATI GPU driver from MSI and if that does not help then you can try one from AMD. Just try making a clean installation of the driver and post back the result you get so that I can have a better idea of your issue. If you face the same issue further then let me know I will try to help you with other possible solution.

  3. #3
    Join Date
    May 2011
    Posts
    1,938

    Re: MSI CX620 + Radeon HD 5470 is making ATI Catalyst center non-responsive

    I am not sure but I think that there is something wrong with the card, if you have other working machine where you can check out the card then try it now and see how it works. If you get the same response there as well then you will have to get the card checked or replaced. If it is working fine there might be something wrong with your system and you can try running System File Checker tool and check out if thatís helping. For running System File Checker tool you need to follow the below steps:
    1. Go to start> Search box> type cmd and hit enter.
    2. Now you will get a new window and you might have to enter administrator password for proceeding.
    3. So after entering the admin details type sfc /scannow and hit enter.
    4. Just try it out and see if the issue is getting solved that way. If that does not then there might be something wrong with the card and you will have to get it checked.

  4. #4
    Join Date
    Jul 2011
    Posts
    1,483

    Re: MSI CX620 + Radeon HD 5470 is making ATI Catalyst center non-responsive

    I have just checked about the same and have found one mentioning that this issue is with Microsoft .NetFramework to resolve the same you need to uninstall all Microsoft .NetFramework entries. When you are done with the same then you should proceed installing ALL Microsoft .NetFramework applications from 1.0 to 3.5SP1 and make sure that you are following the order. Once you are done with these things then you can try making a clean installation of the latest driver. I am really not sure if it is actually related to Microsoft .NetFramework or not but I think that you can give it a try in such condition.

  5. #5
    Join Date
    May 2011
    Posts
    1,131

    Re: MSI CX620 + Radeon HD 5470 is making ATI Catalyst center non-responsive

    Yes it appears to be more of a software issue and not hardware, I think the card is fine but there is something wrong at the software end. Since installing the latest drivers have not helped you out then you can try downloading and installing a couple of old drivers for your card and check them out. There are possibilities one of them might help you out, if it does not then contact the manufacturer and address him the issue that you are facing along with the solution you have tried and check out what they have to say about this issue.

  6. #6
    Join Date
    Jan 2012
    Posts
    66

    Re: MSI CX620 + Radeon HD 5470 is making ATI Catalyst center non-responsive

    Hey guys I have tried testing out the card in other working machine and it is working fine there. So the issue is not with the card and it is with my system. I have tried running System File Checker tool, installing latest Microsoft .NetFramework, latest and recommended updates via windows update but these things are just not helping. while looking after a solution for this issue in other forums I have found some people mentioning that reinstalling windows had helped them out, so I will give that a try and will let you know if it is actually helpful or not.

Similar Threads

  1. Replies: 6
    Last Post: 14-08-2011, 10:52 PM
  2. Will 3D work on ATI Mobility Radeon HD 5470
    By Baldwin in forum Monitor & Video Cards
    Replies: 5
    Last Post: 01-06-2011, 10:23 AM
  3. Replies: 4
    Last Post: 23-03-2011, 07:37 AM
  4. Ati radeon HD 5470 settings for best display
    By dONGsUN in forum Video Games
    Replies: 2
    Last Post: 10-10-2010, 06:46 AM
  5. Ati radeon hd 5470 1gb driver download
    By bRISEIS in forum Monitor & Video Cards
    Replies: 3
    Last Post: 05-10-2010, 05:58 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •