Go Back   TechArena Community > Hardware > Monitor & Video Cards
Become a Member!
Forgot your username/password?
Register Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



Half-Life 2 not showing the high shadows option on GeForce GT 555M and Radeon HD 3000

Monitor & Video Cards


Reply
 
Thread Tools Search this Thread
  #1  
Old 20-04-2012
Member
 
Join Date: Feb 2012
Posts: 75
Half-Life 2 not showing the high shadows option on GeForce GT 555M and Radeon HD 3000
  

I have just bought Half-Life 2 game recently and want to tell you that I am actually like the graphic of the game but there is something I need here on , actually when I go to the option in the half life 2 there is no option for the high shadows . this is wired because I have this two graphic card on my laptop GeForce GT 555M and Radeon HD 3000, its looks as if the game is reading the wrong device for graphics settings. I run the game on the nvidia card but the high option is not available and disabling the intel device wont helping as laptop is not working without it , so it should be running . I am tired now looked everywhere but I am not able to find any option to this. is there anyone here can help me on this , how can I enable high shadows on the Half-Life 2. I am using the Driver version is 285.38 and tried different versions as well

Thanks

Reply With Quote
  #2  
Old 20-04-2012
Member
 
Join Date: Feb 2012
Posts: 68
Re: Half-Life 2 not showing the high shadows option on GeForce GT 555M and Radeon HD 3000

Well I have the same problem . I too have this an Nvidia GT555m graphics card in my laptop that I just recently got. For some cause I can see the high shadows option on th e Half Life 2 .I'm very much certain this is a issue is with how the source engine sense the graphics card on to the laptop. because this GPU contain the Nvidia Optimus power saving technology that means that switches to the Intel integrated card while not in a graphically demanding application . I believe that the Source engine is sensing the graphics card as the Intel integrated graphics card and it is therefore removed the option of the high shadows in the game . obviously this is not the a issue with Optimus in fact changing as the game runs extremely very effortlessly at a high graphics setting, thus the Nvidia GPU is obviously in fact being used. If I go in game and enter "mat_info" into the console, the game show the message that is "Description: Intel Integrated Graphics" thus the game is evidently reading the wrong graphics card. Many user are appear to be having this same issue and none of them have any kind of solution to this .
Reply With Quote
  #3  
Old 20-04-2012
Member
 
Join Date: Feb 2012
Posts: 84
Re: Half-Life 2 not showing the high shadows option on GeForce GT 555M and Radeon HD 3000

This is really very odd. The problem that I am having . I can set the whole thing to High or else Very High, apart from for the high shadows option . I can allow Motion Blur , HDR and Anti-aliasing, although I can't allow dynamic shadows. Like to mention that on the Portal 2 there is the dynamic shadows, although this option is not available in the hl2, Half life 2 or gmod, etc. Well it's just the nvidia ion 2 and generally for testing purposes, however what it s looks like ? Is there a issue on the nvidia optimus? I looked twice on the the nvidia settings, in order that hl2.exe is using the ion 2 instead of the intel card. The GPU activity symbol shows that the hl2.exe is using the nvidia gpu. The game runs very smooth, even with motion blur as well as hdr + AA 2x. although i need to enable the dynamic shadows. I installed the lastest nvidia drivers and the directx 11. I am using win7 64bit thank you in advance
Reply With Quote
  #4  
Old 20-04-2012
Member
 
Join Date: May 2011
Posts: 393
Re: Half-Life 2 not showing the high shadows option on GeForce GT 555M and Radeon HD 3000

I am not sure about this but I feel the graphic card I s nothing to do with this . issue If you not able to choose the setting you needed from the in game menu that mean you have to try verifying the game cache to be certain there are no corrupt files. Just tell me is that you are playing with the Direct X8? You can just set shadow detail to high only in the Direct X9 if I am not wrong . To replace to DX9 type -dxlevel 90 otherwise 95 in the launch option of the Half-Life 2 game or on the Episodes just try it . check the hardware level on the advance settings it's set at dxlevel 7. Well I have did mine and it is showing 9.0 or whatever. No idea why, even at the time of launched with -dxlevel is 90,95 or 98. Looks to me the Optimus is probably the issue .i donít know how to sort it. That problem is that in case i start it without any launch options the hardware dxlevel is 9.0 and the software is 9.0+, if i start it on the -dxlevel 95 the hardware dxlevel is 7, I really hate that and software is 9.0+ 1. I am very certain it is optimus, which is making this issue , because there are lot of people with the Nvidia card has this problem , I guess that all optimus-powered cards have these issue .
Reply With Quote
  #5  
Old 20-04-2012
Member
 
Join Date: Jun 2011
Posts: 411
Re: Half-Life 2 not showing the high shadows option on GeForce GT 555M and Radeon HD 3000

That must be reallt very frustrating , just tell me of this problem is occurring usually at the time you trying to launching HL2 on the directx 8 mode . just find the label "Hardware Direct-X level " that will be in the advanced settings. As far as I know the 8.0 and 8.1 do not have the High shadow options, and perhaps 9.0 doesnít have it as well but the 9.0+ must have it though. Just see if this is helping to you or not try to add a shortcut . this can be done by going to the Half-Life 2 properties on the steam Windows - right click in the game then on the properties " dxlevel 95" without quotes Will it change to DX 9.0+ ?. it will be 9.0+, although high shadows will not be available. the issue is only that CSS detects nvidia but the game don't
Reply With Quote
  #6  
Old 20-04-2012
Member
 
Join Date: Jul 2011
Posts: 349
Re: Half-Life 2 not showing the high shadows option on GeForce GT 555M and Radeon HD 3000

There is no way that you can turn off intel card as it's is needed for outputting picture on the screen. the only way that you can make nvidia card to output the picture is you have to plug the laptop to an external display so making nvidia responsible for picture, however just in the external monitor by the way the laptop screen is shut off in the meantime . although I'm still very in quiet of the information about the CSS and HL2DM have high shadows with no external monitors when the HL2 don't. Games on the similar engine detect different video cards. No idea how this is possible ? Nvidia, did not figured it out yet.
Reply With Quote
  #7  
Old 25-04-2012
Member
 
Join Date: Jan 2011
Posts: 75
Re: Half-Life 2 not showing the high shadows option on GeForce GT 555M and Radeon HD 3000

Well to the system to switch among the IGP as well as the discrete GPU, the user has to manually modify the a setting on th e NVIDIA Switchable Graphics Applet. This applet has the simple menu that shows the user to choose the ideal graphics core based on a certain workload. Once the selection has been made that the he system BIOS (SBIOS) shows the interface that the Switchable Graphics driver use to allow or stop the discrete GPU. That will make the Switchable Graphics driver work as the proxy display driver as well as shuttles OS information to the driver associated with the active and enabled display device. Once the active graphics core (IGP or GPU) is prepared to output a rendered scene or image, a hardware multiplexer (device that provides switching of multiple inputs) can switch to the right show device as directed by the Switchable Graphics driver so as for the video output to be sent to the specified show. The use of many multiplexers ends up in a particularly sophisticated layout. Multiplexers need extra house on the motherboard and dramatically increase trace lengths as every show interface must be routed twice. This ends up in a decrease in signal integrity and needs extra PCB layers that escort added price and complexity. is NVidia correct in their claim that a manual switchable override needs the employment of multiplexers? i'm not a hardware skilled by any suggests that, however it seems from my reading of the text that the hardware mechanism must be re-engineered to permit for a manual switch while not extra hardware pieces? maybe this is often contributing to the silence on Optimus? And yes, I do agree the employment of an HDMI monitor is simply a workaround, and not an answer within the truest sense of the term.
Reply With Quote
Reply

  TechArena Community > Hardware > Monitor & Video Cards
Tags: , , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Half-Life 2 not showing the high shadows option on GeForce GT 555M and Radeon HD 3000"
Thread Thread Starter Forum Replies Last Post
How to install NVIDIA GeForce GT 555M on Windows Vista Sumeet.Pra Monitor & Video Cards 1 17-04-2012 12:15 PM
How to Overclock NVidia GeForce GT 555M in Dell XPS 17 DeepakTij Monitor & Video Cards 10 10-12-2011 01:16 PM
NVIDIA GeForce GT 555M Overclocking Indudep Overclocking & Computer Modification 8 04-12-2011 09:54 PM
frame rate drops while playing Half-Life and Counter-Strike 1.6 using NVIDIA GeForce GT 540M quamar Monitor & Video Cards 8 16-10-2011 10:15 PM
Half Life 2 Crashes With Geforce 8600M QABIL Video Games 3 24-04-2009 07:32 PM


All times are GMT +5.5. The time now is 12:14 AM.